Re: [PATCH v2 5/8] regulator: AXP20x: Add support for regulators subsystem

2014-03-17 Thread Krzysztof Kozlowski
> > AXP202 and AXP209 come with two synchronous step-down DC-DCs and five > LDOs. This patch introduces basic support for those regulators. > > Signed-off-by: Carlo Caione > --- > drivers/regulator/Kconfig| 7 + > drivers/regulator/Makefile | 1 + > drivers/regulator/

[PATCH v2 00/15] iio: adc: at91 cleanups and atmel_tsadcc removal

2014-03-17 Thread Alexandre Belloni
This patch set is a followup of my previous series: iio: adc: at91 fixes 1-3) The first 3 patches are cleaning up the patform_data used for at91_adc. 4-5) Then touchscreen support for older ADCs is added, this allows to use that for the sam9m10g45ek. 6) Following those modifications, the ma

[PATCH v2 14/15] Input: atmel_tsadcc: remove driver

2014-03-17 Thread Alexandre Belloni
The atmel_tsadcc driver is not used anymore, it has been replaced by at91_adc so remove it. Signed-off-by: Alexandre Belloni Acked-by: Dmitry Torokhov --- MAINTAINERS | 6 - drivers/input/touchscreen/Kconfig| 12 -- drivers/input/touchscreen/Makefile

[PATCH v2 15/15] ARM: at91/dt: at91-cosino_mega2560 remove useless tsadcc node

2014-03-17 Thread Alexandre Belloni
The tsadcc node is useless as it doesn't refer to anything and the touchscreen is handled by the adc0 node. Signed-off-by: Alexandre Belloni Cc: Rodolfo Giometti --- arch/arm/boot/dts/at91-cosino_mega2560.dts | 5 - 1 file changed, 5 deletions(-) diff --git a/arch/arm/boot/dts/at91-cosino_

[PATCH v2 13/15] ARM: at91: remove atmel_tsadcc from sama5_defconfig

2014-03-17 Thread Alexandre Belloni
atmel_tsadcc has been removed, stop selecting it. Signed-off-by: Alexandre Belloni --- arch/arm/configs/sama5_defconfig | 1 - 1 file changed, 1 deletion(-) diff --git a/arch/arm/configs/sama5_defconfig b/arch/arm/configs/sama5_defconfig index dc3881e07630..869fa18ebeb2 100644 --- a/arch/arm/co

[PATCH v2 08/15] ARM: at91: sam9rl: add at91_adc to support adc and touchscreen

2014-03-17 Thread Alexandre Belloni
The ADC clock needs to be defined to enable the at91_adc driver. It is defined to the same speed that is used for atmel_tsadcc. Signed-off-by: Alexandre Belloni --- arch/arm/mach-at91/at91sam9rl.c | 7 +++ arch/arm/mach-at91/at91sam9rl_devices.c | 85 + 2

[PATCH v2 10/15] ARM: at91: sam9g45: switch from atmel_tsadcc to at91_adc

2014-03-17 Thread Alexandre Belloni
atmel_tsadcc is not allowing to use the remaining ADC channels while at91_adc does. Completely switch to at91_adc and remove the tsadcc platform_data for at91sam9g45 and at91sam9g45 based boards. Signed-off-by: Alexandre Belloni --- arch/arm/configs/at91sam9g45_defconfig | 3 +- arch/arm/mach

[PATCH v2 12/15] ARM: at91: remove atmel_tsadcc platform_data

2014-03-17 Thread Alexandre Belloni
Signed-off-by: Alexandre Belloni --- arch/arm/mach-at91/board.h | 3 --- include/linux/platform_data/atmel.h | 7 --- 2 files changed, 10 deletions(-) diff --git a/arch/arm/mach-at91/board.h b/arch/arm/mach-at91/board.h index 6c08b341167d..4e773b55bc2d 100644 --- a/arch/arm/mach-at9

[PATCH v2 09/15] ARM: at91: sam9rlek add touchscreen support through at91_adc

2014-03-17 Thread Alexandre Belloni
at91_adc now supports reading a touchscreen for ADCs without a TSMR register. Enable touchscreen support through at91_adc. This allows to use both a touchscreen and the remaining ADC channel at the same time. Signed-off-by: Alexandre Belloni --- arch/arm/mach-at91/board-sam9rlek.c | 14 +

[PATCH v2 06/15] iio: adc: at91: remove unused include from include/mach

2014-03-17 Thread Alexandre Belloni
That include file is now only used by the at91_adc driver, remove it from include/mach for better driver separation. Signed-off-by: Alexandre Belloni --- arch/arm/mach-at91/include/mach/at91_adc.h | 120 - drivers/iio/adc/at91_adc.c | 103 +

[PATCH v2 04/15] iio: adc: at91_adc: Add support for touchscreens without TSMR

2014-03-17 Thread Alexandre Belloni
Old ADCs, as present on the sam9rl and the sam9g45 don't have a TSMR register and the touchscreen support should be handled differently. Signed-off-by: Alexandre Belloni --- arch/arm/mach-at91/include/mach/at91_adc.h | 13 ++ drivers/iio/adc/at91_adc.c | 200

[PATCH v2 05/15] ARM: at91: sam9m10g45ek: Add touchscreen support through at91_adc

2014-03-17 Thread Alexandre Belloni
at91_adc now supports reading a touchscreen for ADCs without a TSMR register. Enable touchscreen support through at91_adc. This allows to use both a touchscreen and the remaining ADC channel at the same time. Also, lower the clock for the ADC as it allows to have more stable reads and this is the

[PATCH v2 07/15] iio: adc: at91: add sam9rl support

2014-03-17 Thread Alexandre Belloni
Signed-off-by: Alexandre Belloni --- drivers/iio/adc/at91_adc.c | 18 ++ 1 file changed, 18 insertions(+) diff --git a/drivers/iio/adc/at91_adc.c b/drivers/iio/adc/at91_adc.c index a51b8badbf8e..3b5bacd4d8da 100644 --- a/drivers/iio/adc/at91_adc.c +++ b/drivers/iio/adc/at91_adc.c

[PATCH v2 01/15] ARM: at91: sam9g45: remove unused platform_data

2014-03-17 Thread Alexandre Belloni
num_channels and registers are not used anymore since they are defined inside the at91_adc driver and assigned by matching the id_table. Also, remove the mach/at91_adc.h include that is not necessary anymore. Signed-off-by: Alexandre Belloni Acked-by: Jonathan Cameron --- arch/arm/mach-at91/at

[PATCH v2 02/15] ARM: at91: sam9260: remove unused platform_data

2014-03-17 Thread Alexandre Belloni
num_channels and registers are not used anymore since they are defined inside the at91_adc driver and assigned by matching the id_table. Also, remove the mach/at91_adc.h include that is not necessary anymore. Signed-off-by: Alexandre Belloni Acked-by: Jonathan Cameron --- arch/arm/mach-at91/at

[PATCH v2 03/15] iio: adc: at91: cleanup platform_data

2014-03-17 Thread Alexandre Belloni
num_channels and registers are not used anymore since they are defined inside the driver and assigned by matching the id_table. Also, struct at91_adc_reg_desc is now only used inside the driver. Signed-off-by: Alexandre Belloni Acked-by: Jonathan Cameron --- drivers/iio/adc/at91_adc.c

[PATCH v2 11/15] ARM: at91: sam9rl: switch from atmel_tsadcc to at91_adc

2014-03-17 Thread Alexandre Belloni
atmel_tsadcc is not allowing to use the remaining ADC channels while at91_adc does. Completely switch to at91_adc and remove the tsadcc platform_data for at91sam9rl and at91sam9rl based boards. Signed-off-by: Alexandre Belloni --- arch/arm/configs/at91sam9rl_defconfig | 3 +- arch/arm/mach-at

Re: [PATCH v2 15/15] ARM: at91/dt: at91-cosino_mega2560 remove useless tsadcc node

2014-03-17 Thread Rodolfo Giometti
On Mon, Mar 17, 2014 at 02:57:08PM +0100, Alexandre Belloni wrote: > The tsadcc node is useless as it doesn't refer to anything and the touchscreen > is handled by the adc0 node. > > Signed-off-by: Alexandre Belloni > Cc: Rodolfo Giometti Acked. Rodolfo -- GNU/Linux Solutions

[PATCH 00/22] atmel_mxt_ts patches, already signed-off

2014-03-17 Thread Nick Dyer
Hi Dimitry- Here is a set of patches for atmel_mxt_ts that you've already signed-off. I've rebased them against the most recent mainline and made some very minor changes such as INIT_COMPLETION->reinit_completion. thanks Nick Dyer -- To unsubscribe from this list: send the line "unsubscribe lin

Re: [PATCH v2 5/8] regulator: AXP20x: Add support for regulators subsystem

2014-03-17 Thread Mark Brown
On Sat, Mar 15, 2014 at 04:43:42PM +0100, Carlo Caione wrote: > AXP202 and AXP209 come with two synchronous step-down DC-DCs and five > LDOs. This patch introduces basic support for those regulators. This is mostly fine apart from the things Krzysztof mentioned and... > +static int axp20x_set_dcd

[PATCH 07/22] Input: atmel_mxt_ts - wait for CHG after bootloader resets

2014-03-17 Thread Nick Dyer
From: Benson Leung Rather than msleep for MXT_RESET_TIME and MXT_FWRESET_TIME during the transition to bootloader mode and the transition back from app, wait for the CHG assert to indicate that the transition is done. This change replaces the msleep with a wait for completion that the mxt_interr

[PATCH 14/22] Input: atmel_mxt_ts - read and report bootloader version

2014-03-17 Thread Nick Dyer
Signed-off-by: Nick Dyer Acked-by: Benson Leung Acked-by: Yufeng Shen Signed-off-by: Dmitry Torokhov --- drivers/input/touchscreen/atmel_mxt_ts.c | 26 ++ 1 file changed, 26 insertions(+) diff --git a/drivers/input/touchscreen/atmel_mxt_ts.c b/drivers/input/touchscree

[PATCH 10/22] Input: atmel_mxt_ts - implement CRC check for configuration data

2014-03-17 Thread Nick Dyer
The configuration is stored in NVRAM on the maXTouch chip. When the device is reset it reports a CRC of the stored configuration values. Therefore it isn't necessary to send the configuration on each probe - we can check the CRC matches and avoid a timeconsuming backup/reset cycle. Signed-off-by:

[PATCH 08/22] Input: atmel_mxt_ts - make wait-after-reset period compatible with all chips

2014-03-17 Thread Nick Dyer
From: Iiro Valkonen The delay before the chip can be accessed after reset varies between different chips in maXTouch family. Waiting for an interrupt and a T6 status message with the RESET bit set is a better behaviour. Signed-off-by: Nick Dyer Acked-by: Benson Leung Acked-by: Yufeng Shen Sig

[PATCH 09/22] Input: atmel_mxt_ts - improve error reporting and debug

2014-03-17 Thread Nick Dyer
- Add error messages for probe errors - Report type in invalid object type - Tweak some other debug output messages Signed-off-by: Nick Dyer Acked-by: Benson Leung Acked-by: Yufeng Shen Signed-off-by: Dmitry Torokhov --- drivers/input/touchscreen/atmel_mxt_ts.c | 33 ++

[PATCH 02/22] Input: atmel_mxt_ts - improve T19 GPIO keys handling

2014-03-17 Thread Nick Dyer
* The mapping of the GPIO numbers into the T19 status byte varies between different maXTouch chips. Some have up to 7 GPIOs. Allowing a keycode array of up to 8 items is simpler and more generic. So replace #define with configurable number of keys which also allows the removal of is_tp.

[PATCH 16/22] Input: atmel_mxt_ts - improve bootloader progress output

2014-03-17 Thread Nick Dyer
By implementing a frame counter, print out fewer debug messages (the firmware may contain hundreds of frames). Signed-off-by: Nick Dyer Acked-by: Benson Leung Acked-by: Yufeng Shen Signed-off-by: Dmitry Torokhov --- drivers/input/touchscreen/atmel_mxt_ts.c | 8 +++- 1 file changed, 7 inse

[PATCH 01/22] Input: atmel_mxt_ts - remove unnecessary platform data

2014-03-17 Thread Nick Dyer
It is not necessary to download these values to the maXTouch chip on every probe, since they are stored in NVRAM. It makes life difficult when tuning the device to keep them in sync with the config array/file, and requires a new kernel build for minor tweaks. These parameters only represent a tiny

[PATCH 06/22] Input: atmel_mxt_ts - wait for CHG assert in mxt_check_bootloader

2014-03-17 Thread Nick Dyer
From: Benson Leung The driver should not immediately read bootloader status when in Application Update Mode. The CHG line will assert when the device has made a state transition and is ready to report a new status via i2c. This change adds a wait for completion in mxt_check_bootloader, and chang

[PATCH 03/22] Input: atmel_mxt_ts - return IRQ_NONE when interrupt handler fails

2014-03-17 Thread Nick Dyer
Signed-off-by: Nick Dyer Acked-by: Benson Leung Acked-by: Yufeng Shen Signed-off-by: Dmitry Torokhov --- drivers/input/touchscreen/atmel_mxt_ts.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/input/touchscreen/atmel_mxt_ts.c b/drivers/input/touchscreen/atmel_mx

[PATCH 20/22] Input: atmel_mxt_ts - rename pressure to amplitude to match spec

2014-03-17 Thread Nick Dyer
Signed-off-by: Nick Dyer Acked-by: Benson Leung Acked-by: Yufeng Shen Signed-off-by: Dmitry Torokhov --- drivers/input/touchscreen/atmel_mxt_ts.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/input/touchscreen/atmel_mxt_ts.c b/drivers/input/touchscreen/at

[PATCH 11/22] Input: atmel_mxt_ts - download device config using firmware loader

2014-03-17 Thread Nick Dyer
The existing implementation which encodes the configuration as a binary blob in platform data is unsatisfactory since it requires a kernel recompile for the configuration to be changed, and it doesn't deal well with firmware changes that move values around on the chip. Atmel define an ASCII format

[PATCH 05/22] Input: atmel_mxt_ts - select FW_LOADER for firmware code

2014-03-17 Thread Nick Dyer
Signed-off-by: Nick Dyer Acked-by: Benson Leung Acked-by: Yufeng Shen Signed-off-by: Dmitry Torokhov --- drivers/input/touchscreen/Kconfig | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/input/touchscreen/Kconfig b/drivers/input/touchscreen/Kconfig index 961d58d..c2c0593 100644 --

[PATCH 15/22] Input: atmel_mxt_ts - implement bootloader frame retries

2014-03-17 Thread Nick Dyer
Signed-off-by: Nick Dyer Acked-by: Benson Leung Acked-by: Yufeng Shen Signed-off-by: Dmitry Torokhov --- drivers/input/touchscreen/atmel_mxt_ts.c | 27 --- 1 file changed, 20 insertions(+), 7 deletions(-) diff --git a/drivers/input/touchscreen/atmel_mxt_ts.c b/drivers

[PATCH 17/22] Input: atmel_mxt_ts - add check for incorrect firmware file format

2014-03-17 Thread Nick Dyer
Atmel supplies firmware files in ASCII HEX format (.enc) which must be converted before they can be loaded by kernel driver. Try to detect the error and print a friendly error message rather than feeding junk to the bootloader. Signed-off-by: Nick Dyer Acked-by: Benson Leung Acked-by: Yufeng She

[PATCH 21/22] Input: atmel_mxt_ts - rename touchscreen defines to include T9

2014-03-17 Thread Nick Dyer
This avoids confusion with the newer T100 touchscreen object. Signed-off-by: Nick Dyer Acked-by: Benson Leung Acked-by: Yufeng Shen Signed-off-by: Dmitry Torokhov --- drivers/input/touchscreen/atmel_mxt_ts.c | 46 1 file changed, 23 insertions(+), 23 deletions

[PATCH 13/22] Input: atmel_mxt_ts - add additional bootloader addresses

2014-03-17 Thread Nick Dyer
Move bootloaders reads/writes into separate functions. Instead of switching client->addr, define new field bootloader_addr in mxt_data. Implement lookup calculation for bootloader addresses. Signed-off-by: Nick Dyer Acked-by: Benson Leung Acked-by: Yufeng Shen Signed-off-by: Dmitry Torokhov --

[PATCH 18/22] Input: atmel_mxt_ts - read screen config from chip

2014-03-17 Thread Nick Dyer
By reading the touchscreen configuration from the settings that the maXTouch chip is actually using, we can remove some platform data. The matrix size is not used for anything, and results in some rather confusing code to re-read it because it may change when configuration is downloaded, so don't

[PATCH 12/22] Input: atmel_mxt_ts - calculate and check CRC in config file

2014-03-17 Thread Nick Dyer
By validating the checksum, we can identify if the configuration is corrupt. In addition, this patch writes the configuration in a short series of block writes rather than as many individual values. Signed-off-by: Nick Dyer Acked-by: Benson Leung Acked-by: Yufeng Shen Signed-off-by: Dmitry Tor

[PATCH 19/22] Input: atmel_mxt_ts - use deep sleep mode when stopped

2014-03-17 Thread Nick Dyer
By writing zero to both the active and idle cycle times the maXTouch device is put into a deep sleep mode when it consumes minimal power. It is unnecessary to change the configuration of any other objects (for example to disable T9 touchscreen). It is counterproductive to reset the chip on resume,

[PATCH 04/22] Input: atmel_mxt_ts - define helper functions for size and instances

2014-03-17 Thread Nick Dyer
From: Daniel Kurtz These two object table entry fields are reported 1 less than their value. When used, however, we always want the actual size and instances. To keep the object size and instances 1-byte fields, and thus preserve the object-table struct's 6-byte packed alignment, add some conven

[PATCH 22/22] Input: atmel_mxt_ts - handle multiple input reports in one message

2014-03-17 Thread Nick Dyer
Signed-off-by: Nick Dyer Acked-by: Benson Leung Acked-by: Yufeng Shen Signed-off-by: Dmitry Torokhov --- drivers/input/touchscreen/atmel_mxt_ts.c | 36 +--- 1 file changed, 28 insertions(+), 8 deletions(-) diff --git a/drivers/input/touchscreen/atmel_mxt_ts.c b/dr

Yet another ALPS dualpoint TP protocol in preparation

2014-03-17 Thread Václav Krpec
Hello everybody, yes, I'm another poor soul who ended up with an ALPS touchpad. More specifically (although not much helpfully), it's a device ALPS manufactured for my Toshiba Portege Z30-A-12N. I've written to both ALPS and Toshiba with pleads for tech. documentation, but (not surprisingly) Tosh

Re: [PATCH v5 0/9] Use regmap+devm+DT in pm8xxx input drivers

2014-03-17 Thread Stephen Boyd
ping? On 03/11/14 10:50, Stephen Boyd wrote: > ping? > > On 03/04/14 10:34, Stephen Boyd wrote: >> These patches move the pm8xxx input drivers over to use devm_* APIs >> and regmap. This breaks the dependency of these drivers on the pm8xxx >> specific read/write calls and also simplifies the probe

Re: [PATCH] hid: fix bug destroying hidraw device files after parent

2014-03-17 Thread Jiri Kosina
On Mon, 17 Mar 2014, Fernando Luis Vázquez Cao wrote: > > I have slightly modified the patch title to make sure that it's obvious > > that what it fixes is actually a WARN_ON() splat. > > Thank you. > > Any chance we can get this to Linus before 3.14 comes out? > According to Linus, rc7 may be t

Re: [PATCH] hid: fix bug destroying hidraw device files after parent

2014-03-17 Thread Fernando Luis Vázquez Cao
(2014年03月18日 08:42), Jiri Kosina wrote: On Mon, 17 Mar 2014, Fernando Luis Vázquez Cao wrote: I have slightly modified the patch title to make sure that it's obvious that what it fixes is actually a WARN_ON() splat. Thank you. Any chance we can get this to Linus before 3.14 comes out? Accordi