[Problem] Samsung 700T1C Elan USB Touchpad not detected as touchpad

2014-07-20 Thread Daniel Heckenberg
Hello, I'm experiencing the following issue which I'd like to help resolve. Please let me know if there's any other information or action that I can provide. I'll send additional information in subsequent mails to avoid the majordomo length block. Many thanks, Daniel [1] Summary: Samsung 700T1C

Re: [Problem] Samsung 700T1C Elan USB Touchpad not detected as touchpad

2014-07-20 Thread Daniel Heckenberg
And some info from X: xinput -list ⎡ Virtual core pointerid=2[master pointer (3)] ⎜ ↳ Virtual core XTEST pointer id=4[slave pointer (2)] ⎜ ↳ Wacom ISDv4 EC Pen stylus id=9[slave pointer (2)] ⎜ ↳ Atmel Atmel maXTouch

Re: [PATCH] drivers: Let several drivers depends on HAS_IOMEM for 'devm_ioremap_resource'

2014-07-20 Thread Chen Gang
On 07/19/2014 02:02 AM, Chen Gang wrote: >> 2014-07-18 18:51 GMT+08:00 Richard Weinberger : >>> Am 18.07.2014 12:44, schrieb Chen Gang: On 07/18/2014 03:35 PM, Richard Weinberger wrote: > Am 18.07.2014 02:36, schrieb Chen Gang: >> >> On 07/18/2014 02:09 AM, Richard Weinberger wrote

Re: [PATCH] drivers: Let several drivers depends on HAS_IOMEM for 'devm_ioremap_resource'

2014-07-20 Thread Chen Gang
On 07/20/2014 04:38 PM, Chen Gang wrote: > On 07/19/2014 02:02 AM, Chen Gang wrote: >>> 2014-07-18 18:51 GMT+08:00 Richard Weinberger : Am 18.07.2014 12:44, schrieb Chen Gang: > On 07/18/2014 03:35 PM, Richard Weinberger wrote: >> Am 18.07.2014 02:36, schrieb Chen Gang: >>> >>>

Re: [PATCH] drivers: Let several drivers depends on HAS_IOMEM for 'devm_ioremap_resource'

2014-07-20 Thread Richard Weinberger
Am 20.07.2014 10:38, schrieb Chen Gang: > On 07/19/2014 02:02 AM, Chen Gang wrote: >>> 2014-07-18 18:51 GMT+08:00 Richard Weinberger : Am 18.07.2014 12:44, schrieb Chen Gang: > On 07/18/2014 03:35 PM, Richard Weinberger wrote: >> Am 18.07.2014 02:36, schrieb Chen Gang: >>> >>

Re: [PATCH] Input: fix defuzzing logic

2014-07-20 Thread David Herrmann
Hi On Sun, Jul 20, 2014 at 1:49 AM, Dmitry Torokhov wrote: > We attempt to remove noise from coordinates reported by devices in > input_handle_abs_event(), unfortunately, unless we were dropping the > event altogether, we were ignoring the adjusted value and were passing > on the original value i

Re: [PATCH] drivers: Let several drivers depends on HAS_IOMEM for 'devm_ioremap_resource'

2014-07-20 Thread Chen Gang
On 07/20/2014 05:45 PM, Richard Weinberger wrote: > > > Am 20.07.2014 10:38, schrieb Chen Gang: >> On 07/19/2014 02:02 AM, Chen Gang wrote: 2014-07-18 18:51 GMT+08:00 Richard Weinberger : > Am 18.07.2014 12:44, schrieb Chen Gang: >> On 07/18/2014 03:35 PM, Richard Weinberger wrote: >

Re: [PATCH] drivers: Let several drivers depends on HAS_IOMEM for 'devm_ioremap_resource'

2014-07-20 Thread Chen Gang
On 07/20/2014 05:51 PM, Chen Gang wrote: > On 07/20/2014 05:45 PM, Richard Weinberger wrote: >> >> >> Am 20.07.2014 10:38, schrieb Chen Gang: >>> On 07/19/2014 02:02 AM, Chen Gang wrote: > 2014-07-18 18:51 GMT+08:00 Richard Weinberger : >> Am 18.07.2014 12:44, schrieb Chen Gang: >>> On

[PATCH] staging: input: sunkbd.c: Fix coding style

2014-07-20 Thread Bivolaru Catalin
Fix coding style with regard to missing spaces after , and the column limit that was violated after the first change. Signed-off-by: Bivolaru Catalin --- The change was tested only by compilation. diff --git a/drivers/input/keyboard/sunkbd.c b/drivers/input/keyboard/sunkbd.c index dc6bb9d..25ba

Re: [PATCH 2/2] iio: exynos-adc: add experimental touchscreen support

2014-07-20 Thread Jonathan Cameron
On 20/07/14 14:49, Jonathan Cameron wrote: On 18/07/14 20:29, Arnd Bergmann wrote: This adds support for the touchscreen on Samsung s3c64xx. The driver is completely untested but shows roughly how it could be done, following the example of the at91 driver. Hi Arnd, Cc'd linux-input and Dmitry

Re: [PATCH] input: Add support for Wacom protocol 4 serial tablets

2014-07-20 Thread Hans de Goede
Hi, On 07/20/2014 01:08 AM, Dmitry Torokhov wrote: > Hi Hans, > > On Sat, Jul 19, 2014 at 06:38:40PM +0200, Hans de Goede wrote: >> Recent version of xf86-input-wacom no longer support directly accessing >> serial tablets. Instead xf86-input-wacom now expects all wacom tablets to >> be driven by

[PATCH v2] input: Add support for Wacom protocol 4 serial tablets

2014-07-20 Thread Hans de Goede
Recent version of xf86-input-wacom no longer support directly accessing serial tablets. Instead xf86-input-wacom now expects all wacom tablets to be driven by the kernel and to show up as evdev devices. This has caused old serial Wacom tablets to stop working for people who still have such tablets

Re: [PATCH] staging: input: sunkbd.c: Fix coding style

2014-07-20 Thread Joe Perches
On Sun, 2014-07-20 at 15:01 +0300, Bivolaru Catalin wrote: > Fix coding style with regard to missing spaces after , and the column limit > that was violated after the first change. Some checkpatch errors should be ignored. These are some of them. This change doesn't make it easier to read or to

Re: [PATCH] Input: fix defuzzing logic

2014-07-20 Thread Henrik Rydberg
Hi Dmitry, > We attempt to remove noise from coordinates reported by devices in > input_handle_abs_event(), unfortunately, unless we were dropping the > event altogether, we were ignoring the adjusted value and were passing > on the original value instead. > > Reviewed-by: Andrew de los Reyes >

[RFC PATCH] Input: evdev - drop redundant list-locking

2014-07-20 Thread David Herrmann
evdev->client_list is rcu-protected. There is no need to have a separate spinlock just for the list. Either one is good enough, so lets drop the spinlock. Signed-off-by: David Herrmann --- Hi I stumbled across this one when doing some evdev reviews. Maybe I'm missing something obvious and I shou

Re: [RFC PATCH] Input: evdev - drop redundant list-locking

2014-07-20 Thread Dmitry Torokhov
On Sun, Jul 20, 2014 at 08:48:12PM +0200, David Herrmann wrote: > evdev->client_list is rcu-protected. There is no need to have a > separate spinlock just for the list. Either one is good enough, so lets > drop the spinlock. > > Signed-off-by: David Herrmann > --- > Hi > > I stumbled across this

Re: [RFC PATCH] Input: evdev - drop redundant list-locking

2014-07-20 Thread David Herrmann
Hi On Sun, Jul 20, 2014 at 8:54 PM, Dmitry Torokhov wrote: > On Sun, Jul 20, 2014 at 08:48:12PM +0200, David Herrmann wrote: >> evdev->client_list is rcu-protected. There is no need to have a >> separate spinlock just for the list. Either one is good enough, so lets >> drop the spinlock. >> >> Si

Re: [RFC PATCH] Input: evdev - drop redundant list-locking

2014-07-20 Thread Dmitry Torokhov
On Sun, Jul 20, 2014 at 09:00:02PM +0200, David Herrmann wrote: > Hi > > On Sun, Jul 20, 2014 at 8:54 PM, Dmitry Torokhov > wrote: > > On Sun, Jul 20, 2014 at 08:48:12PM +0200, David Herrmann wrote: > >> evdev->client_list is rcu-protected. There is no need to have a > >> separate spinlock just f

[PATCH v2] Input: evdev - drop redundant list-locking

2014-07-20 Thread David Herrmann
evdev->client_list is rcu-protected. We need the client_lock only to protect against concurrent writes. However, all paths that access client_list already lock evdev->mutex. Therefore, drop client_lock and use evdev->mutex as list-protection. This also drops several helper functions that are calle

Re: [PATCH] staging: input: sunkbd.c: Fix coding style

2014-07-20 Thread Dmitry Torokhov
On Sun, Jul 20, 2014 at 08:52:54AM -0700, Joe Perches wrote: > On Sun, 2014-07-20 at 15:01 +0300, Bivolaru Catalin wrote: > > Fix coding style with regard to missing spaces after , and the column limit > > that was violated after the first change. > > Some checkpatch errors should be ignored. > >

Re: [PATCH 2/2] iio: exynos-adc: add experimental touchscreen support

2014-07-20 Thread Dmitry Torokhov
On Sun, Jul 20, 2014 at 02:51:37PM +0100, Jonathan Cameron wrote: > On 20/07/14 14:49, Jonathan Cameron wrote: > >On 18/07/14 20:29, Arnd Bergmann wrote: > >>This adds support for the touchscreen on Samsung s3c64xx. > >>The driver is completely untested but shows roughly how > >>it could be done, f

Re: [PATCH v5] Input: Add driver for Microchip's CAP1106

2014-07-20 Thread Dmitry Torokhov
On Tue, Jul 15, 2014 at 01:30:59PM +0200, Daniel Mack wrote: > This patch adds a driver for Microchips CAP1106, an I2C driven, 6-channel > capacitive touch sensor. > > For now, only the capacitive buttons are supported, and no specific > settings that can be tweaked for individual channels, except

Re: [PATCH 1/1] input: remove unnecessary break after goto

2014-07-20 Thread Dmitry Torokhov
On Tue, Jul 08, 2014 at 06:37:36PM +0200, Fabian Frederick wrote: > Cc: Dmitry Torokhov > Cc: Paul Gortmaker > Cc: linux-input@vger.kernel.org > Signed-off-by: Fabian Frederick Applied, thank you. > --- > drivers/input/misc/keyspan_remote.c | 1 - > 1 file changed, 1 deletion(-) > > diff --g

Re: [PATCH] Input: st-keyscan - Fix 'defined but not used' compiler warnings

2014-07-20 Thread Dmitry Torokhov
On Tue, Jul 08, 2014 at 10:47:58AM +0200, Tobias Klauser wrote: > Add #ifdef CONFIG_PM_SLEEP around keyscan_supend() and keyscan_resume() to fix > the following compiler warnings occuring if CONFIG_PM_SLEEP is unset: > > + /scratch/kisskb/src/drivers/input/keyboard/st-keyscan.c: warning: > 'key

Re: [PATCH RESEND 2/5] Input: uinput - uinput_validate_absbits() cleanup

2014-07-20 Thread Dmitry Torokhov
On Sat, Jul 19, 2014 at 03:10:42PM +0200, David Herrmann wrote: > This moves basic checks and setup from uinput_setup_device() into > uinput_validate_absbits() to make it easier to use. This way, we can call > it from other places without copying the boilerplate code. > > Reviewed-by: Peter Hutter

Re: [PATCH RESEND 3/5] Input: uinput - add UI_GET_VERSION ioctl

2014-07-20 Thread Dmitry Torokhov
On Sat, Jul 19, 2014 at 03:10:43PM +0200, David Herrmann wrote: > This ioctl is the counterpart to EVIOCGVERSION and returns the > uinput-version the kernel was compiled with. > > Reviewed-by: Peter Hutterer > Signed-off-by: David Herrmann Applied, thank you. > --- > drivers/input/misc/uinput

Re: [PATCH RESEND 0/5] Evdev Extensions

2014-07-20 Thread Dmitry Torokhov
Hi David, On Sat, Jul 19, 2014 at 03:10:40PM +0200, David Herrmann wrote: > Hi Dmitry > > I posted all these ~2 months ago, but haven't seen any comments from you. > Seeing > that you switched jobs (congratulations, btw!), Thanks :) >I guess you were quite busy the > last few weeks. Hence, her

Re: [PATCH RESEND 4/5] Input: uinput - add new UINPUT_DEV_SETUP ioctl

2014-07-20 Thread Dmitry Torokhov
Hi David, On Sat, Jul 19, 2014 at 03:10:44PM +0200, David Herrmann wrote: > This adds a new ioctl UINPUT_DEV_SETUP that replaces the old device setup > method (by write()'ing "struct uinput_user_dev" to the node). The old > method is not easily extendable and requires huge payloads. Furthermore, >

[PATCH] Input: cap1106 - allow changing key mapping from userspace

2014-07-20 Thread Dmitry Torokhov
Wire up support for EVIOC{G|S}KEYCODE to allow users change key mappings from userspace. Signed-off-by: Dmitry Torokhov --- Just compiled, not tested. drivers/input/keyboard/cap1106.c | 8 +++- 1 file changed, 7 insertions(+), 1 deletion(-) diff --git a/drivers/input/keyboard/cap1106.c b/

Re: [PATCH RESEND 4/5] Input: uinput - add new UINPUT_DEV_SETUP ioctl

2014-07-20 Thread David Herrmann
Hi On Mon, Jul 21, 2014 at 3:01 AM, Dmitry Torokhov wrote: > Hi David, > > On Sat, Jul 19, 2014 at 03:10:44PM +0200, David Herrmann wrote: >> This adds a new ioctl UINPUT_DEV_SETUP that replaces the old device setup >> method (by write()'ing "struct uinput_user_dev" to the node). The old >> metho