[PATCH 2/2] HID: logitech-dj: break out testing of validity of dj_device

2014-08-22 Thread Benjamin Tissoires
We can do once the test of the validity of the dj_device, which removes some duplicated code in various functions. Signed-off-by: Benjamin Tissoires --- drivers/hid/hid-logitech-dj.c | 35 +++ 1 file changed, 11 insertions(+), 24 deletions(-) diff --git a/drivers

[PATCH 1/2] HID: logitech-dj: prevent false errors to be shown

2014-08-22 Thread Benjamin Tissoires
Commit "HID: logitech: perform bounds checking on device_id early enough" unfortunately leaks some errors to dmesg which are not real ones: - if the report is not a DJ one, then there is not point in checking the device_id - the receiver (index 0) can also receive some notifications which can b

Re: [PATCH 1/1] HID: usbhid: add usb_clear_halt determination for next hid_start_in

2014-08-22 Thread Alan Stern
On Sat, 23 Aug 2014, vichy wrote: > from your patch, I have some questions: > a. in Alan's version, if both HID_CLEAR_HALT and HID_RESET_PENDING are > set, hid_reset will both "clear ep halt" and "reset devcie". > But in original one, even HID_CLEAR_HALT and HID_RESET_PENDING are > both set, hid_r

Re: [PATCH 1/1] HID: usbhid: add usb_clear_halt determination for next hid_start_in

2014-08-22 Thread vichy
hi alan and all: > I recently posted (but did not submit) a more comprehensive solution to > this and other related problems. For example, HID devices typically > run at low speed or full speed. When attached through a hub to an EHCI > controller (very common on modern systems), unplugging the d

Re: [PATCH v2] doc: dt/bindings: input: Fix drv260x binding document

2014-08-22 Thread Felipe Balbi
On Fri, Aug 22, 2014 at 12:12:19PM -0500, Dan Murphy wrote: > Update the drv260x dt binding document: > - Change the node name to the devices function not the > device name. > - Add vbat-supply to the example. > - Fix indentation of the example. > > Signed-off-by: Dan Murphy Reviewed-by: Felipe

[PATCH v2] doc: dt/bindings: input: Fix drv260x binding document

2014-08-22 Thread Dan Murphy
Update the drv260x dt binding document: - Change the node name to the devices function not the device name. - Add vbat-supply to the example. - Fix indentation of the example. Signed-off-by: Dan Murphy --- v2 - Address comments on indentation, node declaration, add vbat-supply, removed descripti

Re: [PATCH] doc: dt/bindings: input: Fix drv260x binding document

2014-08-22 Thread Murphy, Dan
Felipe On 08/22/2014 09:45 AM, Balbi, Felipe wrote: > Hi, > > On Fri, Aug 22, 2014 at 09:25:13AM -0500, Murphy, Dan wrote: >> Felipe >> >> On 08/22/2014 09:15 AM, Balbi, Felipe wrote: >>> On Fri, Aug 22, 2014 at 09:12:21AM -0500, Dan Murphy wrote: Update the drv260x dt binding document:

Re: [PATCH] doc: dt/bindings: input: Fix drv260x binding document

2014-08-22 Thread Felipe Balbi
Hi, On Fri, Aug 22, 2014 at 09:25:13AM -0500, Murphy, Dan wrote: > Felipe > > On 08/22/2014 09:15 AM, Balbi, Felipe wrote: > > On Fri, Aug 22, 2014 at 09:12:21AM -0500, Dan Murphy wrote: > >> Update the drv260x dt binding document: > >> - Change the node name to the devices function not the > >>

Re: [GIT PULL] HID

2014-08-22 Thread Benjamin Tissoires
On Aug 22 2014 or thereabouts, Markus Trippelsdorf wrote: > On 2014.08.22 at 03:00 -0500, Jiri Kosina wrote: > > On Fri, 22 Aug 2014, Markus Trippelsdorf wrote: > > > > > > HID: logitech: perform bounds checking on device_id early enough > > > > > > The commit above (ad3e14d7c5268c2e) cause

Re: [PATCH] doc: dt/bindings: input: Fix drv260x binding document

2014-08-22 Thread Murphy, Dan
Felipe On 08/22/2014 09:15 AM, Balbi, Felipe wrote: > On Fri, Aug 22, 2014 at 09:12:21AM -0500, Dan Murphy wrote: >> Update the drv260x dt binding document: >> - Change the node name to the devices function not the >> device name. >> - Add vbat-supply to the example. >> - Fix indentation of the ex

Re: [PATCH] doc: dt/bindings: input: Fix drv260x binding document

2014-08-22 Thread Felipe Balbi
On Fri, Aug 22, 2014 at 09:12:21AM -0500, Dan Murphy wrote: > Update the drv260x dt binding document: > - Change the node name to the devices function not the > device name. > - Add vbat-supply to the example. > - Fix indentation of the example. > > Signed-off-by: Dan Murphy > --- > .../devicetr

[PATCH] input: misc: drv260x: add check for ERM mode and LRA Libraries

2014-08-22 Thread Dan Murphy
Add a check to ensure that LRA libraries are not mixed with the ERM mode. If ERM mode and the Library is empty "OR" the LRA library then exit. As the LRA and empty libraries are not applicable for the ERM actuator. Signed-off-by: Dan Murphy --- drivers/input/misc/drv260x.c |8 1 f

[PATCH] doc: dt/bindings: input: Fix drv260x binding document

2014-08-22 Thread Dan Murphy
Update the drv260x dt binding document: - Change the node name to the devices function not the device name. - Add vbat-supply to the example. - Fix indentation of the example. Signed-off-by: Dan Murphy --- .../devicetree/bindings/input/ti,drv260x.txt | 19 ++- 1 file chan

[PATCH] input: misc: drv260x remove defines not used

2014-08-22 Thread Dan Murphy
Removing some #defines that are not and should never be used pertaining to I2C. Removing: define DRV260X_ALLOWED_R_BYTES 25 define DRV260X_ALLOWED_W_BYTES 2 define DRV260X_MAX_RW_RETRIES 5 define DRV260X_I2C_RETRY_DELAY 10 Signed-off-by: Dan Murphy --- drivers/input/misc/drv260x.c |5 --

Re: [PATCH 1/1] HID: usbhid: add usb_clear_halt determination for next hid_start_in

2014-08-22 Thread Alan Stern
On Fri, 22 Aug 2014, vichy wrote: > hi Jiri: > > 2014-08-22 15:45 GMT+08:00 Jiri Kosina : > > On Fri, 22 Aug 2014, CheChun Kuo wrote: > > > >> HID IR device will not response to any command send from host when > >> it is finishing paring and tring to reset itself. During this period of > >>

Re: [RESEND PATCH 6/7] mfd: cros_ec: Instantiate sub-devices from device tree

2014-08-22 Thread Javier Martinez Canillas
Hello Lee, On 08/21/2014 04:25 PM, Lee Jones wrote: >> >> static const struct mfd_cell cros_devs[] = { >> -{ >> -.name = "cros-ec-keyb", >> -.id = 1, >> -.of_compatible = "google,cros-ec-keyb", >> -}, >> -{ >> -.name = "cros-ec-i2c-tun

Re: [RESEND PATCH 5/7] mfd: cros_ec: wait for completion of commands that return IN_PROGRESS

2014-08-22 Thread Javier Martinez Canillas
Hello Lee, Thanks a lot for your feedback. On 08/21/2014 04:21 PM, Lee Jones wrote: > On Wed, 20 Aug 2014, Javier Martinez Canillas wrote: > >> From: Andrew Bresticker >> >> When an EC command returns EC_RES_IN_PROGRESS, we need to query >> the state of the EC until it indicates that it is no

Re: [PATCH 1/1] HID: usbhid: add usb_clear_halt determination for next hid_start_in

2014-08-22 Thread vichy
hi Jiri: 2014-08-22 15:45 GMT+08:00 Jiri Kosina : > On Fri, 22 Aug 2014, CheChun Kuo wrote: > >> HID IR device will not response to any command send from host when >> it is finishing paring and tring to reset itself. During this period of >> time, usb_cleaer_halt will be fail and if hid_star

RE: [PATCH v4 4/14] input: cyapa: add cyapa key function interfaces in sysfs system

2014-08-22 Thread Dudley Du
> -Original Message- > From: Dmitry Torokhov [mailto:dmitry.torok...@gmail.com] > Sent: Friday, August 22, 2014 2:29 AM > To: Dudley Du > Cc: Rafael J. Wysocki; Benson Leung; Patrik Fimml; > linux-input@vger.kernel.org; > linux-ker...@vger.kernel.org; Dudley Du > Subject: Re: [PATCH v4 4

RE: [PATCH v4 1/14] input: cyapa: re-architecture driver to support multi-trackpads in one driver

2014-08-22 Thread Dudley Du
Dmitry, Thanks for your feedback. Thanks, Dudley > -Original Message- > From: Dmitry Torokhov [mailto:dmitry.torok...@gmail.com] > Sent: Friday, August 22, 2014 2:21 AM > To: Dudley Du > Cc: Rafael J. Wysocki; Benson Leung; Patrik Fimml; > linux-input@vger.kernel.org; > linux-ker...@vge

Re: [GIT PULL] HID

2014-08-22 Thread Markus Trippelsdorf
On 2014.08.22 at 03:00 -0500, Jiri Kosina wrote: > On Fri, 22 Aug 2014, Markus Trippelsdorf wrote: > > > > HID: logitech: perform bounds checking on device_id early enough > > > > The commit above (ad3e14d7c5268c2e) causes the bounds checking to always > > fail on my monolithic kernel (with

Re: [GIT PULL] HID

2014-08-22 Thread Jiri Kosina
On Fri, 22 Aug 2014, Markus Trippelsdorf wrote: > > HID: logitech: perform bounds checking on device_id early enough > > The commit above (ad3e14d7c5268c2e) causes the bounds checking to always > fail on my monolithic kernel (without modules): > > ... > [2.922617] usb 4-2: new full-spe

Re: [GIT PULL] HID

2014-08-22 Thread Markus Trippelsdorf
On 2014.08.21 at 12:43 -0500, Jiri Kosina wrote: > HID: logitech: perform bounds checking on device_id early enough The commit above (ad3e14d7c5268c2e) causes the bounds checking to always fail on my monolithic kernel (without modules): ... [2.922617] usb 4-2: new full-speed USB device

Re: [PATCH 1/1] HID: usbhid: add usb_clear_halt determination for next hid_start_in

2014-08-22 Thread Jiri Kosina
On Fri, 22 Aug 2014, CheChun Kuo wrote: > HID IR device will not response to any command send from host when > it is finishing paring and tring to reset itself. During this period of > time, usb_cleaer_halt will be fail and if hid_start_in soon again, we > has the possibility trap in infi

[PATCH 1/1] HID: usbhid: add usb_clear_halt determination for next hid_start_in

2014-08-22 Thread CheChun Kuo
HID IR device will not response to any command send from host when it is finishing paring and tring to reset itself. During this period of time, usb_cleaer_halt will be fail and if hid_start_in soon again, we has the possibility trap in infinite loop. Signed-off-by: CheChun Kuo --- dri