Re: [PATCH v2] Input - mt: Fix input_mt_get_slot_by_key

2015-04-24 Thread Henrik Rydberg
Peter, It may be a long time ago now, but we had very vocal discussions regarding the MT protocol back then, and I am quite sure all the subtleties are well understood. In order to fully appreciate the simplicity of the protocol, one only needs to stop misintepreting it. In order to do that,

Re: [PATCH v8] psmouse - focaltech pass finger width to userspace

2015-04-24 Thread Dmitry Tunin
I see that I did not change that here. Width can be in state-width or fingers[finger]-width I think latter is mere correct.It should be that way in this patch. I moved ot back and forth and tested. Noticed no difference. 24.04.2015 13:44, Dmitry Tunin пишет: Hi, Some comments below. If it

Re: [PATCH v8] psmouse - focaltech pass finger width to userspace

2015-04-24 Thread Dmitry Tunin
Hi, Some comments below. If it is not a problem that width values are outdated as soon as there are two or more fingers on the touchpad, I think the change is good. Regards, Mathias Am 24.04.2015 um 01:15 schrieb Dmitry Tunin: Focaltech touchpads report finger width in packet[5]

[PATCH v9] psmouse - focaltech pass finger width to userspace

2015-04-24 Thread Dmitry Tunin
Focaltech touchpads report finger width in packet[5] of absolute packet. Range for width in raw format is 0x10 - 0x70. Second half-byte is always 0. 0xff is reported, when a large contact area is detected. This can be handled in userspace. Signed-off-by: Dmitry Tunin hanipouspi...@gmail.com ---

Re: [PATCH v8] psmouse - focaltech pass finger width to userspace

2015-04-24 Thread Mathias Gottschlag
Hi, Some comments below. If it is not a problem that width values are outdated as soon as there are two or more fingers on the touchpad, I think the change is good. Regards, Mathias Am 24.04.2015 um 01:15 schrieb Dmitry Tunin: Focaltech touchpads report finger width in packet[5] of absolute

Re: Turn Sony motion controller into RGB led

2015-04-24 Thread Pavel Machek
Hi! I did not yet figure out how to get sensor data from the controller, but it works rather well as a RGB led. Hi Pavel, From what I've read, the motion controller only sends sensor data when connected via bluetooth. Otherwise it should be in report 1 with the buttons and other data.

RE: [RESEND PATCH V2 1/2] input: misc: da9063: OnKey driver

2015-04-24 Thread Opensource [Steve Twiss]
On 17 April 2015 17:16 Dmitry Torokhov wrote On Fri, Apr 17, 2015 at 01:03:20PM +0100, S Twiss wrote: From: Steve Twiss stwiss.opensou...@diasemi.com Add OnKey driver support for DA9063 Isn't this almost to the letter identical to da9062 that I just looked at? Please find a way to

RE: [RESEND PATCH V2 1/2] input: misc: da9063: OnKey driver

2015-04-24 Thread Opensource [Steve Twiss]
On 18 April 2015 08:55 Paul Bolle wrote: There's still a license mismatch left (it probably got lost in the noise when I finally noticed that the header comment mentioned the LGPL in V1). On Fri, 2015-04-17 at 13:03 +0100, S Twiss wrote: + * as published by the Free Software Foundation;

Re: Turn Sony motion controller into RGB led

2015-04-24 Thread Pavel Machek
Hi! If you can send a version without all of the unrelated underscore changes I'll help clean it up. I don't own one of these controllers though, so I can't help test the functionality. I cleaned some of the (easy) comments, and tested that it still works. Here's the updated version. Thanks,

[PATCH] input: ff-core: Fix spelling mistake in ff-core

2015-04-24 Thread Dan Murphy
Fix spelling of magnitude s/manginude/magnitude Signed-off-by: Dan Murphy dmur...@ti.com --- drivers/input/ff-core.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/input/ff-core.c b/drivers/input/ff-core.c index b81c88c..d10154e 100644 --- a/drivers/input/ff-core.c

[PATCH] Input: drv2667: Fix Kconfig error for help screen

2015-04-24 Thread Dan Murphy
Fix the Kconfig for the drv2667 as there was a copy/paste error. Signed-off-by: Dan Murphy dmur...@ti.com --- drivers/input/misc/Kconfig | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/input/misc/Kconfig b/drivers/input/misc/Kconfig index 4436ab1..7838f1a 100644 ---

[PATCH 2/7] alps: Only set fields actually present when decoding pinnacle / rushmore pkts

2015-04-24 Thread Hans de Goede
Pinnacle / Rushmore packets contain either position info, or bitmap info, never both. So far we've in essence been storing garbage in the position / bitmap fields of the fields struct when decoding a bitmap / pos packet. We've been relying on the following sequence to get away with this: 1)

[PATCH 0/7] alps: Improve coordinates reported when 2fg are down on semi-mt models

2015-04-24 Thread Hans de Goede
Hi Dmitry, This patch-set improves the coordinates reported when 2 fingers are down on semi-mt alps models, leading to a much smoother 2fg scrolling experience. This is somewhat the result of a libinput discussion here: https://bugs.freedesktop.org/show_bug.cgi?id=89683 This has been tested on

[PATCH 7/7] alps: Use the generic process_bitmap function for dolphin (v5) touchpads too

2015-04-24 Thread Hans de Goede
Now that the generic process_bitmap function has been improved to offer accurate coordinates for the first touch we can use it for v5 (dolphin) touchpads too. Besides being a nice code cleanup this also fixes the saw tooth pattern in the coordinates for the second touch the dolphin specific

[PATCH 6/7] alps: Rename alps_set_abs_params_mt to alps_set_abs_params_semi_mt

2015-04-24 Thread Hans de Goede
Rename alps_set_abs_params_mt to alps_set_abs_params_semi_mt, to make it clear that it is only (to be) used for semi-mt devices. Signed-off-by: Hans de Goede hdego...@redhat.com --- drivers/input/mouse/alps.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git

[PATCH v3] HID: wacom: retrieve name from HID descriptor for generic devices

2015-04-24 Thread Ping Cheng
HID generic devices share the same default name, Wacom HID. This causes userland programs to show same device names for different devices, which would confuse end users with same device names for different devices too. This patch uses name retrieved from HID descriptor, if a meaningful name is

Re: [PATCH 2/2] Input - synaptics: pin 3 touches when the firmware reports 3 fingers

2015-04-24 Thread Benjamin Tissoires
Hi Dmitry, [ adding more relevant people to the discussion ] On Apr 23 2015 or thereabouts, Benjamin Tissoires wrote: On Apr 23 2015 or thereabouts, Dmitry Torokhov wrote: On Wed, Apr 22, 2015 at 11:45:09AM -0400, Benjamin Tissoires wrote: Synaptics PS/2 touchpad can send only 2 touches in

Re: [PATCH V1 2/6] regulator: da9062: DA9062 regulator driver

2015-04-24 Thread Mark Brown
On Fri, Apr 24, 2015 at 02:47:06PM +, Opensource [Steve Twiss] wrote: On 18 April 2015 12:48 Mark Brown wrote: Okay. I think I am getting this. As of v3.18 there are newer parts to regulator_desc from the commit a0c7b16 regulator: of: Provide simplified DT parsing method The search

RE: [PATCH V1 2/6] regulator: da9062: DA9062 regulator driver

2015-04-24 Thread Opensource [Steve Twiss]
On 18 April 2015 12:48 Mark Brown wrote: On Fri, Apr 17, 2015 at 03:23:32PM +0100, S Twiss wrote: +/* Regulator interrupt handlers */ +static irqreturn_t da9062_ldo_lim_event(int irq, void *data) +{ + struct da9062_regulators *regulators = data; + struct da9062 *hw =

RE: [PATCH V1 1/6] mfd: da9062: DA9062 MFD core driver

2015-04-24 Thread Opensource [Steve Twiss]
On 17 April 2015 15:24 Steve Twiss wrote. Subject: [PATCH V1 1/6] mfd: da9062: DA9062 MFD core driver From: S Twiss stwiss.opensou...@diasemi.com Add MFD core driver support for DA9062 Signed-off-by: Steve Twiss stwiss.opensou...@diasemi.com --- This patch applies against linux-next

[PATCH 1/7] alps: Change alps_decode_rushmore to do all decoding itself

2015-04-24 Thread Hans de Goede
Change alps_decode_rushmore to do all decoding itself, rather then relying on alps_decode_pinnacle and then overriding some fields + or-ing in some bits. This is a preparation patch for modifying the decode functions to properly differentiate between position and bitmap packets. Signed-off-by:

[PATCH 4/7] alps: Use more accurate coordinates for first touch in semi-mt mode

2015-04-24 Thread Hans de Goede
All alps semi-mt touchpads give us the following data when 2 (or more) fingers are touching: 1 more or less accurate touch for the first finger down, and a bitmap with columns and rows in which 1 or more fingers are seen resulting in a crude (low res) bounding box. So far for v3, rushmore and v4

[PATCH 5/7] alps: Do not use input-mt finger tracking for semi-mt devices

2015-04-24 Thread Hans de Goede
With the recent process_bitmap() changes all semi-mt devices always report the first finger down in slot 0, so stop using input-mt finger tracking for these. Signed-off-by: Hans de Goede hdego...@redhat.com --- drivers/input/mouse/alps.c | 8 ++-- 1 file changed, 6 insertions(+), 2

[PATCH 3/7] alps: Always decode the position packet before the packet with the bitmap data

2015-04-24 Thread Hans de Goede
This way we can use the more accurate position info in process_bitmap() to get better results. Signed-off-by: Hans de Goede hdego...@redhat.com --- drivers/input/mouse/alps.c | 35 ++- 1 file changed, 14 insertions(+), 21 deletions(-) diff --git

Re: [RESEND PATCH V2 1/2] input: misc: da9063: OnKey driver

2015-04-24 Thread Paul Bolle
On Fri, 2015-04-24 at 13:45 +, Opensource [Steve Twiss] wrote: That seems to be a fairly common mistake in the kernel. It's an easy mistake to make. And as long as people pick an ident that passes license_is_gpl_compatible() the module will build and load just fine. When I did a