Re: [PATCH] Input: misc: max77693-haptic - fix active state check in disable()

2014-10-14 Thread Chanwoo Choi
enabled) > + if (!haptic->enabled) > return; > > error = max77693_haptic_configure(haptic, false); > If you modify patch name, Looks good to me. Reviewed-by: Chanwoo Choi Thanks, Chanwoo Choi -- To unsubscribe from this list: send the line "unsu

Re: [PATCH] Input: max77693-haptic - fix potential overflow

2014-10-28 Thread Chanwoo Choi
gt;pwm_dev->period * > - haptic->magnitude); > + period_mag_multi = (u64)haptic->pwm_dev->period * haptic->magnitude; > haptic->pwm_duty = (unsigned int)(period_mag_multi >> >

Re: [PATCH v2 2/2] ARM: dts: Add regulator-haptic device node for exynos3250-rinato

2014-11-24 Thread Chanwoo Choi
}; > }; > + > + haptics { > + compatible = "regulator-haptic"; > + haptic-supply = <&motor_reg>; > + min-microvolt = <110>; > + max-microvolt = <2700000>; > + }; > }; > > &

Re: [PATCH v2 1/2] Input: add regulator haptic driver

2014-11-24 Thread Chanwoo Choi
Kyungmin Park Looks good to me. I tested this patch on Exynos3250-based Rinato (Samsung Gear2) board. Tested-by: Chanwoo Choi Reviewed-by: Chanwoo Choi Thanks, Chanwoo Choi > --- > .../devicetree/bindings/input/regulator-haptic.txt | 24 ++ > drivers/input/misc/Kconfig

Re: [PATCH v2] mfd: max8997: use regmap to access registers

2014-03-05 Thread Chanwoo Choi
:333:3: note: each undeclared identifier is reported only once for each function it appears in make[2]: *** [drivers/mfd/max8997-irq.o] Error 1 make[1]: *** [drivers/mfd] Error 2 make[1]: *** Waiting for unfinished jobs Thansk, Chanwoo CHoi On 03/05/2014 11:58 PM, Robert Baldyga wrote: > T

Re: [PATCH v2 2/3] mfd: max8997: handle IRQs using regmap

2014-03-12 Thread Chanwoo Choi
MIC_INT1_PWRONF_MASK(0x1 << 1) > +#define PMIC_INT1_PWRON1SEC_MASK (0x1 << 3) > +#define PMIC_INT1_JIGONR_MASK(0x1 << 4) > +#define PMIC_INT1_JIGONF_MASK (0x1 << 5) > +#define PMIC_INT1_LOWBAT2_MASK (0x1 <&

Re: [PATCH v2 2/3] mfd: max8997: handle IRQs using regmap

2014-03-13 Thread Chanwoo Choi
Hi Robert, On 03/13/2014 04:46 PM, Robert Baldyga wrote: > Hi, > On 03/13/2014 03:03 AM, Chanwoo Choi wrote: >> Hi Robert, >> >> On 03/12/2014 10:37 PM, Robert Baldyga wrote: >>> This patch modifies mfd driver to use regmap for handling interrupts. >>>

Re: [PATCH v3 3/4] mfd: max8997: change irq names to upper case

2014-03-13 Thread Chanwoo Choi
drivers/extcon/extcon-max8997.c | 32 > include/linux/mfd/max8997-private.h | 16 > 2 files changed, 24 insertions(+), 24 deletions(-) > Acked-by: Chanwoo Choi Thanks, Chanwoo Choi -- To unsubscribe from this list: send the lin

Re: [PATCH v3 0/4] mfd: max8997: add regmap support

2014-03-13 Thread Chanwoo Choi
+ > drivers/rtc/rtc-max8997.c | 102 ++--- > include/linux/mfd/max8997-private.h | 88 ++-- > 11 files changed, 532 insertions(+), 721 deletions(-) > delete mode 100644 drivers/mfd/max8997-irq.c > This patch fix many parts of previous max8997. When I testd

Re: [PATCH v3 2/4] mfd: max8997: handle IRQs using regmap

2014-03-13 Thread Chanwoo Choi
0x1 << 0) > +#define PMIC_INT2_JIGF_MASK (0x1 << 1) > +#define PMIC_INT2_MR_MASK(0x1 << 2) > +#define PMIC_INT2_DVS1OK_MASK(0x1 << 3) > +#define PMIC_INT2_DVS2OK_MASK(0x1 << 4) > +#define PMIC_INT2_DVS3OK_MASK(0x1 << 5) > +#define PMIC_INT2_DVS4OK_MASK(0x1 << 6) > + > +#define PMIC_INT3_CHGINS_MASK(0x1 << 0) > +#define PMIC_INT3_CHGRM_MASK (0x1 << 1) > +#define PMIC_INT3_DCINOVP_MASK (0x1 << 2) > +#define PMIC_INT3_TOPOFFR_MASK (0x1 << 3) > +#define PMIC_INT3_CHGRSTF_MASK (0x1 << 5) > +#define PMIC_INT3_MBCHGTMEXPD_MASK (0x1 << 7) > + > +#define PMIC_INT4_RTC60S_MASK(0x1 << 0) > +#define PMIC_INT4_RTCA1_MASK (0x1 << 1) > +#define PMIC_INT4_RTCA2_MASK (0x1 << 2) > +#define PMIC_INT4_SMPL_INT_MASK (0x1 << 3) > +#define PMIC_INT4_RTC1S_MASK (0x1 << 4) > +#define PMIC_INT4_WTSR_MASK (0x1 << 5) > + > +#define MUIC_INT1_ADC_MASK (0x1 << 0) > +#define MUIC_INT1_ADCLOW_MASK(0x1 << 1) > +#define MUIC_INT1_ADCERROR_MASK (0x1 << 2) > + > +#define MUIC_INT2_CHGTYP_MASK(0x1 << 0) > +#define MUIC_INT2_CHGDETRUN_MASK (0x1 << 1) > +#define MUIC_INT2_DCDTMR_MASK(0x1 << 2) > +#define MUIC_INT2_DBCHG_MASK (0x1 << 3) > +#define MUIC_INT2_VBVOLT_MASK(0x1 << 4) > + > +#define MUIC_INT3_OVP_MASK (0x1 << 2) > + > enum max8997_irq { > MAX8997_PMICIRQ_PWRONR, > MAX8997_PMICIRQ_PWRONF, > @@ -364,19 +406,23 @@ enum max8997_irq { > MAX8997_PMICIRQ_RTC1S, > MAX8997_PMICIRQ_WTSR, > > - MAX8997_MUICIRQ_ADCError, > - MAX8997_MUICIRQ_ADCLow, > + MAX8997_PMICIRQ_NR, > +}; > + > +enum max8997_irq_muic { > MAX8997_MUICIRQ_ADC, > + MAX8997_MUICIRQ_ADCLow, > + MAX8997_MUICIRQ_ADCError, > > - MAX8997_MUICIRQ_VBVolt, > - MAX8997_MUICIRQ_DBChg, > - MAX8997_MUICIRQ_DCDTmr, > - MAX8997_MUICIRQ_ChgDetRun, > MAX8997_MUICIRQ_ChgTyp, > + MAX8997_MUICIRQ_ChgDetRun, > + MAX8997_MUICIRQ_DCDTmr, > + MAX8997_MUICIRQ_DBChg, > + MAX8997_MUICIRQ_VBVolt, > > MAX8997_MUICIRQ_OVP, > > - MAX8997_IRQ_NR, > + MAX8997_MUCIRQ_NR, > }; > > #define MAX8997_NUM_GPIO 12 > @@ -397,9 +443,10 @@ struct max8997_dev { > struct regmap *regmap_haptic; > struct regmap *regmap_muic; > > + struct regmap_irq_chip_data *irq_data; > + struct regmap_irq_chip_data *irq_data_muic; > int irq; > int ono; > - struct irq_domain *irq_domain; > struct mutex irqlock; > int irq_masks_cur[MAX8997_IRQ_GROUP_NR]; > int irq_masks_cache[MAX8997_IRQ_GROUP_NR]; > Thanks, Chanwoo Choi -- To unsubscribe from this list: send the line "unsubscribe linux-input" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH v3 4/4] mfd: max8997: move regmap handling to function drivers

2014-03-13 Thread Chanwoo Choi
m mfd driver to each driver. Best Regards, Chanwoo Choi On 03/13/2014 06:38 PM, Robert Baldyga wrote: > This patch moves code creating new i2c clients and regmaps to function > drivers which use them. It allows to avoid creating this instances when > individual function drivers are not enable

Re: [PATCH v3 1/4] mfd: max8997: use regmap to access registers

2014-03-18 Thread Chanwoo Choi
+--- > include/linux/mfd/max8997-private.h | 17 ++--- > 10 files changed, 228 insertions(+), 249 deletions(-) > For extcon part, Acked-by: Chanwoo Choi Thanks, Chanwoo Choi -- To unsubscribe from this list: send the line "unsubscribe linux-input" in the body

Re: [PATCH v3 2/4] mfd: max8997: handle IRQs using regmap

2014-03-18 Thread Chanwoo Choi
On 03/14/2014 05:33 PM, Robert Baldyga wrote: > On 03/13/2014 11:45 AM, Chanwoo Choi wrote: >> Hi Robert, >> >> On 03/13/2014 06:38 PM, Robert Baldyga wrote: >>> This patch modifies mfd driver to use regmap for handling interrupts. >>> It allows to simplify i

[PATCH] input: gpio_keys: Add IRQF_NO_SUSPEND flag to wake-up from freeze state

2014-05-25 Thread Chanwoo Choi
This patch add IRQF_NO_SUSPEND flag before requesting interrupt handler if button->wakeup is true. If ther interrupt of gpio-keys hasn't included IRQF_NO_SUSPEND, wouldn't wake-up from freeze state when pressing button. Signed-off-by: Chanwoo Choi Acked-by: Kyungmin Park Cc: Dmitry

Re: [PATCH v5 3/3] mfd: max8997: change irq names to upper case

2015-01-29 Thread Chanwoo Choi
Hi Robert, For extcon part, Acked-by: Chanwoo Choi Thanks, Chanwoo Choi On 11/12/2014 04:23 PM, Robert Baldyga wrote: > This patch changes naming convention of MUIC interrupts form CamelCase > to upper case. It makes names more readable and consistent with another > interrupt names i

Re: [PATCH 01/10] mfd/extcon: max77693: Remove unused extern declarations and max77693_dev members

2015-05-03 Thread Chanwoo Choi
} - - if (irq_src < MAX77693_IRQ_GROUP_NR) - info->max77693->irq_masks_cur[irq_src] - = init_data[i].data; } [snip] Except for upper comment, Looks good to me. Thanks, Chanwoo Choi -- To unsubscribe from this list: send the line "un

Re: [PATCH v2 7/9] mfd/extcon: max77843: Rename defines to allow inclusion with max77693

2015-05-27 Thread Chanwoo Choi
lt; CONTROL1_COMP2SW_SHIFT)) > -#define CONTROL1_SW_AUX_USB \ > - ((COM_AUX_USB << CONTROL1_COMP1SW_SHIFT | \ > -COM_AUX_USB << CONTROL1_COMP2SW_SHIFT)) > -#define CONTROL1_SW_AUX_UART \ > - ((COM_AUX_UART << CONTROL1_COMP1SW_SHIFT | \ > -COM_

Re: [PATCH v2 6/9] mfd/extcon: max77693: Rename defines to allow inclusion with max77843

2015-05-27 Thread Chanwoo Choi
Hi Krzysztof, I reviewed it and tested it for kernel build. Acked-by: Chanwoo Choi Thanks, Chanwoo Choi On Sun, May 24, 2015 at 2:43 PM, Krzysztof Kozlowski wrote: > Add MAX77693 prefix to some of the defines used in max77693 extcon > driver so the max77693-private.h can be in

Re: [PATCH v2 5/9] extcon/input/mfd/regulator: max77843: Switch to common max77693 state container

2015-05-27 Thread Chanwoo Choi
Hi Krzysztof, I reviewed it and took the kernel build. There are no any build issue. Acked-by: Chanwoo Choi Thanks, Chanwoo Choi On Sun, May 24, 2015 at 2:43 PM, Krzysztof Kozlowski wrote: > Switch to the same definition of state container as in MAX77693 drivers. > This will allow us

Re: [PATCH v2 4/9] extcon/input/mfd/power/regulator: max77693: Move state container to common header

2015-05-27 Thread Chanwoo Choi
Hi Krzysztof, I reviewed it and took the kernel build. There are no any build issue. Acked-by: Chanwoo Choi Thanks, Chanwoo Choi On Sun, May 24, 2015 at 2:43 PM, Krzysztof Kozlowski wrote: > This prepares for merging some of the drivers between max77693 and > max77843 so the child MFD

Re: [PATCH v2 7/9] mfd/extcon: max77843: Rename defines to allow inclusion with max77693

2015-05-29 Thread Chanwoo Choi
On 05/28/2015 08:42 AM, Krzysztof Kozłowski wrote: > 2015-05-27 22:50 GMT+09:00 Chanwoo Choi : >> On Sun, May 24, 2015 at 2:43 PM, Krzysztof Kozlowski >> wrote: >>> Add MAX77843_MUIC prefix to some of the defines used in max77843 extcon >>> driver so the m