Re: [RFC PATCH 2/3] clk: add managed version of clk_bulk_get

2017-04-21 Thread Stephen Boyd
On 04/13, Dong Aisheng wrote: > On Wed, Apr 12, 2017 at 12:03:28PM +0800, Dong Aisheng wrote: > >drivers/built-in.o: In function `devm_clk_bulk_get': > >> (.text+0x1930e): undefined reference to `clk_bulk_get' >drivers/built-in.o: In function `devm_clk_bulk_release': > >> clk-devres.c:(.te

Re: [RFC PATCH 0/3] clk: introduce clk_bulk_get accessories

2017-04-21 Thread Stephen Boyd
On 04/12, Dong Aisheng wrote: > > Together with the err path handling for each clocks, it does make > things a bit ugly. > > Since we already have regulator_bulk_get accessories, i thought we > probably could introduce clk_bulk_get as well to handle such case to > ease the driver owners' life. >

Re: [RFC] minimum gcc version for kernel: raise to gcc-4.3 or 4.6?

2017-04-21 Thread Maciej W. Rozycki
On Fri, 21 Apr 2017, Kees Cook wrote: > > The linux-4.2 x86 defconfig could still be built with gcc-4.0, but > > later kernels have several minor problems with that, and > > require at least gcc-4.3. > > > > If we are ok with this status quo, we could simply declare gcc-4.3 > > the absolute minimu

Re: [RFC PATCH 1/3] clk: add clk_bulk_get accessories

2017-04-21 Thread Stephen Boyd
On 04/12, Dong Aisheng wrote: > > #ifdef CONFIG_HAVE_CLK > @@ -230,6 +257,32 @@ static inline void clk_unprepare(struct clk *clk) > struct clk *clk_get(struct device *dev, const char *id); > > /** > + * clk_bulk_get - lookup and obtain a number of references to clock producer. > + * @dev: de

Re: [PATCH v2] selftests: ftrace: Allow some tests to be run in a tracing instance

2017-04-21 Thread Steven Rostedt
On Sat, 22 Apr 2017 08:00:36 +0900 Masami Hiramatsu wrote: > > BTW, this seems too complecated (with many similar variables). I'm use to complicated ;-) > I think we just need following patch, if we run the tests which > have "instance" flag twice on top-level and an instance. > (If you'd like

[HMM 09/15] mm/hmm/mirror: helper to snapshot CPU page table v2

2017-04-21 Thread Jérôme Glisse
This does not use existing page table walker because we want to share same code for our page fault handler. Changes since v1: - Use spinlock instead of rcu synchronized list traversal Signed-off-by: Jérôme Glisse Signed-off-by: Evgeny Baskakov Signed-off-by: John Hubbard Signed-off-by: Mark

[HMM 00/15] HMM (Heterogeneous Memory Management) v20

2017-04-21 Thread Jérôme Glisse
Patchset is on top of mmotm mmotm-2017-04-18 and Michal patchset ([PATCH -v3 0/13] mm: make movable onlining suck less). Branch: https://cgit.freedesktop.org/~glisse/linux/log/?h=hmm-v20 I have included all suggestion made since v19, it is all build fix and change in respect to memory hotplug wit

[HMM 06/15] mm/migrate: migrate_vma() unmap page from vma while collecting pages

2017-04-21 Thread Jérôme Glisse
Common case for migration of virtual address range is page are map only once inside the vma in which migration is taking place. Because we already walk the CPU page table for that range we can directly do the unmap there and setup special migration swap entry. Signed-off-by: Jérôme Glisse Signed-

[HMM 13/15] mm/hmm/devmem: device memory hotplug using ZONE_DEVICE v3

2017-04-21 Thread Jérôme Glisse
This introduce a simple struct and associated helpers for device driver to use when hotpluging un-addressable device memory as ZONE_DEVICE. It will find a unuse physical address range and trigger memory hotplug for it which allocates and initialize struct page for the device memory. Changed since

[HMM 10/15] mm/hmm/mirror: device page fault handler

2017-04-21 Thread Jérôme Glisse
This handle page fault on behalf of device driver, unlike handle_mm_fault() it does not trigger migration back to system memory for device memory. Signed-off-by: Jérôme Glisse Signed-off-by: Evgeny Baskakov Signed-off-by: John Hubbard Signed-off-by: Mark Hairgrove Signed-off-by: Sherry Cheung

[HMM 12/15] mm/migrate: allow migrate_vma() to alloc new page on empty entry v2

2017-04-21 Thread Jérôme Glisse
This allow caller of migrate_vma() to allocate new page for empty CPU page table entry. It only support anoymous memory and it won't allow new page to be instance if userfaultfd is armed. This is useful to device driver that want to migrate a range of virtual address and would rather allocate new

[HMM 15/15] hmm: heterogeneous memory management documentation

2017-04-21 Thread Jérôme Glisse
This add documentation for HMM (Heterogeneous Memory Management). It presents the motivation behind it, the features necessary for it to be useful and and gives an overview of how this is implemented. Signed-off-by: Jérôme Glisse --- Documentation/vm/hmm.txt | 362 +++

Re: [RFC PATCH v5 1/2] usb: typec: USB Type-C Port Manager (tcpm)

2017-04-21 Thread Guenter Roeck
On 04/21/2017 03:15 PM, Guenter Roeck wrote: From: Guenter Roeck This driver implements the USB Type-C Power Delivery state machine for both source and sink ports. Alternate mode support is not fully implemented. The driver attaches to the USB Type-C class code implemented in the following pat

[HMM 02/15] mm/put_page: move ZONE_DEVICE page reference decrement v2

2017-04-21 Thread Jérôme Glisse
Move page reference decrement of ZONE_DEVICE from put_page() to put_zone_device_page() this does not affect non ZONE_DEVICE page. Doing this allow to catch when a ZONE_DEVICE page refcount reach 1 which means the device is no longer reference by any one (unlike page from other zone, ZONE_DEVICE pa

Re: [PATCH] xprtrdma: use offset_in_page() macro

2017-04-21 Thread Chuck Lever
> On Apr 21, 2017, at 9:21 PM, Geliang Tang wrote: > > Use offset_in_page() macro instead of open-coding. > > Signed-off-by: Geliang Tang > --- > net/sunrpc/xprtrdma/rpc_rdma.c| 4 ++-- > net/sunrpc/xprtrdma/svc_rdma_sendto.c | 3 +-- > 2 files changed, 3 insertions(+), 4 deletions(-) >

[HMM 05/15] mm/migrate: new memory migration helper for use with device memory v4

2017-04-21 Thread Jérôme Glisse
This patch add a new memory migration helpers, which migrate memory backing a range of virtual address of a process to different memory (which can be allocated through special allocator). It differs from numa migration by working on a range of virtual address and thus by doing migration in chunk th

[HMM 04/15] mm/migrate: new migrate mode MIGRATE_SYNC_NO_COPY

2017-04-21 Thread Jérôme Glisse
Introduce a new migration mode that allow to offload the copy to a device DMA engine. This changes the workflow of migration and not all address_space migratepage callback can support this. So it needs to be tested in those cases. This is intended to be use by migrate_vma() which itself is use for

[HMM 11/15] mm/migrate: support un-addressable ZONE_DEVICE page in migration

2017-04-21 Thread Jérôme Glisse
Allow to unmap and restore special swap entry of un-addressable ZONE_DEVICE memory. Signed-off-by: Jérôme Glisse Cc: Kirill A. Shutemov --- include/linux/migrate.h | 10 +++- mm/migrate.c| 136 ++-- mm/page_vma_mapped.c| 10 mm/

[PATCH v3] selftests: ftrace: Allow some tests to be run in a tracing instance

2017-04-21 Thread Steven Rostedt
>From 4464dc867ead3ea14654165ad3ab68263aff7b17 Mon Sep 17 00:00:00 2001 From: "Steven Rostedt (VMware)" Date: Thu, 20 Apr 2017 12:53:18 -0400 Subject: [PATCH] selftests: ftrace: Allow some tests to be run in a tracing instance An tracing instance has several of the same capabilities as the top l

[HMM 03/15] mm/unaddressable-memory: new type of ZONE_DEVICE for unaddressable memory

2017-04-21 Thread Jérôme Glisse
HMM (heterogeneous memory management) need struct page to support migration from system main memory to device memory. Reasons for HMM and migration to device memory is explained with HMM core patch. This patch deals with device memory that is un-addressable memory (ie CPU can not access it). Henc

[HMM 01/15] mm, memory_hotplug: introduce add_pages

2017-04-21 Thread Jérôme Glisse
From: Michal Hocko There are new users of memory hotplug emerging. Some of them require different subset of arch_add_memory. There are some which only require allocation of struct pages without mapping those pages to the kernel address space. We currently have __add_pages for that purpose. But th

[HMM 07/15] mm/hmm: heterogeneous memory management (HMM for short) v2

2017-04-21 Thread Jérôme Glisse
HMM provides 3 separate types of functionality: - Mirroring: synchronize CPU page table and device page table - Device memory: allocating struct page for device memory - Migration: migrating regular memory to device memory This patch introduces some common helpers and definitions to al

[HMM 08/15] mm/hmm/mirror: mirror process address space on device with HMM helpers v2

2017-04-21 Thread Jérôme Glisse
This is a heterogeneous memory management (HMM) process address space mirroring. In a nutshell this provide an API to mirror process address space on a device. This boils down to keeping CPU and device page table synchronize (we assume that both device and CPU are cache coherent like PCIe device ca

Re: [tip:irq/urgent] genirq/affinity: Fix calculating vectors to assign

2017-04-21 Thread Andrei Vagin
Looks like 4.11 will be release in a few days, it would be nice if this commit reaches the upstream tree before this moment. Thanks. On Thu, Apr 20, 2017 at 07:06:49AM -0700, tip-bot for Keith Busch wrote: > Commit-ID: b72f8051f34b8164a62391e3676edc34523c5952 > Gitweb: http://git.kernel.org/

Re: [HMM 02/15] mm/put_page: move ZONE_DEVICE page reference decrement v2

2017-04-21 Thread Dan Williams
On Fri, Apr 21, 2017 at 8:30 PM, Jérôme Glisse wrote: > Move page reference decrement of ZONE_DEVICE from put_page() > to put_zone_device_page() this does not affect non ZONE_DEVICE > page. > > Doing this allow to catch when a ZONE_DEVICE page refcount reach > 1 which means the device is no longer

[HMM 14/15] mm/hmm/devmem: dummy HMM device for ZONE_DEVICE memory v3

2017-04-21 Thread Jérôme Glisse
This introduce a dummy HMM device class so device driver can use it to create hmm_device for the sole purpose of registering device memory. It is useful to device driver that want to manage multiple physical device memory under same struct device umbrella. Changed since v2: - use device_initcall

Re: [PATCH] drm: fourcc byteorder: brings header file comments in line with reality.

2017-04-21 Thread Ilia Mirkin
On Fri, Apr 21, 2017 at 12:59 PM, Ville Syrjälä wrote: > On Fri, Apr 21, 2017 at 10:49:49AM -0400, Ilia Mirkin wrote: >> On Fri, Apr 21, 2017 at 3:58 AM, Gerd Hoffmann wrote: >> > While working on graphics support for virtual machines on ppc64 (which >> > exists in both little and big endian vari

Re: [HMM 03/15] mm/unaddressable-memory: new type of ZONE_DEVICE for unaddressable memory

2017-04-21 Thread Dan Williams
On Fri, Apr 21, 2017 at 8:30 PM, Jérôme Glisse wrote: > HMM (heterogeneous memory management) need struct page to support migration > from system main memory to device memory. Reasons for HMM and migration to > device memory is explained with HMM core patch. > > This patch deals with device memor

Linux 3.18.50

2017-04-21 Thread Greg KH
I'm announcing the release of the 3.18.50 kernel. All users of the 3.18 kernel series must upgrade. The updated 3.18.y git tree can be found at: git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git linux-3.18.y and can be browsed at the normal kernel.org git web browser:

Re: Linux 3.18.50

2017-04-21 Thread Greg KH
diff --git a/Makefile b/Makefile index 252070fdf91c..8665178e2a36 100644 --- a/Makefile +++ b/Makefile @@ -1,6 +1,6 @@ VERSION = 3 PATCHLEVEL = 18 -SUBLEVEL = 49 +SUBLEVEL = 50 EXTRAVERSION = NAME = Diseased Newt diff --git a/arch/arm/include/asm/psci.h b/arch/arm/include/asm/psci.h index e37

Re: [PATCH 2/8] selftests: lib.mk: define CLEAN macro to allow Makefiles to override clean

2017-04-21 Thread Michael Ellerman
Shuah Khan writes: > Define CLEAN macro to allow Makefiles to override common clean target > in lib.mk. This will help fix the following failures: > > warning: overriding recipe for target 'clean' > ../lib.mk:55: warning: ignoring old recipe for target 'clean' > > Signed-off-by: Shuah Khan Shou

Re: [PATCH 4/8] selftests: gpio: override clean in lib.mk to fix warnings

2017-04-21 Thread Michael Ellerman
Shuah Khan writes: > Add override for lib.mk clean to fix the following warnings from clean > target run. > > Makefile:11: warning: overriding recipe for target 'clean' > ../lib.mk:55: warning: ignoring old recipe for target 'clean' > > Signed-off-by: Shuah Khan > --- > tools/testing/selftests/

Re: [PATCH 7/8] selftests: sync: override clean in lib.mk to fix warnings

2017-04-21 Thread Michael Ellerman
Shuah Khan writes: > Add override for lib.mk clean to fix the following warnings from clean > target run. > > Makefile:24: warning: overriding recipe for target 'clean' > ../lib.mk:55: warning: ignoring old recipe for target 'clean' > > Signed-off-by: Shuah Khan > --- > tools/testing/selftests/

Re: [PATCH 6/8] selftests: splice: override clean in lib.mk to fix warnings

2017-04-21 Thread Michael Ellerman
Shuah Khan writes: > Add override for lib.mk clean to fix the following warnings from clean > target run. > > Makefile:8: warning: overriding recipe for target 'clean' > ../lib.mk:55: warning: ignoring old recipe for target 'clean' > > Signed-off-by: Shuah Khan > --- > tools/testing/selftests/s

Re: [PATCH 8/8] selftests: x86: override clean in lib.mk to fix warnings

2017-04-21 Thread Michael Ellerman
Shuah Khan writes: > Add override for lib.mk clean to fix the following warnings from clean > target run. > > Makefile:44: warning: overriding recipe for target 'clean' > ../lib.mk:55: warning: ignoring old recipe for target 'clean' > > Signed-off-by: Shuah Khan > --- > tools/testing/selftests/

Re: [PATCH v4 3/7] kprobes: validate the symbol name provided during probe registration

2017-04-21 Thread Michael Ellerman
"Naveen N. Rao" writes: > When a kprobe is being registered, we use the symbol_name field to > lookup the address where the probe should be placed. Since this is a > user-provided field, let's ensure that the length of the string is > within expected limits. What are we actually trying to protec

Re: [PATCH v2 3/3] powerpc/mm: Implement CONFIG_DEBUG_RODATA on PPC32

2017-04-21 Thread Michael Ellerman
"Naveen N. Rao" writes: > Excerpts from Christophe Leroy's message of April 21, 2017 18:32: >> diff --git a/arch/powerpc/kernel/ftrace.c >> b/arch/powerpc/kernel/ftrace.c >> index 32509de6ce4c..06d2ac53f471 100644 >> --- a/arch/powerpc/kernel/ftrace.c >> +++ b/arch/powerpc/kernel/ftrace.c >> @@ -

Re: powerpc KVM build break in linux-next (was Re: [PATCH tip/core/rcu 40/40] srcu: Parallelize callback handling)

2017-04-21 Thread Michael Ellerman
"Paul E. McKenney" writes: > On Fri, Apr 21, 2017 at 09:27:59AM +0200, Paolo Bonzini wrote: >> On 21/04/2017 06:17, Paul E. McKenney wrote: >> >> Thanks, this looks perfect to me, and if you're happy to put it on top >> >> of your tree that would limit the breakage to a smaller history window, >>

Re: [PATCH] hwmon: (ibmpowernv) Add min/max attributes and current sensors

2017-04-21 Thread Michael Ellerman
Shilpasri G Bhat writes: > On 04/21/2017 05:17 PM, Cédric Le Goater wrote: >> On 04/21/2017 06:31 AM, Shilpasri G Bhat wrote: >>> diff --git a/drivers/hwmon/ibmpowernv.c b/drivers/hwmon/ibmpowernv.c >>> index 6d2e660..1f329fa8 100644 >>> --- a/drivers/hwmon/ibmpowernv.c >>> +++ b/drivers/hwmon/ibm

RE: Performance of low-cpu utilisation benchmark regressed severely since 4.6

2017-04-21 Thread Doug Smythies
On 2017.04.20 18:18 Rafael wrote: > On Thursday, April 20, 2017 07:55:57 AM Doug Smythies wrote: >> On 2017.04.19 01:16 Mel Gorman wrote: >>> On Fri, Apr 14, 2017 at 04:01:40PM -0700, Doug Smythies wrote: Hi Mel, > > [cut] > >>> And the revert does help albeit not being an option for reasons R

[PATCH v2] bus: fsl-mc: dpio: fix alter FQ state command

2017-04-21 Thread Horia Geantă
When checking the response verb, the valid bit should be masked out, since its value flips depending on what Response Register (RR0 /RR1) it's been read from. Fixes: 321eecb06bfb ("bus: fsl-mc: dpio: add QBMan portal APIs for DPAA2") Signed-off-by: Horia Geantă --- v2: use QBMAN_RESULT_MASK inste

Re: [PATCH v3 2/2] modules:capabilities: add a per-task modules autoload restriction

2017-04-21 Thread Andy Lutomirski
On Fri, Apr 21, 2017 at 5:13 PM, Casey Schaufler wrote: > On 4/21/2017 5:00 PM, Andy Lutomirski wrote: >> On Fri, Apr 21, 2017 at 4:52 PM, Casey Schaufler >> wrote: >>> On 4/21/2017 4:28 PM, Andy Lutomirski wrote: On Fri, Apr 21, 2017 at 4:19 PM, Kees Cook wrote: > On Wed, Apr 19, 2017

Re: [PATCH v3 2/2] modules:capabilities: add a per-task modules autoload restriction

2017-04-21 Thread Andy Lutomirski
On Fri, Apr 21, 2017 at 5:12 PM, Djalal Harouni wrote: > On Sat, Apr 22, 2017 at 1:51 AM, Andy Lutomirski wrote: > [...] I personally like my implicit_rights idea, and it might be interesting to prototype it. >>> >>> I don't like blocking a needed feature behind a large super-feature >>

Re: [PATCH] ASoC: fix odd_ptr_err.cocci warnings (fwd)

2017-04-21 Thread Takashi Iwai
On Sat, 22 Apr 2017 00:14:57 +0200, Julia Lawall wrote: > > I don't think the patch is correct, so I haven't bothered signing off on > it. Probably the & is not correct in the IS_ERR call? Yes, IS_ERR() was called with the wrong argument. I fixed it now. Note that it's no branch to be merged t

Re: [PATCH v2 3/3] powerpc/mm: Implement CONFIG_DEBUG_RODATA on PPC32

2017-04-21 Thread christophe leroy
Le 22/04/2017 à 08:08, Michael Ellerman a écrit : "Naveen N. Rao" writes: Excerpts from Christophe Leroy's message of April 21, 2017 18:32: diff --git a/arch/powerpc/kernel/ftrace.c b/arch/powerpc/kernel/ftrace.c index 32509de6ce4c..06d2ac53f471 100644 --- a/arch/powerpc/kernel/ftrace.c +++

<    4   5   6   7   8   9