Re: [tip:x86/cpu] x86/CPU/AMD: Set the CPB bit unconditionally on F17h

2019-02-20 Thread Borislav Petkov
On Fri, Jan 18, 2019 at 07:48:59AM -0800, tip-bot for Jiaxun Yang wrote: > Commit-ID: 0237199186e7a4aa5310741f0a6498a20c820fd7 > Gitweb: > https://git.kernel.org/tip/0237199186e7a4aa5310741f0a6498a20c820fd7 > Author: Jiaxun Yang > AuthorDate: Tue, 20 Nov 2018 11:00:18 +0800 > Committer:

Re: [PATCH v3 -next] tpm: Fix the type of the return value in calc_tpm2_event_size()

2019-02-20 Thread Jarkko Sakkinen
On Wed, Feb 20, 2019 at 04:25:38PM +0800, Yue Haibing wrote: > calc_tpm2_event_size() has an invalid signature because > it returns a 'size_t' where as its signature says that > it returns 'int'. > > Cc: > Fixes: 4d23cc323cdb ("tpm: add securityfs support for TPM 2.0 firmware event > log") >

RE: [PATCH V7 1/4] dt-bindings: fsl: scu: add thermal binding

2019-02-20 Thread Anson Huang
Best Regards! Anson Huang > -Original Message- > From: Aisheng Dong > Sent: 2019年2月20日 15:45 > To: Anson Huang ; mark.rutl...@arm.com; > shawn...@kernel.org; s.ha...@pengutronix.de; ker...@pengutronix.de; > feste...@gmail.com; catalin.mari...@arm.com; will.dea...@arm.com; >

[PATCH v2] arm64: dts: ls1028a: Add Audio DT nodes

2019-02-20 Thread Alison Wang
This patch adds Audio DT nodes for LS1028ARDB and LS1028AQDS boards. Signed-off-by: Alison Wang --- Changes in v2: - Modify some nodes' names. - Use GIC_SPI and IRQ_TYPE_LEVEL_HIGH. arch/arm64/boot/dts/freescale/fsl-ls1028a-qds.dts | 62

Re: [PATCH] reset: Don't WARN if trying to get a used reset control

2019-02-20 Thread Thierry Reding
On Thu, Feb 07, 2019 at 09:27:51AM +0100, Thierry Reding wrote: > On Wed, Feb 06, 2019 at 07:12:04PM +0100, Philipp Zabel wrote: > > On Wed, 2019-02-06 at 17:00 +0100, Thierry Reding wrote: > [...] > > > That way we operate on the same reset control, but we wouldn't need to > > > iterate over all

Re: [PATCH v2 5/5] base: soc: Export soc_device_register/unregister APIs

2019-02-20 Thread Vaishali Thakkar
On Wed, 20 Feb 2019 at 12:25, Greg KH wrote: > > On Wed, Feb 20, 2019 at 10:29:46AM +0530, Vaishali Thakkar wrote: > > From: Vinod Koul > > > > Qcom Socinfo driver can be built as a module, so > > export these two APIs. > > > > Signed-off-by: Vinod Koul > > Signed-off-by: Vaishali Thakkar > >

Re: linux-next: Fixes tag needs some work in the net-next tree

2019-02-20 Thread Jiri Pirko
Wed, Feb 20, 2019 at 07:48:13AM CET, da...@davemloft.net wrote: >From: Vinod Koul >Date: Wed, 20 Feb 2019 10:10:55 +0530 > >> On 20-02-19, 09:31, Stephen Rothwell wrote: >>> Hi all, >>> >>> In commit >>> >>> a968b5e9d587 ("net: dsa: qca8k: Enable delay for RGMII_ID mode") >>> >>> Fixes tag

Re: [PATCH v7 0/3] Fixes for Tegra soctherm

2019-02-20 Thread Wei Ni
On 20/2/2019 10:14 AM, Zhang Rui wrote: > On 一, 2019-02-18 at 15:59 +0800, Wei Ni wrote: >> Rui, >> Will you take this serial? >> > it is already in my tree. > I missed -rc6, thus I will queue them for 5.1-rc1. Thanks. I updated v8 patch per Daniel Lezcano's comment. Please check it. Wei. >

Re: [PATCH] HID: roccat: Mark expected switch fall-through

2019-02-20 Thread Jiri Kosina
On Wed, 20 Feb 2019, Stefan Achatz wrote: > I already confirmed this 7 months ago but as I see only in a reply to > you. I guess that fell in between cracks somewhere. > Yes, this patch is correct. Applied, thanks. -- Jiri Kosina SUSE Labs

Re: [PATCH v1 01/12] of: Add bindings of thermtrip for Tegra soctherm

2019-02-20 Thread Wei Ni
On 20/2/2019 9:22 AM, Eduardo Valentin wrote: > On Fri, Dec 28, 2018 at 11:28:42AM +0800, Wei Ni wrote: >> >> >> On 28/12/2018 7:06 AM, Rob Herring wrote: >>> On Tue, Dec 18, 2018 at 03:34:33PM +0800, Wei Ni wrote: Add optional property "nvidia,thermtrips". If present, these trips

[PATCH 5/6] lib/test_bitmap: add testcases for bitmap_parselist

2019-02-20 Thread Yury Norov
Add tests for non-number character, empty regions, integer overflow. Signed-off-by: Yury Norov --- lib/test_bitmap.c | 18 +- 1 file changed, 17 insertions(+), 1 deletion(-) diff --git a/lib/test_bitmap.c b/lib/test_bitmap.c index b06e0fd3811b..709424a788ee 100644 ---

[PATCH 1/6] bitmap_parselist: don't calculate length of the input string

2019-02-20 Thread Yury Norov
bitmap_parselist() calculates length of the input string before passing it to the __bitmap_parselist(). But the end-of-line condition is checked for every character in __bitmap_parselist() anyway. So doing it in wrapper is a simple waste of time. Signed-off-by: Yury Norov --- lib/bitmap.c | 5

[PATCH 4/6] lib/test_bitmap: switch test_bitmap_parselist to ktime_get()

2019-02-20 Thread Yury Norov
test_bitmap_parselist currently uses get_cycles which is not implemented on some platforms, so use ktime_get() instead. Signed-off-by: Yury Norov --- lib/test_bitmap.c | 9 - 1 file changed, 4 insertions(+), 5 deletions(-) diff --git a/lib/test_bitmap.c b/lib/test_bitmap.c index

[PATCH 6/6] lib/test_bitmap: add tests for bitmap_parselist_user

2019-02-20 Thread Yury Norov
Propagate existing bitmap_parselist() tests to bitmap_parselist_user(). Signed-off-by: Yury Norov --- lib/test_bitmap.c | 46 -- 1 file changed, 36 insertions(+), 10 deletions(-) diff --git a/lib/test_bitmap.c b/lib/test_bitmap.c index

[PATCH 2/6] bitmap_parselist: move non-parser logic to helpers

2019-02-20 Thread Yury Norov
Move region checking and setting functionality of __bitmap_parselist() to helpers. Signed-off-by: Yury Norov --- lib/bitmap.c | 64 +++- 1 file changed, 53 insertions(+), 11 deletions(-) diff --git a/lib/bitmap.c b/lib/bitmap.c index

[PATCH 3/6] bitmap_parselist: rework input string parser

2019-02-20 Thread Yury Norov
The requirement for this rework is to keep the __bitmap_parselist() copy-less and single-pass but make it more readable and maintainable by splitting into logical parts and removing explicit nested cycles and opaque local variables. __bitmap_parselist() can parse userspace inputs and therefore we

[PATCH v2 0/5] lib: rework bitmap_parselist and tests

2019-02-20 Thread Yury Norov
bitmap_parselist has been evolved from a pretty simple idea for long and now lacks for refactoring. It is not structured, has nested loops and a set of opaque-named variables. All this leads to extremely hard understanding of the code. Once during the optimization of it I missed a scenario which

Re: [PATCH v1 2/2] drm/mediatek: add mipi_tx driver for mt8183

2019-02-20 Thread CK Hu
Hi, Jitao: On Tue, 2019-02-19 at 17:14 +0800, Jitao Shi wrote: > This patch add mt8183 mipi_tx driver. > And also support other chips that use the same binding and driver. > > Signed-off-by: Jitao Shi > --- > drivers/gpu/drm/mediatek/mtk_mipi_tx.c| 2 + >

Re: [RFC PATCH] mm, memory_hotplug: fix off-by-one in is_pageblock_removable

2019-02-20 Thread Oscar Salvador
On Mon, Feb 18, 2019 at 07:15:44PM +0100, Michal Hocko wrote: > From: Michal Hocko > Fixes: efad4e475c31 ("mm, memory_hotplug: is_mem_section_removable do not > pass the end of a zone") > Reported-by: > Signed-off-by: Michal Hocko Looks good to me. I glanced quickly over the memhotplug code

Re: [PATCHv7] x86/kdump: bugfix, make the behavior of crashkernel=X consistent with kaslr

2019-02-20 Thread Borislav Petkov
On Mon, Feb 18, 2019 at 09:48:20AM +0800, Dave Young wrote: > It is ideal if kernel can do it automatically, but I'm not sure if > kernel can predict the swiotlb reserved size automatically. Do you see how even more absurd this gets? If the kernel cannot know the swiotlb reserved size

Re: [PATCH] acpi/nfit: Fix bus command validation

2019-02-20 Thread Johannes Thumshirn
On 20/02/2019 03:58, Dan Williams wrote: [...] >> >> Tricky code path, eh? > > ioctl path, number one source of bugs / thrash in this subsystem. 2nd > place, ARS. Possibly unpopular idea, but should we maybe teach trinity/syzcaller about these ioctl()s? Better we find the bugs in a QA like

[PATCH v3 -next] tpm: Fix the type of the return value in calc_tpm2_event_size()

2019-02-20 Thread Yue Haibing
calc_tpm2_event_size() has an invalid signature because it returns a 'size_t' where as its signature says that it returns 'int'. Cc: Fixes: 4d23cc323cdb ("tpm: add securityfs support for TPM 2.0 firmware event log") Suggested-by: Jarkko Sakkinen Signed-off-by: Yue Haibing --- v3: fix My real

Re: [PATCH] soc: imx: gpcv2: Make use of regmap_read_poll_timeout()

2019-02-20 Thread Lucas Stach
Am Dienstag, den 19.02.2019, 18:14 -0800 schrieb Andrey Smirnov: > Replace explicit polling loop with a call to > regmap_read_poll_timeout() to avoid code repetition. Also fix > misspelled "failed" while at it. > > Signed-off-by: Andrey Smirnov > Cc: Lucas Stach > Cc: Chris Healy > Cc:

Re: [PATCH] x86/asm: Pin sensitive CR4 bits

2019-02-20 Thread Dominik Brodowski
On Tue, Feb 19, 2019 at 04:54:49PM -0800, Kees Cook wrote: > diff --git a/arch/x86/kernel/cpu/common.c b/arch/x86/kernel/cpu/common.c > index cb28e98a0659..7e0ea4470f8e 100644 > --- a/arch/x86/kernel/cpu/common.c > +++ b/arch/x86/kernel/cpu/common.c > @@ -312,10 +312,16 @@ static __init int

Re: [PATCH v3 5/5] arm64: dts: imx8mq-evk: Enable PCIE0 interface

2019-02-20 Thread Lucas Stach
Am Dienstag, den 19.02.2019, 17:58 -0800 schrieb Andrey Smirnov: > Enable PCIE0 interface connected to BCM4356 WiFi/Bluetooth module. > > Signed-off-by: Andrey Smirnov > Cc: Shawn Guo > Cc: Fabio Estevam > Cc: Chris Healy > Cc: Lucas Stach > Cc: Leonard Crestez > Cc: "A.s. Dong" > Cc:

Re: [RFC PATCH net-next v3 05/21] ethtool: netlink bitset handling

2019-02-20 Thread Michal Kubecek
On Tue, Feb 19, 2019 at 06:27:59PM -0800, Jakub Kicinski wrote: > On Mon, 18 Feb 2019 19:21:49 +0100 (CET), Michal Kubecek wrote: > > + else if (is_u32) > > + bitmap_from_arr32(val, bitmap, nbits); > > + else > > + bitmap_copy(val, bitmap,

Re: [PATCH] dt-bindings: imx: update scu resource id headfile

2019-02-20 Thread Marco Felsch
On 19-02-20 03:38, Aisheng Dong wrote: > [...] > > > > I don't like droping some ID's (e.g. IMX_SC_R_DC_0_CAPTURE0) by mark > > > them as unused or even worse give them a other meaning. IMHO the > > > scu-api should be stable since day 1 and the ID's should only be extended. > > > Marking ID's as

[PATCH 1/3] regulator: tps65218.c: fix LS3 issues

2019-02-20 Thread Christian Hohnstaedt
- Fix list of valid LS3 currents from mA to µA - Fix selection of min/max microAmps of LS3. Selecting one of the configured values as max value now really selects it instead of the next lower one Signed-off-by: Christian Hohnstaedt --- drivers/regulator/tps65218-regulator.c | 5 +++-- 1

[PATCH 2/3] dt-bindings: regulator: Add LS2 load switch

2019-02-20 Thread Christian Hohnstaedt
and change units of LS3 example from microvolt to microamp Signed-off-by: Christian Hohnstaedt --- Documentation/devicetree/bindings/regulator/tps65218.txt | 9 +++-- 1 file changed, 7 insertions(+), 2 deletions(-) diff --git a/Documentation/devicetree/bindings/regulator/tps65218.txt

Re: [PATCH] HID: roccat: Mark expected switch fall-through

2019-02-20 Thread Stefan Achatz
Am Dienstag, den 19.02.2019, 14:16 +0100 schrieb Jiri Kosina: > On Mon, 11 Feb 2019, Gustavo A. R. Silva wrote: > > > In preparation to enabling -Wimplicit-fallthrough, mark switch > > cases where we are expecting to fall through. > > > > This patch fixes the following warning: > > > >

[PATCH 3/3] regulator: tps65218: Add support for LS2

2019-02-20 Thread Christian Hohnstaedt
Re-use the "tps65218_pmic_*_current_limit()" functions of LS3 and calculate the different required bit-shift by counting the trailing 0s in "struct regulator_desc.csel_mask" Signed-off-by: Christian Hohnstaedt --- drivers/regulator/tps65218-regulator.c | 18 +- 1 file changed,

[PATCH 0/3] regulator: tps65218: Fix LS3 and add LS2

2019-02-20 Thread Christian Hohnstaedt
The patch-series fixes issues in the LS3 configuration and adds support for the LS2 regulator in the tps65218 Christian Hohnstaedt (3): regulator: tps65218.c: fix LS3 issues dt-bindings: regulator: Add LS2 load switch regulator: tps65218: Add support for LS2

RE: [PATCH] arm64: dts: ls1028a: Add Audio DT nodes

2019-02-20 Thread Alison Wang
Hi, Shawn, > On Wed, Jan 23, 2019 at 01:21:35PM +0800, Alison Wang wrote: > > This patch adds Audio DT nodes for LS1028ARDB and LS1028AQDS boards. > > > > Signed-off-by: Alison Wang > > --- > > arch/arm64/boot/dts/freescale/fsl-ls1028a-qds.dts | 62 > > >

Re: [PATCH 1/2 v2] kprobe: Do not use uaccess functions to access kernel memory that can fault

2019-02-20 Thread Masami Hiramatsu
On Tue, 19 Feb 2019 14:03:30 -0500 Steven Rostedt wrote: > > > Basically, a kprobe is mostly used for debugging what's happening in a > > > live kernel, to read any address. > > > > My point is that "any address" is not sufficient to begin with. You > > need "kernel or user". > > > > Having

[GIT PULL] pin control fixes for v5.0

2019-02-20 Thread Linus Walleij
Hi Linus, some final pin control fixes (I hope) to round off the v5.0 pin control development cycle. Only driver fixes, one for stable. Please pull them in! Yours, Linus Walleij The following changes since commit d13937116f1e82bf508a6325111b322c30c85eb9: Linux 5.0-rc6 (2019-02-10 14:42:20

Re: [PATCH v2] jffs2: safely remove obsolete dirent from the f->dents list

2019-02-20 Thread Richard Weinberger
Am Samstag, 16. Februar 2019, 09:53:35 CET schrieb yuyufen: > ping? Sorry for the delay. I didn't forget (completely) about this one. The thing is, I don't really maintain jffs2 but I will collect and test patches for the upcoming merge window and carry them via my ubifs tree. David, I hope I

Re: [PATCH v1 1/2] arm64: dts: renesas: r8a7795: use extended audio dmac register

2019-02-20 Thread Geert Uytterhoeven
On Wed, Feb 20, 2019 at 6:25 AM Jiada Wang wrote: > Basic audio dmac register only supports busif from 0 to 3, > in order to use busif4 ~ busif7, extended audio dmac register > need to be used. > > Signed-off-by: Jiada Wang Reviewed-by: Geert Uytterhoeven but please consider my comments to the

Re: [PATCH v1 2/2] arm64: dts: renesas: r8a7796: use extended audio dmac register

2019-02-20 Thread Geert Uytterhoeven
On Wed, Feb 20, 2019 at 6:25 AM Jiada Wang wrote: > Basic audio dmac register only supports busif from 0 to 3, > in order to use busif4 ~ busif7, extended audio dmac register > need to be used > > Signed-off-by: Jiada Wang Reviewed-by: Geert Uytterhoeven but please consider my comments to the

Re: [PATCH v1 0/2] rsnd: dts: change to use extended audio dmac register

2019-02-20 Thread Geert Uytterhoeven
Hi Jiada, On Wed, Feb 20, 2019 at 6:25 AM Jiada Wang wrote: > According to user reference manual for R-CAR H3 and M3-W SoCs, > in order to access busif4 ~ busif7, extended audio dmac registers > (PDMASAREn, PDMADAREn, PDMACHCREn) > need to be used, rather than basic audio dmac registers >

[GIT PULL] GPIO fixes for the v5.0 series

2019-02-20 Thread Linus Walleij
Hi Linus, some final polish for GPIO for v5.0. Both patches are also tagged for stable. Please pull them in! Yours, Linus Walleij The following changes since commit 8834f5600cf3c8db365e18a3d5cac2c2780c81e5: Linux 5.0-rc5 (2019-02-03 13:48:04 -0800) are available in the Git repository at:

<    7   8   9   10   11   12