Re: [PATCH] pata_ipx4xx_cf: Fix unsigned comparison with less than zero

2021-04-10 Thread Sergei Shtylyov
On 10.04.2021 2:38, angkery wrote: On Fri, 9 Apr 2021 20:02:56 +0300 Sergei Shtylyov wrote: On 4/9/21 7:49 PM, Sergei Shtylyov wrote: From: Junlin Yang The return from the call to platform_get_irq() is int, it can be a negative error code, however this is being assigned to an unsigned int

Re: [PATCH] perf session: Dump PERF_RECORD_TIME_CONV event

2021-04-10 Thread Adrian Hunter
On 10/04/21 6:19 am, Leo Yan wrote: > Now perf tool uses the common stub function process_event_op2_stub() for > dumping TIME_CONV event, thus it doesn't output the clock parameters > contained in the event. > > This patch adds the callback function for dumping the hardware clock > parameters in T

Re: [PATCH] tty: n_gsm: check error while registering tty devices

2021-04-10 Thread Greg KH
On Wed, Apr 07, 2021 at 04:21:30PM +0800, Hillf Danton wrote: > On Wed, 7 Apr 2021 07:37:53 Jiri Slaby wrote: > > > >Yes, the fix makes sense. > > Thanks for taking a look. > > >But could you elaborate in the commit log when this happens? > >I only wonder how real this is. I assume you inject fau

Re: [PATCH v7 clocksource 2/5] clocksource: Retry clock read if long delays detected

2021-04-10 Thread Thomas Gleixner
On Fri, Apr 02 2021 at 15:49, paulmck wrote: > This commit therefore re-reads the watchdog clock on either side of 'This commit' is not any better than 'This patch' and this sentence makes no sense. I might be missing something, but how exactly does "the commit" re-read the watchdog clock? git g

Re: [PATCH v6 3/6] w1: ds2438: fixed a coding style issue

2021-04-10 Thread Greg KH
On Fri, Apr 09, 2021 at 12:15:30AM -0300, Luiz Sampaio wrote: > Changed the permissions to preferred octal style. > > Signed-off-by: Luiz Sampaio > --- > drivers/w1/slaves/w1_ds2438.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/w1/slaves/w1_ds2438.c b/driver

Re: [PATCH v3] powerpc/traps: Enhance readability for trap types

2021-04-10 Thread Xiongwei Song
> On Apr 10, 2021, at 8:04 AM, Michael Ellerman wrote: > > Christophe Leroy writes: >> Le 08/04/2021 à 16:07, Xiongwei Song a écrit : >>> From: Xiongwei Song >>> >>> Create a new header named traps.h, define macros to list ppc interrupt >>> types in traps.h, replace the reference of the trap

Re: [PATCH v2 1/1] efi/dev-path-parser: Switch to use for_each_acpi_dev_match()

2021-04-10 Thread Ard Biesheuvel
On Sun, 4 Apr 2021 at 20:12, Andy Shevchenko wrote: > > Switch to use for_each_acpi_dev_match() instead of home grown analogue. > No functional change intended. > > Signed-off-by: Andy Shevchenko > --- > v2: fixed refcounting > (example from which I took the v1 approach has been broken, fix i

Re: [PATCH 0/6] staging: rtl8192e: cleanup patchset for style issues

2021-04-10 Thread Greg KH
On Sat, Apr 10, 2021 at 07:04:23AM +0530, Mitali Borkar wrote: > This patches fix the cleanup style issues. > > Mitali Borkar (6): > staging: rtl8192e: add spaces around binary operators > staging: rtl8192e: remove unnecessary blank line before brace > staging: rtl8192e: remove unncessary bl

Re: [PATCH v3] powerpc/traps: Enhance readability for trap types

2021-04-10 Thread Xiongwei Song
> On Apr 10, 2021, at 12:14 AM, Christophe Leroy > wrote: > > > > Le 08/04/2021 à 16:07, Xiongwei Song a écrit : >> From: Xiongwei Song >> Create a new header named traps.h, define macros to list ppc interrupt >> types in traps.h, replace the reference of the trap hex values with these >> m

Re: [Outreachy kernel] [Patch 0/3]

2021-04-10 Thread Julia Lawall
On Sat, 10 Apr 2021, Greg KH wrote: > On Sat, Apr 10, 2021 at 09:57:00AM +0200, Fabio M. De Francesco wrote: > > On Saturday, April 10, 2021 9:29:29 AM CEST Greg KH wrote: > > > On Fri, Apr 09, 2021 at 06:29:59PM +0200, Fabio M. De Francesco wrote: > > > > This patch series removes camelcases,

Re: [Outreachy kernel] [Patch 0/3]

2021-04-10 Thread Julia Lawall
On Sat, 10 Apr 2021, Fabio M. De Francesco wrote: > On Saturday, April 10, 2021 9:29:29 AM CEST Greg KH wrote: > > On Fri, Apr 09, 2021 at 06:29:59PM +0200, Fabio M. De Francesco wrote: > > > This patch series removes camelcases, changes the type and use of a > > > variable, and correct misspel

Re: [PATCH 2/2] iommu/amd: Remove performance counter pre-initialization test

2021-04-10 Thread David Coe
Well, well! This is a promising start to the weekend. Thank you both, Suravee and Paul. Results for AMD Ryzen 4 2400G running Ubuntu 21.04β kernel 5.11.0-13 and Windows 10 2H2 under KVM $ sudo dmesg | grep IOMMU [0.557725] pci :00:00.2: AMD-Vi: IOMMU performance counters supported [

Re: [PATCH 04/12] ARM: pxa: stargate2: Constify the software node

2021-04-10 Thread Robert Jarzmik
Wolfram Sang writes: > On Mon, Mar 29, 2021 at 01:50:39PM +0300, Heikki Krogerus wrote: >> Additional device properties are always just a part of a >> software fwnode. If the device properties are constant, the >> software node can also be constant. >> >> Signed-off-by: Heikki Krogerus >> Cc: J

Re: [Outreachy kernel] [PATCH 1/3] staging: rtl8192e: replace comparison to NULL by boolean

2021-04-10 Thread Julia Lawall
On Sat, 10 Apr 2021, Mitali Borkar wrote: > Replaced comparison to NULL by boolean expressions > (here used boolean negations). This improves readability of code. > Reported by checkpatch. > > Signed-off-by: Mitali Borkar > --- > drivers/staging/rtl8192e/rtl819x_HTProc.c | 10 +- > 1

Re: [PATCH] ARM: pxa: mainstone: avoid -Woverride-init warning

2021-04-10 Thread Robert Jarzmik
Arnd Bergmann writes: > From: Arnd Bergmann > > On Tue, 23 Mar 2021 14:08:27 +0100, Arnd Bergmann wrote: >> The default initializer at the start of the array causes a warning >> when building with W=1: >> >> In file included from arch/arm/mach-pxa/mainstone.c:47: >> arch/arm/mach-pxa/mainstone.

Re: [PATCH 1/2] dt-bindings: soc: qcom: Add bindings for Qualcomm Memshare service

2021-04-10 Thread Nikita Travkin
Hi, sorry for a late reply but I couldn't answer earlier. 30.03.2021 19:40, Rob Herring пишет: > On Fri, Mar 19, 2021 at 10:23:20PM +0500, nikitos...@gmail.com wrote: >> From: Nikita Travkin >> >> Add DT bindings for memshare: QMI service that allocates >> memory per remote processor request. >>

Re: [Outreachy kernel] [Patch 0/3]

2021-04-10 Thread Greg KH
On Sat, Apr 10, 2021 at 09:57:00AM +0200, Fabio M. De Francesco wrote: > On Saturday, April 10, 2021 9:29:29 AM CEST Greg KH wrote: > > On Fri, Apr 09, 2021 at 06:29:59PM +0200, Fabio M. De Francesco wrote: > > > This patch series removes camelcases, changes the type and use of a > > > variable, an

Re: [PATCH v7 clocksource] Do not mark clocks unstable due to delays for v5.13

2021-04-10 Thread Thomas Gleixner
On Fri, Apr 02 2021 at 15:48, Paul E. McKenney wrote: > Hello! > > If there is a sufficient delay between reading the watchdog clock and the > clock under test, the clock under test will be marked unstable through no > fault of its own. This series checks for this, doing limited retries > to get a

Re: [Outreachy kernel] [Patch 0/3]

2021-04-10 Thread Fabio M. De Francesco
On Saturday, April 10, 2021 9:29:29 AM CEST Greg KH wrote: > On Fri, Apr 09, 2021 at 06:29:59PM +0200, Fabio M. De Francesco wrote: > > This patch series removes camelcases, changes the type and use of a > > variable, and correct misspelled words. > > > > Patch 1/3: staging: rtl8723bs: Remove came

Re: [PATCH] hrtimer: avoid retrigger_next_event IPI

2021-04-10 Thread Thomas Gleixner
On Fri, Apr 09 2021 at 13:51, Marcelo Tosatti wrote: > On Fri, Apr 09, 2021 at 04:15:13PM +0200, Thomas Gleixner wrote: >> On Wed, Apr 07 2021 at 10:53, Marcelo Tosatti wrote: >> ---> fail because that newly started timer is on the old offset. > > CPU0

[PATCH] drm/nouveau/nvkm: Remove unnecessary assignment

2021-04-10 Thread Wan Jiabing
The declaration with assignment here is confusing. Remove the unnecessary assignment. Signed-off-by: Wan Jiabing --- drivers/gpu/drm/nouveau/nvkm/subdev/instmem/nv50.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/nouveau/nvkm/subdev/instmem/nv50.c b/driver

[PATCH] preempt/dynamic: fix typo in macro conditional statement

2021-04-10 Thread Zhouyi Zhou
commit 40607ee97e4e ("preempt/dynamic: Provide irqentry_exit_cond_resched() static call") tried to provide irqentry_exit_cond_resched() static call in irqentry_exit, but has a typo in macro conditional statement. This patch fix this typo. Signed-off-by: Zhouyi Zhou --- kernel/entry/common.c |

Re: [PATCH] mm/frontswap: fix frontswap_register_ops() race with swapon and swapoff

2021-04-10 Thread Miaohe Lin
Hi: On 2021/4/5 18:20, Miaohe Lin wrote: > frontswap_register_ops can race with swapon. Consider the following scene: Any comment or suggestion? Or is this race window too theoretical to fix? Thanks. > > CPU1 CPU2 > > fr

Re: [Outreachy kernel] [Resend Patch 0/3] staging: rtl8723bs: Patchset for rtl8723bs

2021-04-10 Thread Greg KH
On Fri, Apr 09, 2021 at 06:39:31PM +0200, Fabio M. De Francesco wrote: > This patch series removes camelcase, changes the type and use of a > variable, and correct misspelled words. > > Patch 1/3: staging: rtl8723bs: Remove camelcase in several files I've again, dropped all patches from you fr

Re: [Outreachy kernel] [Patch 0/3]

2021-04-10 Thread Greg KH
On Fri, Apr 09, 2021 at 06:29:59PM +0200, Fabio M. De Francesco wrote: > This patch series removes camelcases, changes the type and use of a > variable, and correct misspelled words. > > Patch 1/3: staging: rtl8723bs: Remove camelcase in several files > > drivers/staging/rtl8723bs/core/rtw_cmd.c

Re: [PATCH 5.4 00/23] 5.4.111-rc1 review

2021-04-10 Thread Naresh Kamboju
On Fri, 9 Apr 2021 at 15:29, Greg Kroah-Hartman wrote: > > This is the start of the stable review cycle for the 5.4.111 release. > There are 23 patches in this series, all will be posted as a response > to this one. If anyone has any issues with these being applied, please > let me know. > > Resp

Re: [PATCH] mm/memory_hotplug: Make unpopulated zones PCP structures unreachable during hot remove

2021-04-10 Thread Michal Hocko
On Fri 09-04-21 16:12:59, Mel Gorman wrote: [...] > If anything, the minimal "fix" is to simply delete IRQ disable/enable on > the grounds that IRQs protect nothing and assume the existing hotplug > paths guarantees the PCP cannot be used after zone_pcp_enable(). That > should be the case already b

[PATCH v2 1/5] mm/hugeltb: remove redundant VM_BUG_ON() in region_add()

2021-04-10 Thread Miaohe Lin
The same VM_BUG_ON() check is already done in the callee. Remove this extra one to simplify the code slightly. Reviewed-by: Mike Kravetz Signed-off-by: Miaohe Lin --- mm/hugetlb.c | 1 - 1 file changed, 1 deletion(-) diff --git a/mm/hugetlb.c b/mm/hugetlb.c index c22111f3da20..a03a50b7c410 100

[PATCH v2 4/5] mm/hugeltb: handle the error case in hugetlb_fix_reserve_counts()

2021-04-10 Thread Miaohe Lin
A rare out of memory error would prevent removal of the reserve map region for a page. hugetlb_fix_reserve_counts() handles this rare case to avoid dangling with incorrect counts. Unfortunately, hugepage_subpool_get_pages and hugetlb_acct_memory could possibly fail too. We should correctly handle t

[PATCH v2 3/5] mm/hugeltb: clarify (chg - freed) won't go negative in hugetlb_unreserve_pages()

2021-04-10 Thread Miaohe Lin
The resv_map could be NULL since this routine can be called in the evict inode path for all hugetlbfs inodes and we will have chg = 0 in this case. But (chg - freed) won't go negative as Mike pointed out: "If resv_map is NULL, then no hugetlb pages can be allocated/associated with the file. As

[PATCH v2 0/5] Cleanup and fixup for hugetlb

2021-04-10 Thread Miaohe Lin
Hi all, This series contains cleanups to remove redundant VM_BUG_ON() and simplify the return code. Also this handles the error case in hugetlb_fix_reserve_counts() correctly. More details can be found in the respective changelogs. Thanks! v1->v2: collect Reviewed-by tag remove the HPAGE_RESV_

[PATCH v2 5/5] mm/hugetlb: remove unused variable pseudo_vma in remove_inode_hugepages()

2021-04-10 Thread Miaohe Lin
The local variable pseudo_vma is not used anymore. Signed-off-by: Miaohe Lin --- fs/hugetlbfs/inode.c | 3 --- 1 file changed, 3 deletions(-) diff --git a/fs/hugetlbfs/inode.c b/fs/hugetlbfs/inode.c index d81f52b87bd7..a2a42335e8fd 100644 --- a/fs/hugetlbfs/inode.c +++ b/fs/hugetlbfs/inode.c @@

[PATCH v2 2/5] mm/hugeltb: simplify the return code of __vma_reservation_common()

2021-04-10 Thread Miaohe Lin
It's guaranteed that the vma is associated with a resv_map, i.e. either VM_MAYSHARE or HPAGE_RESV_OWNER, when the code reaches here or we would have returned via !resv check above. So it's unneeded to check whether HPAGE_RESV_OWNER is set here. Simplify the return code to make it more clear. Signe

Re: [PATCH 5.10 00/41] 5.10.29-rc1 review

2021-04-10 Thread Naresh Kamboju
On Fri, 9 Apr 2021 at 15:30, Greg Kroah-Hartman wrote: > > This is the start of the stable review cycle for the 5.10.29 release. > There are 41 patches in this series, all will be posted as a response > to this one. If anyone has any issues with these being applied, please > let me know. > > Resp

Re: [PATCH v5] ACPI / APEI: fix the regression of synchronous external aborts occur in user-mode

2021-04-10 Thread Xiaofei Tan
Hi James, Boris a friendly ping.. any comments for this ? On 2021/2/5 20:55, Rafael J. Wysocki wrote: On Tue, Jan 26, 2021 at 2:32 PM tanxiaofei wrote: @James Hi James, please help to review this patch. Thank you very much. :) James, Boris, any comments? On 2020/12/10 20:09, Xiaofei Tan

[PATCH] Documentation: dev-tools: Add Testing Overview

2021-04-10 Thread David Gow
The kernel now has a number of testing and debugging tools, and we've seen a bit of confusion about what the differences between them are. Add a basic documentation outlining the testing tools, when to use each, and how they interact. This is a pretty quick overview rather than the idealised "ker

Re: [PATCH v2] kconfig: nconf: stop endless search-up loops

2021-04-10 Thread Mihai Moldovan
* On 4/10/21 7:47 AM, Masahiro Yamada wrote: > On Sun, Mar 28, 2021 at 6:52 PM Mihai Moldovan wrote: >> + if ((index == -1) && (index == match_start)) >> + return -1; > > We know 'index' is -1 in the second comparison. > So, you can also write like this: > >

Re: [PATCH -next] i2c: omap: fix PM reference leak in omap_i2c_probe()

2021-04-10 Thread Vignesh Raghavendra
Hi. On 4/8/21 6:26 PM, Li Huafei wrote: > pm_runtime_get_sync will increment pm usage counter even it failed. > Forgetting to putting operation will result in reference leak here. Fix > it by replacing it with pm_runtime_resume_and_get to keep usage counter > balanced. > > Reported-by: Hulk Robot

<    1   2   3   4   5