On 10/4/24 06:44, Martin KaFai Lau wrote:
> On 9/24/24 6:37 PM, Martin KaFai Lau wrote:
>> There are other .sh tests that could better use the test_progs migration. In
>> particular the ones without existing test coverage. For non XDP related,
>> test_tcp_check_syncookie.sh, test_flow_dissector.sh,
On Fri, Oct 04, 2024 at 02:32:28PM +1000, Alexey Kardashevskiy wrote:
> > +/**
> > + * struct iommu_viommu_set_vdev_id - ioctl(IOMMU_VIOMMU_SET_VDEV_ID)
> > + * @size: sizeof(struct iommu_viommu_set_vdev_id)
> > + * @viommu_id: viommu ID to associate with the device to store its virtual
> > ID
> >
On 10/3/24 17:42, Stephen Boyd wrote:
Quoting Guenter Roeck (2024-10-03 17:25:37)
On 10/3/24 16:46, Stephen Boyd wrote:
[ ... ]
That DT test has been there for a few releases. Is this the first time
those tests have been run on arm64+acpi? I didn't try after sending the
patches and forgot that
On 9/24/24 6:37 PM, Martin KaFai Lau wrote:
There are other .sh tests that could better use the test_progs migration. In
particular the ones without existing test coverage. For non XDP related,
test_tcp_check_syncookie.sh, test_flow_dissector.sh, and test_tc_edt.sh should
be the good ones.
I
On 28/8/24 02:59, Nicolin Chen wrote:
Introduce a pair of new ioctls to set/unset a per-viommu virtual device id
that should be linked to a physical device id via an idev pointer.
Continue the support IOMMU_VIOMMU_TYPE_DEFAULT for a core-managed viommu.
Provide a lookup function for drivers to l
Add a new UAPI to support setting the vhost device to
use task mode. The user space application needs to use
VHOST_SET_INHERIT_FROM_OWNER to set the mode.
This setting must be set before VHOST_SET_OWNER is set.
Signed-off-by: Cindy Lu
---
drivers/vhost/vhost.c | 18 +-
inclu
Split the function vhost_worker_create to support both task and kthread
Added back the previous old function vhost_worker_create and rename it to
vhost_worker_create_khtread to support the khtread.
The new vhost_worker_create will be selected which to use based on the
value of the parameter.
the
Add back the previously removed cgroup function to support the kthread
The biggest change for this part is in vhost_attach_cgroups() and
vhost_worker_cgroups_kthread(). This is because of the change in
struct dev->worker_xa.
The old function was remove in
commit 6e890c5d5021 ("vhost: use vhost_tas
Add back the previously removed vhost_worker function to support the kthread
and rename it vhost_run_work_kthread_list.
The old function vhost_worker was change to support task in
commit 6e890c5d5021 ("vhost: use vhost_tasks for worker threads")
change to xarray in
commit 1cdaafa1b8b4 ("vhost: rep
Added back the previously removed function vhost_workers_free() and
renamed it to vhost_workers_free_khtread(). The new vhost_workers_free()
will select the different mode based on the value of the parameter.
The old function vhost_workers_free was change to support task in
commit 6e890c5d5021 ("v
Added back the previously removed function vhost_worker_queue() and
renamed it to vhost_worker_queue_khtread(). The new vhost_worker_queue()
will select the different mode based on the value of the parameter.
The old function vhost_work_queue() was change to support task in
commit 6e890c5d5021 ("
The vhost is now using vhost_task and working as a child of the owner thread.
While this makes sense from containerization POV, some old userspace is
confused, as previously vhost not and so was allowed to steal cpu resources
from outside the container. So we add the kthread API support back
Add a
In commit 6e890c5d5021 ("vhost: use vhost_tasks for worker threads"),
vhost is now a child of the owner thread. but some old userspace is confused,
In these patch we will let userspace to select the mode
In this PATCH, the support of kthread is added back.
a module_param is added to select which
Quoting Guenter Roeck (2024-10-03 17:25:37)
> On 10/3/24 16:46, Stephen Boyd wrote:
> [ ... ]
> > That DT test has been there for a few releases. Is this the first time
> > those tests have been run on arm64+acpi? I didn't try after sending the
> > patches and forgot that the patch was dropped.
> >
On Wed, Oct 2, 2024 at 5:12 PM Daniel Xu wrote:
>
> This commit allows progs to elide a null check on statically known map
> lookup keys. In other words, if the verifier can statically prove that
> the lookup will be in-bounds, allow the prog to drop the null check.
>
> This is useful for two reas
On 10/3/24 16:46, Stephen Boyd wrote:
[ ... ]
That DT test has been there for a few releases. Is this the first time
those tests have been run on arm64+acpi? I didn't try after sending the
patches and forgot that the patch was dropped.
Previously I had the affected tests disabled and never tra
On 10/2/24 00:15, Anders Roxell wrote:
On Wed, 25 Sept 2024 at 19:26, Shuah Khan wrote:
On 9/20/24 04:38, Jakub Kicinski wrote:
On Thu, 19 Sep 2024 09:51:47 -0600 Shuah Khan wrote:
@@ -261,6 +261,7 @@ ifdef INSTALL_PATH
@ret=1; \
for TARGET in $(TARGETS) $(INSTALL_DEP_TARGETS); do
Hello:
This patch was applied to netdev/net-next.git (main)
by Jakub Kicinski :
On Mon, 30 Sep 2024 12:29:34 -0400 you wrote:
> Rename ip_len to payload_len since the length in this case refers only
> to the payload, and not the entire IP packet like for IPv4. While we're
> at it, just use the va
Quoting Guenter Roeck (2024-09-28 14:32:35)
> On 9/28/24 12:27, Shuah Khan wrote:
> > On 9/28/24 11:54, Shuah Khan wrote:
> >> On 9/28/24 11:31, Guenter Roeck wrote:
> >>> On 9/27/24 17:08, Guenter Roeck wrote:
> On 9/27/24 13:45, Shuah Khan wrote:
> > On 9/27/24 10:19, Guenter Roeck wrote
Ackerley Tng writes:
> Elliot Berman writes:
>
>> On Tue, Sep 10, 2024 at 11:44:01PM +, Ackerley Tng wrote:
>>> Since guest_memfd now supports mmap(), folios have to be prepared
>>> before they are faulted into userspace.
>>>
>>> When memory attributes are switched between shared and private
On 10/2/24 16:51, Jason A. Donenfeld wrote:
Wasn't this already submitted and commented on?
https://lore.kernel.org/all/20240919111841.20226-1-liaoy...@huawei.com/
Thank you Jason. Yes we reviewed this - I asked Yu Liao to send
me v2 since the define is coming in from pthread.h indirectly.
Su
On Thu, Oct 3, 2024 at 10:21 AM Mathieu Desnoyers
wrote:
> >
> > Reviewed-by: Joel Fernandes (Google)
>
> Please double-check with -O2, and let me know if you still agree with
> the patch :)
>
You are quite right, with -O2 I can indeed see that the optimize hide
var fixes it.
FWIW:
Tested-by: J
On 9/21/24 17:15, Vinicius Peixoto wrote:
Hi all,
On 9/3/24 18:36, Diego Vieira wrote:
Hi all,
This is part of a hackathon organized by LKCAMP [1], focused on writing
tests using KUnit. We reached out a while ago asking for advice on what would
be a useful contribution [2] and ended up choosin
Elliot Berman writes:
> On Tue, Sep 10, 2024 at 11:44:01PM +, Ackerley Tng wrote:
>> Since guest_memfd now supports mmap(), folios have to be prepared
>> before they are faulted into userspace.
>>
>> When memory attributes are switched between shared and private, the
>> up-to-date flags will
On Android with arm, there is some synchronization needed to avoid a
deadlock when forking after pthread_create.
Fixes: cff294582798 ("selftests/mm: extend and rename uffd pagemap test")
Signed-off-by: Edward Liaw
---
tools/testing/selftests/mm/uffd-unit-tests.c | 7 +++
1 file changed, 7 in
Swaps synchronization primitive with pthread_barrier, so that
stdatomic.h does not need to be included.
The synchronization is needed on Android ARM64; we see a deadlock with
pthread_create when the parent thread races forward before the child has
a chance to start doing work.
Fixes: 8c864371b2a1
On Android arm, pthread_create followed by a fork caused a deadlock in
the case where the fork required work to be completed by the created
thread.
Updated the synchronization primitive to use pthread_barrier instead of
atomic_bool.
Applied the same fix to the wp-fork-with-event test.
Edward Lia
t_data,
+};
+kunit_test_suite(crc16_test_suite);
+
+MODULE_AUTHOR("Fabricio Gasperin ");
+MODULE_AUTHOR("Vinicius Peixoto ");
+MODULE_AUTHOR("Enzo Bertoloti ");
+MODULE_DESCRIPTION("Unit tests for crc16");
+MODULE_LICENSE("GPL");
---
base-commit: 9852d85ec9d492ebef56dc5f229416c925758edc
change-id: 20241003-crc16-kunit-127a4dc2b72c
Best regards,
--
Vinicius Peixoto
On Thu, Oct 03, 2024 at 12:48:22PM -0700, Luis Chamberlain wrote:
+ linux-modu...@vger.kernel.org + Lucas
On Mon, Sep 30, 2024 at 07:03:52PM +0200, Aleksandr Mikhalitsyn wrote:
On Mon, Sep 30, 2024 at 5:43 PM Stefano Garzarella wrote:
>
> Hi Aleksandr,
>
> On Mon, Sep 30, 2024 at 04:43:36PM GM
Elliot Berman writes:
> On Tue, Sep 10, 2024 at 11:43:46PM +, Ackerley Tng wrote:
>> If HugeTLB is requested at guest_memfd creation time, HugeTLB pages
>> will be used to back guest_memfd.
>>
>> Signed-off-by: Ackerley Tng
>>
>>
>>
>> +/**
>> + * Use the uptodate flag to indicate that the
Previously when retrieving `bpf_link_info.perf_event` for
kprobe/uprobe/tracepoint, the `name_len` field was not populated by the
kernel, leaving it to reflect the value initially set by the user. This
behavior was inconsistent with how other input/output string buffer
fields function (e.g. `raw_tr
+ linux-modu...@vger.kernel.org + Lucas
On Mon, Sep 30, 2024 at 07:03:52PM +0200, Aleksandr Mikhalitsyn wrote:
> On Mon, Sep 30, 2024 at 5:43 PM Stefano Garzarella
> wrote:
> >
> > Hi Aleksandr,
> >
> > On Mon, Sep 30, 2024 at 04:43:36PM GMT, Aleksandr Mikhalitsyn wrote:
> > >On Mon, Sep 30, 202
On Wed, Oct 02, 2024 at 09:38:39PM +, tyrone-wu wrote:
> Previously when retrieving `bpf_link_info.perf_event` for
> kprobe/uprobe/tracepoint, the `name_len` field was not populated by the
> kernel, leaving it to reflect the value initially set by the user. This
> behavior was inconsistent with
On 2024-10-03 19:07, David Laight wrote:
...
What _does_ work however are the following two approaches:
1) Perform the equality check on the original variables, creating
new versions (with OPTIMIZER_HIDE_VAR) of both variables for the
rest of their use, therefore making sure the pointer derefer
...
> What _does_ work however are the following two approaches:
>
> 1) Perform the equality check on the original variables, creating
> new versions (with OPTIMIZER_HIDE_VAR) of both variables for the
> rest of their use, therefore making sure the pointer dereference
> are not derived from versio
Hello,
syzbot found the following issue on:
HEAD commit:9852d85ec9d4 Linux 6.12-rc1
git tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/usb.git
usb-testing
console output: https://syzkaller.appspot.com/x/log.txt?x=1606e58058
kernel config: https://syzkaller.appspot.co
On Wed, Oct 02, 2024 at 12:59:55PM -0700, Andrii Nakryiko wrote:
> On Tue, Sep 3, 2024 at 3:08 PM Andrii Nakryiko
> wrote:
> >
> > On Tue, Sep 3, 2024 at 9:32 AM Paul E. McKenney wrote:
> > >
> > > Hello!
> > >
> > > This series provides light-weight readers for SRCU. This lightness
> > > is sel
On Tue, Oct 01, 2024 at 05:12:38PM +0200, Christian Brauner wrote:
> > Thanks for the info!
> >
> > >
> > > My preference is to keep the api consistent and require a stack_size for
> > > shadow stacks as well.
> >
> > Did you catch that a token can be at a different offsets location on the
> >
Hello Peter,
On Thu, Oct 03, 2024 at 05:32:31PM +0200, Peter Zijlstra wrote:
> On Thu, Oct 03, 2024 at 07:51:20AM -0700, Breno Leitao wrote:
> > Upstream kernel (6.12-rc1) has a new lockdep splat, that I am sharing to
> > get more visibility:
> >
> > WARNING: HARDIRQ-safe -> HARDIRQ-unsafe lo
On Thu, Oct 03, 2024 at 07:51:20AM -0700, Breno Leitao wrote:
> Upstream kernel (6.12-rc1) has a new lockdep splat, that I am sharing to
> get more visibility:
>
> WARNING: HARDIRQ-safe -> HARDIRQ-unsafe lock order detected
>
> This is happening because the HARDIRQ-irq-unsafe "_xmit_ETHER#2
On Thu, Oct 03, 2024 at 10:59:11PM +0800, zhang warden wrote:
> > This attribute specifies the sequence in which live patch modules
> > are applied to the system. If multiple live patches modify the same
> > function, the implementation with the highest stack order is used,
> > unless a transition
On Thu, Oct 03, 2024 at 07:51:20AM -0700, Breno Leitao wrote:
> Upstream kernel (6.12-rc1) has a new lockdep splat, that I am sharing to
> get more visibility:
>
> WARNING: HARDIRQ-safe -> HARDIRQ-unsafe lock order detected
>
> This is happening because the HARDIRQ-irq-unsafe "_xmit_ETHER#2
Hi, Petr.
> Also please rebase the patch on top of current Linus' master or
> v6.11. There are conflicts with the commit adb68ed26a3e922
> ("livepatch: Add "replace" sysfs attribute").
>
OK, will fix it.
+Contact:live-patch...@vger.kernel.org
+Description:
+ This attribut
Hi, Miroslav.
> On Oct 2, 2024, at 19:44, Miroslav Benes wrote:
>
> Hello,
>
> could you also include the selftests as discussed before, please?
>
> Miroslav
Should I include selftests in one patch?
Regards.
Wardenjohn.
Upstream kernel (6.12-rc1) has a new lockdep splat, that I am sharing to
get more visibility:
WARNING: HARDIRQ-safe -> HARDIRQ-unsafe lock order detected
This is happening because the HARDIRQ-irq-unsafe "_xmit_ETHER#2" lock is
acquired in virtnet_poll_tx() while holding the HARDIRQ-irq-sa
On 2024-10-03 02:08, Joel Fernandes wrote:
On Tue, Oct 01, 2024 at 09:02:02PM -0400, Mathieu Desnoyers wrote:
Compiler CSE and SSA GVN optimizations can cause the address dependency
of addresses returned by rcu_dereference to be lost when comparing those
pointers with either constants or previou
On Tue, 1 Oct 2024 at 07:35, Jason Gunthorpe wrote:
>
> On Mon, Sep 30, 2024 at 10:40:30AM -0600, Mathieu Poirier wrote:
> > On Mon, Aug 12, 2024 at 03:28:11PM +0800, Lu Baolu wrote:
> > > An iommu domain is allocated in rproc_enable_iommu() and is attached to
> > > rproc->dev.parent in the same f
On 2024-10-03 02:24, Boqun Feng wrote:
On Tue, Oct 01, 2024 at 09:02:04PM -0400, Mathieu Desnoyers wrote:
[...]
+/*
+ * hp_allocate: Allocate a hazard pointer.
+ *
+ * Allocate a hazard pointer slot for @addr. The object existence should
+ * be guaranteed by the caller.
+ *
+ * Returns a hazard
On 2024-10-03 03:50, 'Alan Stern' wrote:
On Wed, Oct 02, 2024 at 03:24:45PM +, David Laight wrote:
I think I know what you are trying to do, and you just fail.
Whether something can work is another matter, but that code
can't ever work.
Inside if (a == b) the compiler will always use the sa
On Thu 2024-10-03 16:06:59, zhang warden wrote:
> Hi,Miroslav.
>
> > could you also include the selftests as discussed before, please?
>
> Should I submit the selftests in one patch?
I would put it into a separate patch from the patch adding the
"stack_order" attribute.
You might split the sel
On Thu 2024-10-03 14:26:19, zhang warden wrote:
>
> Hi, Josh!
> > On Oct 1, 2024, at 07:26, Josh Poimboeuf wrote:
> >>
> >> diff --git a/Documentation/ABI/testing/sysfs-kernel-livepatch
> >> b/Documentation/ABI/testing/sysfs-kernel-livepatch
> >> index a5df9b4910dc..2a60b49aa9a5 100644
> >> ---
Yes, I ran it but faced an issue. After reading comments on a similar patch
shared by Jason A.
Donenfeld, I realized that my environment is Ubuntu 22.04 (Linux 5.15 + glibc
2.35).
After upgrading to a newer version of glibc, the issue seems to be fixed.
I think including might not be needed.
virtio_transport_send_pkt in now called on transport fast path,
under RCU read lock. In that case, we have a bug: virtio_add_sgs
is called with GFP_KERNEL, and might sleep.
Pass the gfp flags as an argument, and use GFP_ATOMIC on
the fast path.
Link:
https://lore.kernel.org/all/hfcr2aget2zojmqp
On Sun, Sep 29, 2024 at 10:03:23PM -0500, Bjorn Andersson wrote:
> On Fri, Sep 27, 2024 at 04:51:32PM GMT, Wasim Nazir wrote:
> > This test includes:
> > 1) Start/stop test for each rproc instance sequencially
> > 2) Start/stop test for all rproc instances concurrently
> >
>
> This fails
Hi Antonio,
kernel test robot noticed the following build warnings:
[auto build test WARNING on 44badc908f2c85711cb18e45e13119c10ad3a05f]
url:
https://github.com/intel-lab-lkp/linux/commits/Antonio-Quartulli/netlink-add-NLA_POLICY_MAX_LEN-macro/20241002-172734
base: 44badc908f2c85711cb18e4
On Wed, Oct 02, 2024 at 09:41:42AM GMT, Michael S. Tsirkin wrote:
> virtio_transport_send_pkt in now called on transport fast path,
> under RCU read lock. In that case, we have a bug: virtio_add_sgs
> is called with GFP_KERNEL, and might sleep.
>
> Pass the gfp flags as an argument, and use GFP_AT
Hello:
This patch was applied to netdev/net-next.git (main)
by Paolo Abeni :
On Fri, 27 Sep 2024 12:00:50 +0800 you wrote:
> From: zhang jiao
>
> There is no va_end after va_copy, just add it.
>
> Signed-off-by: zhang jiao
> ---
> tools/testing/selftests/net/tcp_ao/lib/aolib.h | 1 +
> 1 fil
57 matches
Mail list logo