[tip:sched/core] sched: Document task_struct::personality field

2013-04-14 Thread tip-bot for Andrei Epure
Commit-ID: 9b89f6ba2ab56e4d9c00e7e591d6bc333137895e Gitweb: http://git.kernel.org/tip/9b89f6ba2ab56e4d9c00e7e591d6bc333137895e Author: Andrei Epure AuthorDate: Thu, 11 Apr 2013 20:30:29 +0300 Committer: Ingo Molnar CommitDate: Fri, 12 Apr 2013 07:20:27 +0200 sched: Document

[PATCH v2] include:linux: task_struct personality comment

2013-04-11 Thread Andrei Epure
Signed-off-by: Andrei Epure --- include/linux/sched.h |4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/include/linux/sched.h b/include/linux/sched.h index d35d2b6..c6b2119 100644 --- a/include/linux/sched.h +++ b/include/linux/sched.h @@ -1274,8 +1274,10 @@ struct

Re: [PATCH] include:linux: task_struct personality comment

2013-04-10 Thread Andrei Epure
onality.h: > > > So the updated comment should say that. > Ok, thanks, I will send a v2. Andrei -- Andrei Epure -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.

[PATCH] include:linux: task_struct personality comment

2013-04-09 Thread Andrei Epure
Signed-off-by: Andrei Epure --- include/linux/sched.h |4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/include/linux/sched.h b/include/linux/sched.h index d35d2b6..8621bb0 100644 --- a/include/linux/sched.h +++ b/include/linux/sched.h @@ -1274,8 +1274,10 @@ struct

[PATCH 21/21] power: fix invalid free of devm_ allocated data

2013-03-27 Thread Andrei Epure
The objects allocated by devm_* APIs are managed by devres and are freed when the device is detached. Hence there is no need to use kfree() explicitly. Patch found using coccinelle. Signed-off-by: Andrei Epure --- drivers/power/88pm860x_charger.c |2 -- 1 file changed, 2 deletions(-) diff

[PATCH] power: pass IRQF_ONESHOT to request_threaded_irq()

2013-03-27 Thread Andrei Epure
Patch found using coccinelle. Signed-off-by: Andrei Epure --- drivers/power/ab8500_btemp.c |2 +- drivers/power/ab8500_charger.c |2 +- drivers/power/ab8500_fg.c|2 +- drivers/power/lp8788-charger.c |2 +- drivers/power/max17042_battery.c |3 ++- drivers

[PATCH] video: fix invalid free of devm_ allocated data

2013-03-27 Thread Andrei Epure
The objects allocated by devm_* APIs are managed by devres and are freed when the device is detached. Hence there is no need to use kfree() explicitly. Patch found using coccinelle. Signed-off-by: Andrei Epure --- drivers/video/vt8500lcdfb.c |3 --- drivers/video/wm8505fb.c|3 --- 2

[PATCH] video: fixed missing iounmap coccinelle errors

2013-03-27 Thread Andrei Epure
Modified or added the necessary goto statements so that the ioremapped regions get unmapped before return. Signed-off-by: Andrei Epure --- drivers/video/vt8500lcdfb.c |7 --- drivers/video/wm8505fb.c|7 --- 2 files changed, 8 insertions(+), 6 deletions(-) diff --git a

[PATCH] power: resource_size() instead of computation

2013-03-27 Thread Andrei Epure
Patch found using coccinelle. Signed-off-by: Andrei Epure --- drivers/power/goldfish_battery.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/power/goldfish_battery.c b/drivers/power/goldfish_battery.c index c10f460..29eba88 100644 --- a/drivers/power

[PATCH] power: kmemdup instead of kzalloc + memcpy

2013-03-27 Thread Andrei Epure
Patch found using coccinelle. Signed-off-by: Andrei Epure --- drivers/power/charger-manager.c |3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/power/charger-manager.c b/drivers/power/charger-manager.c index 8acc3f8..fefc39f 100644 --- a/drivers/power/charger

[PATCH] video: exynos: remove useless safety check in list traversal

2013-03-27 Thread Andrei Epure
list_for_each_entry_safe() does not require safety check. Patch found using coccinelle. Signed-off-by: Andrei Epure --- drivers/video/exynos/exynos_mipi_dsi.c | 16 ++-- 1 file changed, 6 insertions(+), 10 deletions(-) diff --git a/drivers/video/exynos/exynos_mipi_dsi.c b

[PATCH] video: mmp: removed reference preceded by free

2013-03-27 Thread Andrei Epure
Patch found with coccinelle. Signed-off-by: Andrei Epure --- drivers/video/mmp/core.c |2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/video/mmp/core.c b/drivers/video/mmp/core.c index 9ed8341..84de263 100644 --- a/drivers/video/mmp/core.c +++ b/drivers/video/mmp/core.c @@ -252,7

[PATCH] video: omap2: dss: use PTR_RET function

2013-03-27 Thread Andrei Epure
Use PTR_RET function instead of IS_ERR + PTR_ERR. Patch found using coccinelle. Signed-off-by: Andrei Epure --- drivers/video/omap2/dss/core.c |5 + 1 file changed, 1 insertion(+), 4 deletions(-) diff --git a/drivers/video/omap2/dss/core.c b/drivers/video/omap2/dss/core.c index f8779d4

[PATCH] video: exynos: Convert to devm_ioremap_resource()

2013-03-27 Thread Andrei Epure
The new devm_ioremap_resource() provides its own error messages. Patch found using coccinelle. Signed-off-by: Andrei Epure --- drivers/video/exynos/exynos_mipi_dsi.c |7 +++ 1 file changed, 3 insertions(+), 4 deletions(-) diff --git a/drivers/video/exynos/exynos_mipi_dsi.c b/drivers

[PATCH] drivers: video: matrox: changed kmalloc+memset with kzalloc

2013-03-27 Thread Andrei Epure
Signed-off-by: Andrei Epure --- drivers/video/matrox/matroxfb_base.c |3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/video/matrox/matroxfb_base.c b/drivers/video/matrox/matroxfb_base.c index 401a56e..2456529 100644 --- a/drivers/video/matrox/matroxfb_base.c

[tip:sched/core] sched: Fix variable name misnomer, add comments

2013-03-18 Thread tip-bot for Andrei Epure
Commit-ID: 1bf08230f745e48fea9c18ee34a73581631fe7c9 Gitweb: http://git.kernel.org/tip/1bf08230f745e48fea9c18ee34a73581631fe7c9 Author: Andrei Epure AuthorDate: Tue, 12 Mar 2013 21:12:24 +0200 Committer: Ingo Molnar CommitDate: Thu, 14 Mar 2013 08:22:29 +0100 sched: Fix variable name

[PATCH] kernel:sched: renamed max_vruntime parameter

2013-03-12 Thread Andrei Epure
The min_vruntime variable actually stores the maximum value. The added comment was taken from place_entity function. Signed-off-by: Andrei Epure --- kernel/sched/fair.c |9 + 1 file changed, 5 insertions(+), 4 deletions(-) diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c

[tip:sched/core] sched: Spelling fix

2013-03-11 Thread tip-bot for Andrei Epure
Commit-ID: 660cc00f8c6f7a2e16c25918590b470e86de19ec Gitweb: http://git.kernel.org/tip/660cc00f8c6f7a2e16c25918590b470e86de19ec Author: Andrei Epure AuthorDate: Mon, 11 Mar 2013 12:03:20 +0200 Committer: Ingo Molnar CommitDate: Mon, 11 Mar 2013 15:12:11 +0100 sched: Spelling fix

[PATCH] kernel:sched hyphened compound adjective before noun

2013-03-11 Thread Andrei Epure
Signed-off-by: Andrei Epure --- kernel/sched/fair.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c index 7a33e59..3220639 100644 --- a/kernel/sched/fair.c +++ b/kernel/sched/fair.c @@ -652,7 +652,7 @@ static u64 sched_slice(struct

[PATCH] acpi: replaced kmalloc+memcpy with kmemdup

2013-03-11 Thread Andrei Epure
Signed-off-by: Andrei Epure --- drivers/acpi/bus.c |5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/acpi/bus.c b/drivers/acpi/bus.c index 01708a1..292de3c 100644 --- a/drivers/acpi/bus.c +++ b/drivers/acpi/bus.c @@ -288,13 +288,12 @@ acpi_status acpi_run_osc

[PATCH] wireless:iwlwifi: changed kmalloc+memcpy with kmemdup

2013-03-10 Thread Andrei Epure
Signed-off-by: Andrei Epure --- drivers/net/wireless/iwlwifi/iwl-test.c |3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/net/wireless/iwlwifi/iwl-test.c b/drivers/net/wireless/iwlwifi/iwl-test.c index ce0c67b..9bc402c 100644 --- a/drivers/net/wireless/iwlwifi/iwl

[PATCH] wireless:rtlwifi: replaced kmalloc+memcpy with kmemdup

2013-03-10 Thread Andrei Epure
Signed-off-by: Andrei Epure --- drivers/net/wireless/rtlwifi/usb.c |3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/net/wireless/rtlwifi/usb.c b/drivers/net/wireless/rtlwifi/usb.c index 156b527..b5c80b5 100644 --- a/drivers/net/wireless/rtlwifi/usb.c +++ b

[PATCH] ath: changed kmalloc to kmemdup

2013-03-10 Thread Andrei Epure
Signed-off-by: Andrei Epure --- drivers/net/wireless/ath/ath6kl/usb.c |4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/net/wireless/ath/ath6kl/usb.c b/drivers/net/wireless/ath/ath6kl/usb.c index 5fcd342..ffa1daa 100644 --- a/drivers/net/wireless/ath/ath6kl/usb.c