Mutual Benefit

2019-02-24 Thread David Lin
Hi, I am contacting you with regards to using your last name for funds claim of long dormant funds belonging to a late depositor . Let me know if you are intreasted for more details . Best Regards David Lin

[PATCH] kbuild: clang: fix build failures with sparse check

2017-10-20 Thread David Lin
We should avoid using the space character when passing arguments to clang, because static code analysis check tool such as sparse may misinterpret the arguments followed by spaces as build targets hence cause the build to fail. Signed-off-by: David Lin --- Makefile | 4 ++-- 1 file changed, 2

Re: Vibrations in input vs. LED was Re: [PATCH v2 0/3] led: ledtrig-transient: add support for hrtimer

2017-09-28 Thread David Lin
On Wed, Sep 27, 2017 at 10:43 PM, Dmitry Torokhov wrote: >>One thing I noticed is that input_ff_create_memless() also does not >>use high-resolution timer hence it also does not have the stop-time >>precision that I'm looking for. > > I'll take patches for high resolution timers in ff memless, the

Re: Vibrations in input vs. LED was Re: [PATCH v2 0/3] led: ledtrig-transient: add support for hrtimer

2017-09-27 Thread David Lin
Dmitry, On Fri, Sep 15, 2017 at 3:30 PM, Dmitry Torokhov wrote: > On Fri, Sep 15, 2017 at 2:55 PM, Jacek Anaszewski > wrote: >> On 09/15/2017 08:34 PM, Dmitry Torokhov wrote: >>> On Thu, Sep 14, 2017 at 1:58 PM, Pavel Machek wrote: On Thu 2017-09-14 21:31:31, Jacek Anaszewski wrote: >

Re: [PATCH v2 0/3] led: ledtrig-transient: add support for hrtimer

2017-09-14 Thread David Lin
On Thu, Sep 14, 2017 at 12:31 PM, Jacek Anaszewski wrote: > I would change one more thing in this patch, though. The hr_timer engine > should be made optional and not used by default for fast LEDs. > It could be made configurable by exposing additional sysfs file from > ledtrig-transient.c, e.g. h

Re: [PATCH v2 0/3] led: ledtrig-transient: add support for hrtimer

2017-09-14 Thread David Lin
On Wed, Sep 13, 2017 at 2:34 PM, Pavel Machek wrote: > > On Wed 2017-09-13 14:20:58, David Lin wrote: > > On Wed, Sep 13, 2017 at 1:20 PM, Pavel Machek wrote: > > > > > > Hi! > > > > > > > These patch series add the LED_BRIGHTNESS_FAST flag supp

Re: [PATCH v2 0/3] led: ledtrig-transient: add support for hrtimer

2017-09-13 Thread David Lin
On Wed, Sep 13, 2017 at 1:20 PM, Pavel Machek wrote: > > Hi! > > > These patch series add the LED_BRIGHTNESS_FAST flag support for > > ledtrig-transient to use hrtimer so that platforms with high-resolution > > timer > > support can have better accuracy in the trigger duration timing. The need >

[PATCH v2 2/3] leds: Add the LED_BRIGHTNESS_FAST flag

2017-09-13 Thread David Lin
Anaszewski Signed-off-by: David Lin --- Documentation/leds/leds-class.txt | 5 + include/linux/leds.h | 1 + 2 files changed, 6 insertions(+) diff --git a/Documentation/leds/leds-class.txt b/Documentation/leds/leds-class.txt index 836cb16d6f09..70d7a3dca621 100644 --- a/Documentation

[PATCH v2 3/3] led: ledtrig-transient: add support for hrtimer

2017-09-13 Thread David Lin
This patch adds a hrtimer to ledtrig-transient so that when driver is registered with LED_BRIGHTNESS_FAST, the hrtimer is used for the better time accuracy in handling the duration. Signed-off-by: David Lin --- drivers/leds/trigger/ledtrig-transient.c | 59 +--- 1

[PATCH v2 0/3] led: ledtrig-transient: add support for hrtimer

2017-09-13 Thread David Lin
/patch/8664831/ [2] https://lkml.org/lkml/2015/4/28/260 Changes from v1 to v2: - Convert all the bit shifting flag in leds.h to use the BIT macro. - Removed inline modifiers for the timer helper function. David Lin (3): leds: Replace flags bit shift with BIT() macros leds: Add the

[PATCH v2 1/3] leds: Replace flags bit shift with BIT() macros

2017-09-13 Thread David Lin
This is for readability as well as to avoid checkpatch warnings when adding new bit flag information in the future. Signed-off-by: David Lin --- include/linux/leds.h | 18 +- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git a/include/linux/leds.h b/include/linux

Re: [PATCH 0/3] led: ledtrig-transient: add support for hrtimer

2017-05-03 Thread David Lin
+Cc: Greg KH On Sun, Apr 30, 2017 at 2:36 PM, David Lin wrote: > Hi, > > These patch series add the LED_BRIGHTNESS_FAST flag support for > ledtrig-transient to use hrtimer so that platforms with high-resolution timer > support can have better accuracy in the trigger duration timin

[PATCH 3/3] led: ledtrig-transient: add support for hrtimer

2017-04-30 Thread David Lin
This patch adds a hrtimer to ledtrig-transient so that when driver is registered with LED_BRIGHTNESS_FAST, the hrtimer is used for the better time accuracy in handling the duration. Signed-off-by: David Lin --- drivers/leds/trigger/ledtrig-transient.c | 59 +--- 1

[PATCH 2/3] leds: Add the LED_BRIGHTNESS_FAST flag

2017-04-30 Thread David Lin
Anaszewski Signed-off-by: David Lin --- Documentation/leds/leds-class.txt | 5 + include/linux/leds.h | 1 + 2 files changed, 6 insertions(+) diff --git a/Documentation/leds/leds-class.txt b/Documentation/leds/leds-class.txt index 836cb16d6f09..70d7a3dca621 100644 --- a/Documentation

[PATCH 1/3] leds: Replace flags bit shift with BIT() macros

2017-04-30 Thread David Lin
This is for readability as well as to avoid checkpatch warnings when adding new bit flag information in the future. Signed-off-by: David Lin --- include/linux/leds.h | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/include/linux/leds.h b/include/linux/leds.h

[PATCH 0/3] led: ledtrig-transient: add support for hrtimer

2017-04-30 Thread David Lin
/patch/8664831/ [2] https://lkml.org/lkml/2015/4/28/260 David Lin (3): leds: Replace flags bit shift with BIT() macros leds: Add the LED_BRIGHTNESS_FAST flag led: ledtrig-transient: add support for hrtimer Documentation/leds/leds-class.txt| 5 +++ drivers/leds/trigger/ledtrig

Re: [PATCH] led: ledtrig-transient: replace timer_list with hrtimer

2017-04-26 Thread David Lin
On Tue, Apr 25, 2017 at 1:15 PM, Jacek Anaszewski wrote: >> However, there's a need to >> support hrtimer if the LED subsystem claims support the use case of >> vibrator (please see Documentation/leds/ledtrig-transient.txt) as even >> a 5ms of variation is perceivable to the user. I'm thinking if

Re: [PATCH] led: ledtrig-transient: replace timer_list with hrtimer

2017-04-24 Thread David Lin
Hi Jacek, On Mon, Apr 24, 2017 at 12:59 PM, Jacek Anaszewski wrote: > > Hi David, > > Thanks for the patch. > > Unfortunately we cannot switch to using hr timers just like that > without introducing side effects for many devices. We had similar > attempt of increasing timer tirgger accuracy two y

[PATCH] led: ledtrig-transient: replace timer_list with hrtimer

2017-04-23 Thread David Lin
illisecond precision as modern haptic actuators can be driven in precisely one cycle (~1 ms) in order to provide a crisp and subtle feedback. Cc: Richard Purdie Cc: Jacek Anaszewski Cc: Pavel Machek Cc: Rob Herring Cc: Rom Lemarchand Cc: Joel Fernandes Cc: sta...@vger.kernel.org Signed-off-by:

Re: [PATCH v2] jump label: fix passing kbuild_cflags when checking for asm goto support

2017-03-10 Thread David Lin
pass kbuild_cflags when checking for asm > goto support") > Cc: sta...@vger.kernel.org # v4.10 > Signed-off-by: Gleb Fotengauer-Malinovskiy > Signed-off-by: Dmitry V. Levin > --- Acked-by: David Lin

[PATCH RESEND] jump label: pass kbuild_cflags when checking for asm goto support

2017-01-20 Thread David Lin
the script does not rely on the default config from different compilers. Signed-off-by: David Lin Acked-by: Steven Rostedt --- Makefile | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/Makefile b/Makefile index 5f1a84735ff6..c5dec246b4ab 100644 --- a/Makefile +++ b/Makef

Re: [PATCH] jump label: pass kbuild_cflags when checking for asm goto support

2017-01-01 Thread David Lin
+Cc: Steven Rostedt +Cc: Will Deacon On Fri, Dec 9, 2016 at 4:46 PM, David Lin wrote: > Some versions of ARM GCC compiler such as Android toolchain throws in a > '-fpic' flag by default. This causes the gcc-goto check script to fail > although some config would have &#x

[PATCH] jump label: pass kbuild_cflags when checking for asm goto support

2016-12-09 Thread David Lin
the script does not rely on the default config from different compilers. Signed-off-by: David Lin --- Makefile | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/Makefile b/Makefile index 694111b..f667daa 100644 --- a/Makefile +++ b/Makefile @@ -790,7 +790,7 @@ KBUILD_CFLAGS