Re: [PATCH 1/2] ARM: dump: Convert to use DEFINE_SHOW_ATTRIBUTE macro

2018-12-27 Thread Donglin Peng
On Wed, Jun 13, 2018 at 9:15 AM Peng Donglin wrote: > > Use DEFINE_SHOW_ATTRIBUTE macro to simplify the code. > > Signed-off-by: Peng Donglin > --- > arch/arm/mm/ptdump_debugfs.c | 13 + > 1 file changed, 1 insertion(+), 12 deletions(-) > > diff --git a/arch/arm/mm/ptdump_debugfs.c

Re: [PATCH v4] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-14 Thread Donglin Peng
On Wed, Feb 14, 2018 at 10:53 PM, Mark Brown wrote: > On Wed, Feb 14, 2018 at 10:48:07PM +0800, Peng Donglin wrote: > >> v4: >> * resend patch using outlook email, because I can't disable gmail >>word wrap in plain text mode > > Using Outlook for better interaction with

Re: [PATCH v4] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-14 Thread Donglin Peng
On Wed, Feb 14, 2018 at 10:53 PM, Mark Brown wrote: > On Wed, Feb 14, 2018 at 10:48:07PM +0800, Peng Donglin wrote: > >> v4: >> * resend patch using outlook email, because I can't disable gmail >>word wrap in plain text mode > > Using Outlook for better interaction with the lists! Okay, I

Re: [PATCH v3] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-14 Thread Donglin Peng
On Wed, Feb 14, 2018 at 10:41 PM, Andy Shevchenko <andy.shevche...@gmail.com> wrote: > On Wed, Feb 14, 2018 at 4:39 PM, Donglin Peng <dolinux.p...@gmail.com> wrote: >> On Mon, Feb 12, 2018 at 7:49 PM, Mark Brown <broo...@kernel.org> wrote: >>> On Fri, Feb 09, 20

Re: [PATCH v3] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-14 Thread Donglin Peng
On Wed, Feb 14, 2018 at 10:41 PM, Andy Shevchenko wrote: > On Wed, Feb 14, 2018 at 4:39 PM, Donglin Peng wrote: >> On Mon, Feb 12, 2018 at 7:49 PM, Mark Brown wrote: >>> On Fri, Feb 09, 2018 at 11:10:55PM +0800, Donglin Peng wrote: > >> Hi Mark, do you know the way

Re: [PATCH v3] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-14 Thread Donglin Peng
On Mon, Feb 12, 2018 at 7:49 PM, Mark Brown <broo...@kernel.org> wrote: > On Fri, Feb 09, 2018 at 11:10:55PM +0800, Donglin Peng wrote: > >> --- a/sound/soc/soc-core.c >> +++ b/sound/soc/soc-core.c >> @@ -349,7 +349,7 @@ static void soc_init_codec_debugfs(struct &

Re: [PATCH v3] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-14 Thread Donglin Peng
On Mon, Feb 12, 2018 at 7:49 PM, Mark Brown wrote: > On Fri, Feb 09, 2018 at 11:10:55PM +0800, Donglin Peng wrote: > >> --- a/sound/soc/soc-core.c >> +++ b/sound/soc/soc-core.c >> @@ -349,7 +349,7 @@ static void soc_init_codec_debugfs(struct >> snd_soc_component *co

Re: [PATCH v3] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-14 Thread Donglin Peng
On Mon, Feb 12, 2018 at 3:49 AM, Mark Brown <broo...@kernel.org> wrote: > On Fri, Feb 09, 2018 at 11:10:55PM +0800, Donglin Peng wrote: > >> --- a/sound/soc/soc-core.c >> +++ b/sound/soc/soc-core.c >> @@ -349,7 +349,7 @@ static void soc_init_codec_debugfs(struct &

Re: [PATCH v3] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-14 Thread Donglin Peng
On Mon, Feb 12, 2018 at 3:49 AM, Mark Brown wrote: > On Fri, Feb 09, 2018 at 11:10:55PM +0800, Donglin Peng wrote: > >> --- a/sound/soc/soc-core.c >> +++ b/sound/soc/soc-core.c >> @@ -349,7 +349,7 @@ static void soc_init_codec_debugfs(struct >> snd_soc_component *co

Re: [PATCH] seq_file: remove redundant assignment of index to m->index

2018-02-10 Thread Donglin Peng
On Sun, Feb 11, 2018 at 9:02 AM, Matthew Wilcox wrote: > On Sat, Feb 10, 2018 at 10:04:23AM -0800, Joe Perches wrote: >> > @@ -120,14 +120,12 @@ static int traverse(struct seq_file *m, loff_t >> > offset) >> > if (pos + m->count > offset) { >> > m->from

Re: [PATCH] seq_file: remove redundant assignment of index to m->index

2018-02-10 Thread Donglin Peng
On Sun, Feb 11, 2018 at 9:02 AM, Matthew Wilcox wrote: > On Sat, Feb 10, 2018 at 10:04:23AM -0800, Joe Perches wrote: >> > @@ -120,14 +120,12 @@ static int traverse(struct seq_file *m, loff_t >> > offset) >> > if (pos + m->count > offset) { >> > m->from = offset - pos; >> >

[PATCH] seq_file: remove redundant assignment of index to m->index

2018-02-10 Thread Donglin Peng
There are two redundant assignments in the traverse() function, because the while loop will break after these two assignments, and after that the variable index will be assigned to m->index again. Signed-off-by: Peng Donglin --- fs/seq_file.c | 2 -- 1 file changed, 2

[PATCH] seq_file: remove redundant assignment of index to m->index

2018-02-10 Thread Donglin Peng
There are two redundant assignments in the traverse() function, because the while loop will break after these two assignments, and after that the variable index will be assigned to m->index again. Signed-off-by: Peng Donglin --- fs/seq_file.c | 2 -- 1 file changed, 2 deletions(-) diff --git

[PATCH v3] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-09 Thread Donglin Peng
There is some duplicate code in soc-core.c, and the kernel provides DEFINE_SHOW_ATTRIBUTE() helper macro to decrease it in seq_file.h. Signed-off-by: Peng Donglin Reviewed-by: Andy Shevchenko --- v3: [addressed comments from Andy] * add

[PATCH v3] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-09 Thread Donglin Peng
There is some duplicate code in soc-core.c, and the kernel provides DEFINE_SHOW_ATTRIBUTE() helper macro to decrease it in seq_file.h. Signed-off-by: Peng Donglin Reviewed-by: Andy Shevchenko --- v3: [addressed comments from Andy] * add missing tag v2: [addressed comments from Andy] * modify

Re: [PATCH v2] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-09 Thread Donglin Peng
On Fri, Feb 9, 2018 at 10:52 PM, Andy Shevchenko <andy.shevche...@gmail.com> wrote: > On Fri, Feb 9, 2018 at 4:43 PM, Donglin Peng <dolinux.p...@gmail.com> wrote: >> There is some duplicate code in soc-core.c, and the kernel provides >> DEFINE_SHOW_ATTRIBUTE

Re: [PATCH v2] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-09 Thread Donglin Peng
On Fri, Feb 9, 2018 at 10:52 PM, Andy Shevchenko wrote: > On Fri, Feb 9, 2018 at 4:43 PM, Donglin Peng wrote: >> There is some duplicate code in soc-core.c, and the kernel provides >> DEFINE_SHOW_ATTRIBUTE() helper macro to decrease it in seq_file.h. >> > > You

Re: [PATCH v2] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-09 Thread Donglin Peng
On Fri, Feb 9, 2018 at 10:52 PM, Andy Shevchenko <andy.shevche...@gmail.com> wrote: > On Fri, Feb 9, 2018 at 4:43 PM, Donglin Peng <dolinux.p...@gmail.com> wrote: >> There is some duplicate code in soc-core.c, and the kernel provides >> DEFINE_SHOW_ATTRIBUTE

Re: [PATCH v2] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-09 Thread Donglin Peng
On Fri, Feb 9, 2018 at 10:52 PM, Andy Shevchenko wrote: > On Fri, Feb 9, 2018 at 4:43 PM, Donglin Peng wrote: >> There is some duplicate code in soc-core.c, and the kernel provides >> DEFINE_SHOW_ATTRIBUTE() helper macro to decrease it in seq_file.h. >> > > You

[PATCH v2] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-09 Thread Donglin Peng
There is some duplicate code in soc-core.c, and the kernel provides DEFINE_SHOW_ATTRIBUTE() helper macro to decrease it in seq_file.h. Signed-off-by: Peng Donglin --- v2: [addressed comments from Andy] * modify code change description * do not rename m -> s ---

[PATCH v2] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-09 Thread Donglin Peng
There is some duplicate code in soc-core.c, and the kernel provides DEFINE_SHOW_ATTRIBUTE() helper macro to decrease it in seq_file.h. Signed-off-by: Peng Donglin --- v2: [addressed comments from Andy] * modify code change description * do not rename m -> s --- sound/soc/soc-core.c | 45

Re: [PATCH] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-09 Thread Donglin Peng
On Fri, Feb 9, 2018 at 9:21 PM, Andy Shevchenko <andy.shevche...@gmail.com> wrote: > On Fri, Feb 9, 2018 at 8:58 AM, Donglin Peng <dolinux.p...@gmail.com> wrote: >> There is some duplicate code in soc-core.c,and the kernel provides > > 'core.c,and' -> 'core.c, and' &g

Re: [PATCH] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-09 Thread Donglin Peng
On Fri, Feb 9, 2018 at 9:21 PM, Andy Shevchenko wrote: > On Fri, Feb 9, 2018 at 8:58 AM, Donglin Peng wrote: >> There is some duplicate code in soc-core.c,and the kernel provides > > 'core.c,and' -> 'core.c, and' > >> +static int codec_list_show(struct seq_file *s, voi

[PATCH] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-08 Thread Donglin Peng
There is some duplicate code in soc-core.c,and the kernel provides DEFINE_SHOW_ATTRIBUTE() helper macro to decrease it in seq_file.h. Signed-off-by: Peng Donglin --- sound/soc/soc-core.c | 51 +-- 1 file changed, 9

[PATCH] ASoC: use DEFINE_SHOW_ATTRIBUTE() to decrease code duplication

2018-02-08 Thread Donglin Peng
There is some duplicate code in soc-core.c,and the kernel provides DEFINE_SHOW_ATTRIBUTE() helper macro to decrease it in seq_file.h. Signed-off-by: Peng Donglin --- sound/soc/soc-core.c | 51 +-- 1 file changed, 9 insertions(+), 42 deletions(-)

Re: [PATCH v2] ASoC: use seq_file to dump the contents of dai_list,platform_list and codec_list

2018-02-08 Thread Donglin Peng
Okay, I will send it later. On Thu, Feb 8, 2018 at 11:42 PM, Mark Brown <broo...@kernel.org> wrote: > On Thu, Feb 08, 2018 at 04:25:10PM +0200, Andy Shevchenko wrote: >> On Fri, Jan 26, 2018 at 9:16 AM, Donglin Peng <dolinux.p...@gmail.com> wrote: > >> &g

Re: [PATCH v2] ASoC: use seq_file to dump the contents of dai_list,platform_list and codec_list

2018-02-08 Thread Donglin Peng
Okay, I will send it later. On Thu, Feb 8, 2018 at 11:42 PM, Mark Brown wrote: > On Thu, Feb 08, 2018 at 04:25:10PM +0200, Andy Shevchenko wrote: >> On Fri, Jan 26, 2018 at 9:16 AM, Donglin Peng wrote: > >> > I can send another patch after the following patch

Re: [PATCH v2] ASoC: use seq_file to dump the contents of dai_list,platform_list and codec_list

2018-01-25 Thread Donglin Peng
On Wed, Jan 24, 2018 at 1:37 AM, Mark Brown wrote: > On Tue, Jan 23, 2018 at 07:08:15PM +0200, Andy Shevchenko wrote: > >> If it's not critical, I would suggest to wait till v4.16-rc1, where I >> would like to push [1], and switch to DEFINE_SHOW_ATTRIBUTE() macro. > > Too

Re: [PATCH v2] ASoC: use seq_file to dump the contents of dai_list,platform_list and codec_list

2018-01-25 Thread Donglin Peng
On Wed, Jan 24, 2018 at 1:37 AM, Mark Brown wrote: > On Tue, Jan 23, 2018 at 07:08:15PM +0200, Andy Shevchenko wrote: > >> If it's not critical, I would suggest to wait till v4.16-rc1, where I >> would like to push [1], and switch to DEFINE_SHOW_ATTRIBUTE() macro. > > Too late, I already applied

[PATCH v2] ASoC: use seq_file to dump the contents of dai_list,platform_list and codec_list

2018-01-17 Thread Donglin Peng
/platform_list/codec_list. Signed-off-by: Donglin Peng <dolinux.p...@gmail.com> --- Changelog v2 -fix commit log error sound/soc/soc-core.c | 111 +-- 1 file changed, 37 insertions(+), 74 deletions(-) diff --git a/sound/soc/soc-core.c b/sound/s

[PATCH v2] ASoC: use seq_file to dump the contents of dai_list,platform_list and codec_list

2018-01-17 Thread Donglin Peng
/platform_list/codec_list. Signed-off-by: Donglin Peng --- Changelog v2 -fix commit log error sound/soc/soc-core.c | 111 +-- 1 file changed, 37 insertions(+), 74 deletions(-) diff --git a/sound/soc/soc-core.c b/sound/soc/soc-core.c index

Re: [alsa-devel] [PATCH] ASoC: dapm: Fix typos in comment

2017-09-27 Thread Donglin Peng
Thanks, i see. On Wed, Sep 27, 2017 at 10:39 PM, Lars-Peter Clausen wrote: > On 09/27/2017 04:35 PM, Peng Donglin wrote: >> Signed-off-by: Peng Donglin >> --- >> sound/soc/soc-dapm.c | 4 ++-- >> 1 file changed, 2 insertions(+), 2 deletions(-) >> >>

Re: [alsa-devel] [PATCH] ASoC: dapm: Fix typos in comment

2017-09-27 Thread Donglin Peng
Thanks, i see. On Wed, Sep 27, 2017 at 10:39 PM, Lars-Peter Clausen wrote: > On 09/27/2017 04:35 PM, Peng Donglin wrote: >> Signed-off-by: Peng Donglin >> --- >> sound/soc/soc-dapm.c | 4 ++-- >> 1 file changed, 2 insertions(+), 2 deletions(-) >> >> diff --git a/sound/soc/soc-dapm.c

Re: [PATCH v2 03/10] ASoC: Intel: Remove unnecessary function call

2017-08-27 Thread Donglin Peng
Hi Mark, On Wed, Aug 23, 2017 at 8:19 PM, Peng Donglin wrote: > The work of the function platform_set_drvdata is done by > devm_snd_soc_register_card. > > Signed-off-by: Peng Donglin > --- > > Changes in v2: > -add missed occurrences. > >

Re: [PATCH v2 03/10] ASoC: Intel: Remove unnecessary function call

2017-08-27 Thread Donglin Peng
Hi Mark, On Wed, Aug 23, 2017 at 8:19 PM, Peng Donglin wrote: > The work of the function platform_set_drvdata is done by > devm_snd_soc_register_card. > > Signed-off-by: Peng Donglin > --- > > Changes in v2: > -add missed occurrences. > > sound/soc/intel/boards/bytcht_da7213.c | 6 ++

Re: [PATCH v2] ASoC: Add a sanity check before using dai driver name

2017-08-27 Thread Donglin Peng
On Sun, Aug 27, 2017 at 10:31 PM, Jeffy Chen wrote: > hi dong, > > thanks for noticing, but i think mark've applied the right version. > > this amazing robot would help to test all patches, not only the ones already > applied :) I also think so.

Re: [PATCH v2] ASoC: Add a sanity check before using dai driver name

2017-08-27 Thread Donglin Peng
On Sun, Aug 27, 2017 at 10:31 PM, Jeffy Chen wrote: > hi dong, > > thanks for noticing, but i think mark've applied the right version. > > this amazing robot would help to test all patches, not only the ones already > applied :) I also think so.

Re: [PATCH v2] ASoC: Add a sanity check before using dai driver name

2017-08-27 Thread Donglin Peng
Hi Jeffy, On Sun, Aug 27, 2017 at 8:19 PM, Mark Brown <broo...@kernel.org> wrote: > On Sat, Aug 26, 2017 at 11:09:49PM +0800, Donglin Peng wrote: > >> It seems that the v3 patch should be applied other than v2. > > Please send incremental fixes rather than

Re: [PATCH v2] ASoC: Add a sanity check before using dai driver name

2017-08-27 Thread Donglin Peng
Hi Jeffy, On Sun, Aug 27, 2017 at 8:19 PM, Mark Brown wrote: > On Sat, Aug 26, 2017 at 11:09:49PM +0800, Donglin Peng wrote: > >> It seems that the v3 patch should be applied other than v2. > > Please send incremental fixes rather than new versions for things that > are are

Re: [PATCH v2] ASoC: Add a sanity check before using dai driver name

2017-08-26 Thread Donglin Peng
Hi Mark, On Sat, Aug 26, 2017 at 10:13 PM, kbuild test robot wrote: > Hi Jeffy, > > [auto build test ERROR on asoc/for-next] > [also build test ERROR on next-20170825] > [cannot apply to v4.13-rc6] > [if your patch is applied to the wrong git tree, please drop us a note to >

Re: [PATCH v2] ASoC: Add a sanity check before using dai driver name

2017-08-26 Thread Donglin Peng
Hi Mark, On Sat, Aug 26, 2017 at 10:13 PM, kbuild test robot wrote: > Hi Jeffy, > > [auto build test ERROR on asoc/for-next] > [also build test ERROR on next-20170825] > [cannot apply to v4.13-rc6] > [if your patch is applied to the wrong git tree, please drop us a note to > help improve the

Re: [PATCH v2] ASoC: Add a sanity check before using dai driver name

2017-08-23 Thread Donglin Peng
On Thu, Aug 24, 2017 at 11:34 AM, Jeffy Chen wrote: > list_for_each_entry(dai, >dai_list, list) { > if (dlc->dai_name && strcmp(dai->name, dlc->dai_name) > - && strcmp(dai->driver->name, dlc->dai_name)) >

Re: [PATCH v2] ASoC: Add a sanity check before using dai driver name

2017-08-23 Thread Donglin Peng
On Thu, Aug 24, 2017 at 11:34 AM, Jeffy Chen wrote: > list_for_each_entry(dai, >dai_list, list) { > if (dlc->dai_name && strcmp(dai->name, dlc->dai_name) > - && strcmp(dai->driver->name, dlc->dai_name)) > +

Re: [PATCH v5 2/9] ASoC: soc-core: Allow searching dai driver name in snd_soc_find_dai

2017-08-22 Thread Donglin Peng
On Tue, Aug 22, 2017 at 10:02 PM, Mark Brown <broo...@kernel.org> wrote: > On Tue, Aug 22, 2017 at 09:24:32PM +0800, Donglin Peng wrote: > >> In case that dai->driver->name is NULL, strcmp(dai->driver->name, >> dlc->dai_name) will cause segmentation

Re: [PATCH v5 2/9] ASoC: soc-core: Allow searching dai driver name in snd_soc_find_dai

2017-08-22 Thread Donglin Peng
On Tue, Aug 22, 2017 at 10:02 PM, Mark Brown wrote: > On Tue, Aug 22, 2017 at 09:24:32PM +0800, Donglin Peng wrote: > >> In case that dai->driver->name is NULL, strcmp(dai->driver->name, >> dlc->dai_name) will cause segmentation fault. >> so I think that

Re: [PATCH v5 2/9] ASoC: soc-core: Allow searching dai driver name in snd_soc_find_dai

2017-08-22 Thread Donglin Peng
Hi jeffy, On Tue, Aug 22, 2017 at 3:57 PM, Jeffy Chen wrote: > @@ -978,7 +978,8 @@ struct snd_soc_dai *snd_soc_find_dai( > if (dlc->name && strcmp(component->name, dlc->name)) > continue; >

Re: [PATCH v5 2/9] ASoC: soc-core: Allow searching dai driver name in snd_soc_find_dai

2017-08-22 Thread Donglin Peng
Hi jeffy, On Tue, Aug 22, 2017 at 3:57 PM, Jeffy Chen wrote: > @@ -978,7 +978,8 @@ struct snd_soc_dai *snd_soc_find_dai( > if (dlc->name && strcmp(component->name, dlc->name)) > continue; > list_for_each_entry(dai, >dai_list, list) { > -

Re: [PATCH v5 6/9] ASoC: rockchip: Parse dai links from dts

2017-08-22 Thread Donglin Peng
On Tue, Aug 22, 2017 at 3:57 PM, Jeffy Chen wrote: > Refactor rockchip_sound_probe, parse dai links from dts instead of > hard coding them. > > Signed-off-by: Jeffy Chen > Reviewed-by: Matthias Kaehlcke > Tested-by:

Re: [PATCH v5 6/9] ASoC: rockchip: Parse dai links from dts

2017-08-22 Thread Donglin Peng
On Tue, Aug 22, 2017 at 3:57 PM, Jeffy Chen wrote: > Refactor rockchip_sound_probe, parse dai links from dts instead of > hard coding them. > > Signed-off-by: Jeffy Chen > Reviewed-by: Matthias Kaehlcke > Tested-by: Matthias Kaehlcke > --- > > Changes in v5: None > Changes in v4: None >