[PATCH] tools: usb: usbip_device_driver: prefer 'unsigned int' to 'unsigned'

2017-12-30 Thread Elad Wexler
Fixup a coding style issue Signed-off-by: Elad Wexler <elad.wex...@gmail.com> --- tools/usb/usbip/libsrc/usbip_device_driver.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/tools/usb/usbip/libsrc/usbip_device_driver.c b/tools/usb/usbip/libsrc/usbip_device_driver.c

[PATCH] tools: usb: usbip_device_driver: prefer 'unsigned int' to 'unsigned'

2017-12-30 Thread Elad Wexler
Fixup a coding style issue Signed-off-by: Elad Wexler --- tools/usb/usbip/libsrc/usbip_device_driver.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/tools/usb/usbip/libsrc/usbip_device_driver.c b/tools/usb/usbip/libsrc/usbip_device_driver.c index e059b7d..b2dac82 100644

[PATCH] tools: usb: usbip: fix fd leak in case of 'fread' failure

2017-12-30 Thread Elad Wexler
Fix possible resource leak: fd Signed-off-by: Elad Wexler <elad.wex...@gmail.com> --- tools/usb/usbip/libsrc/usbip_device_driver.c | 5 - 1 file changed, 4 insertions(+), 1 deletion(-) diff --git a/tools/usb/usbip/libsrc/usbip_device_driver.c b/tools/usb/usbip/libsrc/usbip_device_dr

[PATCH] tools: usb: usbip: fix fd leak in case of 'fread' failure

2017-12-30 Thread Elad Wexler
Fix possible resource leak: fd Signed-off-by: Elad Wexler --- tools/usb/usbip/libsrc/usbip_device_driver.c | 5 - 1 file changed, 4 insertions(+), 1 deletion(-) diff --git a/tools/usb/usbip/libsrc/usbip_device_driver.c b/tools/usb/usbip/libsrc/usbip_device_driver.c index e059b7d..1aa27af

[PATCH] android: binder: Prefer __func__ to using hardcoded function name

2017-12-29 Thread Elad Wexler
Coding style fixup Signed-off-by: Elad Wexler <elad.wex...@gmail.com> --- drivers/android/binder.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/android/binder.c b/drivers/android/binder.c index bccec9d..a66ad3d 100644 --- a/drivers/android/binder.c

[PATCH] android: binder: Prefer __func__ to using hardcoded function name

2017-12-29 Thread Elad Wexler
Coding style fixup Signed-off-by: Elad Wexler --- drivers/android/binder.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/android/binder.c b/drivers/android/binder.c index bccec9d..a66ad3d 100644 --- a/drivers/android/binder.c +++ b/drivers/android/binder.c

[RFC] Supporting namespaces in the connector driver

2017-12-28 Thread Elad Wexler
Hi, I have spent some time looking at the cn_proc monitor capabilities which use the connector driver for monitoring processes. Currently the cn_proc (and all other modules which are using the connector) only works on the main init_user_ns namespace. If I am working inside a docker container (as

[RFC] Supporting namespaces in the connector driver

2017-12-28 Thread Elad Wexler
Hi, I have spent some time looking at the cn_proc monitor capabilities which use the connector driver for monitoring processes. Currently the cn_proc (and all other modules which are using the connector) only works on the main init_user_ns namespace. If I am working inside a docker container (as

[PATCH] staging: ccree: ssi_hash: remove unnecessary parentheses

2017-12-28 Thread Elad Wexler
Fixed a coding style issue Signed-off-by: Elad Wexler <elad.wex...@gmail.com> --- drivers/staging/ccree/ssi_hash.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/ccree/ssi_hash.c b/drivers/staging/ccree/ssi_hash.c index 2035835..8d56fa7

[PATCH] staging: ccree: ssi_hash: remove unnecessary parentheses

2017-12-28 Thread Elad Wexler
Fixed a coding style issue Signed-off-by: Elad Wexler --- drivers/staging/ccree/ssi_hash.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/ccree/ssi_hash.c b/drivers/staging/ccree/ssi_hash.c index 2035835..8d56fa7 100644 --- a/drivers/staging/ccree

Re: [PATCH] misc: cs5535-mfgpt: Replace 'module_init' with 'module_platform_driver'

2013-09-28 Thread Elad Wexler
On Sat, Sep 28, 2013 at 08:54:55PM +0200, richard -rw- weinberger wrote: > On Sat, Sep 28, 2013 at 8:14 PM, wrote: > > From: Elad Wexler > > > > Driver doesn't do anything special in 'module_init'. > > > > 'module_platform_init' makes the code more readable. &

[PATCH] misc: cs5535-mfgpt: Replace 'module_init' with 'module_platform_driver'

2013-09-28 Thread elad . wexler
From: Elad Wexler Driver doesn't do anything special in 'module_init'. 'module_platform_init' makes the code more readable. Signed-off-by: Elad Wexler --- drivers/misc/cs5535-mfgpt.c |8 +--- 1 file changed, 1 insertion(+), 7 deletions(-) diff --git a/drivers/misc/cs5535-mfgpt.c b

[PATCH] misc: cs5535-mfgpt: Replace 'module_init' with 'module_platform_driver'

2013-09-28 Thread elad . wexler
From: Elad Wexler elad.wex...@gmail.com Driver doesn't do anything special in 'module_init'. 'module_platform_init' makes the code more readable. Signed-off-by: Elad Wexler elad.wex...@gmail.com --- drivers/misc/cs5535-mfgpt.c |8 +--- 1 file changed, 1 insertion(+), 7 deletions

Re: [PATCH] misc: cs5535-mfgpt: Replace 'module_init' with 'module_platform_driver'

2013-09-28 Thread Elad Wexler
On Sat, Sep 28, 2013 at 08:54:55PM +0200, richard -rw- weinberger wrote: On Sat, Sep 28, 2013 at 8:14 PM, elad.wex...@gmail.com wrote: From: Elad Wexler elad.wex...@gmail.com Driver doesn't do anything special in 'module_init'. 'module_platform_init' makes the code more readable

[PATCH] Drivers: char: misc: 'misc_deregister()' changed the 'mutex_unlock' logic upon an error

2013-09-14 Thread Elad Wexler
From: Elad Wexler This change improves code readability & is less error-prone. For example: case adding more error paths one should remember to call 'mutex_unlock' Signed-off-by: Elad Wexler --- drivers/char/misc.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff -

[PATCH] Drivers: char: misc: 'misc_deregister()' changed the 'mutex_unlock' logic upon an error

2013-09-14 Thread Elad Wexler
From: Elad Wexler elad.wex...@gmail.com This change improves code readability is less error-prone. For example: case adding more error paths one should remember to call 'mutex_unlock' Signed-off-by: Elad Wexler elad.wex...@gmail.com --- drivers/char/misc.c | 8 1 file changed, 4

[PATCH] Time: Clocksource: fix 'ret' data type of sysfs_override_clocksource() and sysfs_unbind_clocksource()

2013-09-13 Thread elad . wexler
From: Elad Wexler sysfs_override_clocksource(): The expression 'if (ret >= 0)' is always true. This will cause clocksource_select() to always run. Thus modified ret to be of type ssize_t. sysfs_unbind_clocksource(): The expression 'if (ret < 0)' is always false. So in case sysfs_get

[PATCH] Time: Clocksource: fix 'ret' data type of sysfs_override_clocksource() and sysfs_unbind_clocksource()

2013-09-13 Thread elad . wexler
From: Elad Wexler elad.wex...@gmail.com sysfs_override_clocksource(): The expression 'if (ret = 0)' is always true. This will cause clocksource_select() to always run. Thus modified ret to be of type ssize_t. sysfs_unbind_clocksource(): The expression 'if (ret 0)' is always false. So in case