Re: [PATCH v2] integrity: Add declarations to init_once void arguments.

2021-04-09 Thread Jiele Zhao
Okay, thank you. I'll keep an eye on that ! On 2021/4/10 2:55, Mimi Zohar wrote: Hi Jiele, On Wed, 2021-04-07 at 01:44 +, Jiele Zhao wrote: init_once is a callback to kmem_cache_create. The parameter type of this function is void *, so it's better to give a explicit cast here. Signed-off

Re: [PATCH v2] integrity: Add declarations to init_once void arguments.

2021-04-08 Thread Jiele Zhao
Hi Mimi, And this is another patch that has been modified. On 2021/4/7 9:44, Jiele Zhao wrote: init_once is a callback to kmem_cache_create. The parameter type of this function is void *, so it's better to give a explicit cast here. Signed-off-by: Jiele Zhao --- security/integrity/iint.c

Re: [PATCH v2] ima: Fix function name error in comment.

2021-04-08 Thread Jiele Zhao
Hi Mimi, On 2021/4/6 10:12, Jiele Zhao wrote: The original function name was ima_path_check(). The policy parsing still supports PATH_CHECK. Commit 9bbb6cad0173 ("ima: rename ima_path_check to ima_file_check") renamed the function to ima_file_check(), but missed modifying the fun

[PATCH v2] integrity: Add declarations to init_once void arguments.

2021-04-06 Thread Jiele Zhao
init_once is a callback to kmem_cache_create. The parameter type of this function is void *, so it's better to give a explicit cast here. Signed-off-by: Jiele Zhao --- security/integrity/iint.c | 2 +- security/integrity/ima/ima_main.c | 2 +- 2 files changed, 2 insertions(+), 2

Re: [PATCH] integrity/ima: Add declarations to init_once void arguments.

2021-04-06 Thread Jiele Zhao
Hi Mimi, Please see if this is a useful suggestion. On 2021/4/6 10:38, James Morris wrote: On Tue, 6 Apr 2021, Jiele Zhao wrote: Ping. Mimi Zohar is the maintainer for this code. On 2021/3/23 9:33, Jiele Zhao wrote: init_once is a callback to kmem_cache_create. The parameter type

Re: [PATCH] integrity/ima: Add declarations to init_once void arguments.

2021-04-05 Thread Jiele Zhao
Ping. On 2021/3/23 9:33, Jiele Zhao wrote: init_once is a callback to kmem_cache_create. The parameter type of this function is void *, so it's better to give a explicit cast here. Signed-off-by: Jiele Zhao --- security/integrity/iint.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion

[PATCH v2] ima: Fix function name error in comment.

2021-04-05 Thread Jiele Zhao
uot;ima: rename ima_path_check to ima_file_check"). Signed-off-by: Jiele Zhao --- security/integrity/ima/ima_main.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/security/integrity/ima/ima_main.c b/security/integrity/ima/ima_main.c index 9ef748ea829f..03bef720ab44 1

Re: [PATCH] integrity/ima: Add declarations to init_once void arguments.

2021-03-29 Thread Jiele Zhao
Ping. On 2021/3/23 9:33, Jiele Zhao wrote: init_once is a callback to kmem_cache_create. The parameter type of this function is void *, so it's better to give a explicit cast here. Signed-off-by: Jiele Zhao --- security/integrity/iint.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion

[PATCH] integrity/ima: Add declarations to init_once void arguments.

2021-03-22 Thread Jiele Zhao
init_once is a callback to kmem_cache_create. The parameter type of this function is void *, so it's better to give a explicit cast here. Signed-off-by: Jiele Zhao --- security/integrity/iint.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/security/integrity/iint.c b

Re: [PATCH] security/loadpin: Update the changing interface in the source code.

2021-03-15 Thread Jiele Zhao
On 2021/3/8 10:03, Jiele zhao wrote: Loadpin cmdline interface "enabled" has been renamed to "enforce" for a long time, but the User Description Document was not updated. (Meaning unchanged) And kernel_read_file* were moved from linux/fs.h to its own linux/kernel_read_fil

[PATCH v3] security/loadpin: Replace "kernel_read_file_str[j]" with function "kernel_read_file_id_str(j)".

2021-03-04 Thread Jiele zhao
_read_file_id)); to make sure the arrays stay within expected sizes. By the way, sorry for that mistake PATCH v2 file, I sent wrong path... ... Signed-off-by: Jiele zhao --- security/loadpin/loadpin.c | 7 --- 1 file changed, 4 insertions(+), 3 deletions(-) diff --git a/security/loadpi

[PATCH v2] security/loadpin: Replace "kernel_read_file_str[j]" with function "kernel_read_file_id_str(j)".

2021-03-04 Thread Jiele zhao
_read_file_id)); to make sure the arrays stay within expected sizes. Signed-off-by: Jiele zhao --- security/loadpin/loadpin.c | 7 --- 1 file changed, 4 insertions(+), 3 deletions(-) diff --git a/security/loadpin/loadpin.c b/security/loadpin/loadpin.c index b12f7d986b1e..3d59ff363087