Re: [PATCH 4/5] Fix the configuration dependencies

2007-11-27 Thread Ken';ichi Ohmichi
GMEM_ENABLE. But the dependency was wrong, and it should depend on CONFIG_NUMA. The part is necessary for a NUMA kernel even if sparsemem. Thanks Ken'ichi Ohmichi --- Signed-off-by: Ken'ichi Ohmichi <[EMAIL PROTECTED]> --- diff -rpuN a/arch/x86/kernel/machine_kexec_64.c b/arch/x

Re: [PATCH 4/5] Fix the configuration dependencies

2007-11-20 Thread Ken';ichi Ohmichi
Hi Simon, Thank you for reviewing and your "Acked-by" signs. Simon Horman wrote: > On Fri, Nov 16, 2007 at 11:33:20AM +0900, Ken'ichi Ohmichi wrote: >> This patch fixes the configuration dependencies in the vmcoreinfo data. >> >> i386's "node_

[PATCH 1/5] Rename vmcoreinfo's macros returning the size

2007-11-15 Thread Ken';ichi Ohmichi
s the following: http://www.ussg.iu.edu/hypermail/linux/kernel/0709.3/0582.html Signed-off-by: Ken'ichi Ohmichi <[EMAIL PROTECTED]> Acked-by: David Rientjes <[EMAIL PROTECTED]> --- diff -rpuN a/arch/ia64/kernel/machine_kexec.c b/arch/ia64/kernel/machine_kexec.c --- a/arch/ia64/kernel/ma

[PATCH 4/5] Fix the configuration dependencies

2007-11-15 Thread Ken';ichi Ohmichi
_SPARSEMEM)+= discontig.o ia64's "node_memblk" is defined in arch/ia64/mm/numa.c, and it depends on CONFIG_NUMA: arch/ia64/mm/Makefile:8 obj-$(CONFIG_NUMA) += numa.o Signed-off-by: Ken'ichi Ohmichi <[EMAIL PROTECTED]> --- diff -rpuN a/arch/ia64/kernel/

[PATCH 5/5] Add the array length of "free_list" for filtering free pages

2007-11-15 Thread Ken';ichi Ohmichi
e_list" and the vmcoreinfo data should contain it. Signed-off-by: Huang Ying <[EMAIL PROTECTED]> Tested-by: Ken'ichi Ohmichi <[EMAIL PROTECTED]> --- diff -rpuN a/kernel/kexec.c b/kernel/kexec.c --- a/kernel/kexec.c2007-11-12 11:15:26.0 +0900 +++ b/kernel/kexec.c

[PATCH 2/5] Use the existing offsetof() for VMCOREINFO_OFFSET()

2007-11-15 Thread Ken';ichi Ohmichi
It is better that the existing offsetof() is used for VMCOREINFO_OFFSET(). This discussion is the following: http://www.ussg.iu.edu/hypermail/linux/kernel/0709.3/0584.html Signed-off-by: Ken'ichi Ohmichi <[EMAIL PROTECTED]> --- diff -rpuN a/include/linux/kexec.h b/include/linux/ke

[PATCH 3/5] Add "VMCOREINFO_" to all the call for vmcoreinfo_append_str()

2007-11-15 Thread Ken';ichi Ohmichi
For readability, all the calls to vmcoreinfo_append_str() are changed to macros having a prefix "VMCOREINFO_". This discussion is the following: http://www.ussg.iu.edu/hypermail/linux/kernel/0709.3/0584.html Signed-off-by: Ken'ichi Ohmichi <[EMAIL PROTECTED]> --- diff

[PATCH 0/5] vmcoreinfo patches for linux-2.6.24-rc3

2007-11-15 Thread Ken';ichi Ohmichi
fixing the configuration dependencies. Patch 5 is a new patch for filtering free pages of linux-2.6.24. Their details are explained in each patch. I confirmed that their coding styles are right by checkpatch.pl and tested them on my i386, x86_64 and ia64. Thanks Ken'ichi Ohmichi - To unsubs

[PATCH] Dump filtering supports x86_64 sparsemem(Re: Linux v2.6.24-rc1)

2007-10-25 Thread Ken';ichi Ohmichi
eeds the symbol "init_level4_pgt". Thanks Ken'ichi Ohmichi --- Signed-off-by: Ken'ichi Ohmichi <[EMAIL PROTECTED]> --- diff -rpuN a/arch/x86/kernel/machine_kexec_64.c b/arch/x86/kernel/machine_kexec_64.c --- a/arch/x86/kernel/machine_kexec_64.c2007-10-26 11:05:

Re: [PATCH 2/3] [kexec-tools] Pass vmcoreinfo's address and size

2007-10-16 Thread Ken';ichi Ohmichi
Hi Simon, Simon Horman wrote: > On Wed, Aug 22, 2007 at 09:13:39PM +0900, Ken'ichi Ohmichi wrote: >> [2/3] [kexec-tools] Pass vmcoreinfo's address and size >> The patch is for kexec-tools-testing-20070330. >> (http://www.kernel.org/pub/linux/kernel/people/horms

Re: [PATCH 4/4] [-mm patch] Add a prefix "VMCOREINFO_" to the vmcoreinfo macros.

2007-09-25 Thread Ken';ichi Ohmichi
5. Re: [PATCH 5/4] [-mm patch] Rename macros returning the size. from Ken'ichi Ohmichi, 2007/09/25 http://www.ussg.iu.edu/hypermail/linux/kernel/0709.3/0582.html 6. Re: [PATCH 6/4] [-mm patch] use the existing offsetof(). from Ken'ichi Ohmichi, 2007/09/25 http:/

Re: [PATCH 6/4] [-mm patch] use the existing offsetof().

2007-09-25 Thread Ken';ichi Ohmichi
his mistake, these macros are very useful. For more readability, I think it is good that all the calls are changed to macros having a prefix "VMCOREINFO_" like the attached patch. Thanks Ken'ichi Ohmichi --- Signed-off-by: Ken'ichi Ohmichi <[EMAIL PROTECTED]> --- diff -rp

Re: [PATCH 5/4] [-mm patch] Rename macros returning the size.

2007-09-25 Thread Ken';ichi Ohmichi
Hi Satyam, Satyam Sharma wrote: > > On Thu, 20 Sep 2007, Ken'ichi Ohmichi wrote: >> >> [PATCH 5/4] [-mm patch] Rename macros returning the size. >> >> The #define SIZE() should be renamed STRUCT_SIZE() since it's always >> >> returning t

[PATCH 6/4] [-mm patch] use the existing offsetof().

2007-09-19 Thread Ken';ichi Ohmichi
[PATCH 6/4] [-mm patch] use the existing offsetof(). It is better that offsetof() is used for VMCOREINFO_OFFSET(). This idea is Joe Perches's. Thanks Ken'ichi Ohmichi --- Signed-off-by: Joe Perches <[EMAIL PROTECTED]> Signed-off-by: Ken'ichi Ohmichi <[EMAIL PROT

[PATCH 5/4] [-mm patch] Rename macros returning the size.

2007-09-19 Thread Ken';ichi Ohmichi
edefs. This idea is David Rientjes's. http://www.ussg.iu.edu/hypermail/linux/kernel/0709.1/1964.html Thanks Ken'ichi Ohmichi --- Signed-off-by: David Rientjes <[EMAIL PROTECTED]> Signed-off-by: Ken'ichi Ohmichi <[EMAIL PROTECTED]> --- diff -rpuN a/arch/ia64/kernel/ma

Re: [PATCH 4/4] [-mm patch] Add a prefix "VMCOREINFO_" to the vmcoreinfo macros.

2007-09-19 Thread Ken';ichi Ohmichi
Hi Andrew, Andrew Morton wrote: > > On Fri, 14 Sep 2007 12:00:18 +0900 "Ken'ichi Ohmichi" <[EMAIL PROTECTED]> > > wrote: > > >> >> [4/4] Add a prefix "VMCOREINFO_" to the vmcoreinfo macros. >> >>Old vmcoreinfo macros

Re: [PATCH 2/4] [-mm patch] Add nodemask_t's size and NR_FREE_PAGES's value to vmcoreinfo_data.

2007-09-19 Thread Ken';ichi Ohmichi
Hi David, David Rientjes wrote: > On Fri, 14 Sep 2007, Ken'ichi Ohmichi wrote: > >> diff -rpuN a/include/linux/kexec.h b/include/linux/kexec.h >> --- a/include/linux/kexec.h2007-09-10 23:28:42.0 +0900 >> +++ b/include/linux/kexec.h2007-09-10 23:29:52.

[PATCH 4/4] [-mm patch] Add a prefix "VMCOREINFO_" to the vmcoreinfo macros.

2007-09-13 Thread Ken';ichi Ohmichi
/hypermail/linux/kernel/0709.1/0415.html Thanks Ken'ichi Ohmichi --- Signed-off-by: Ken'ichi Ohmichi <[EMAIL PROTECTED]> --- diff -rpuN a/arch/i386/kernel/machine_kexec.c b/arch/i386/kernel/machine_kexec.c --- a/arch/i386/kernel/machine_kexec.c 2007-09-14 11:12:35.0 +0

[PATCH 3/4] [-mm patch] Use the existing ia64_tpa() instead of asm code.

2007-09-13 Thread Ken';ichi Ohmichi
[3/4] Use the existing ia64_tpa() instead of asm code. Thanks Ken'ichi Ohmichi --- Signed-off-by: Ken'ichi Ohmichi <[EMAIL PROTECTED]> --- diff -rpuN a/arch/ia64/kernel/machine_kexec.c b/arch/ia64/kernel/machine_kexec.c --- a/arch/ia64/kernel/machine_kexec.c 2007-09-10 23

[PATCH 2/4] [-mm patch] Add nodemask_t's size and NR_FREE_PAGES's value to vmcoreinfo_data.

2007-09-13 Thread Ken';ichi Ohmichi
I created the patch to let the kernel output them. makedumpfile site: https://sourceforge.net/projects/makedumpfile/ Thanks Ken'ichi Ohmichi --- Signed-off-by: Ken'ichi Ohmichi <[EMAIL PROTECTED]> --- diff -rpuN a/include/linux/kexec.h b/include/linux/kexec.h --- a/includ

[PATCH 1/4] [-mm patch] Cleanup the coding style according to Andrew's comments

2007-09-13 Thread Ken';ichi Ohmichi
conds() instead of xtime.tv_sec. - Use init_uts_ns.name.release instead of UTS_RELEASE. Thanks Ken'ichi Ohmichi --- Signed-off-by: Ken'ichi Ohmichi <[EMAIL PROTECTED]> Signed-off-by: Andrew Morton <[EMAIL PROTECTED]> --- diff -rpuN a/include/linux/kexec.h b/include/linux/

[PATCH 0/4] [-mm patch] Cleanup add-vmcoreinfo.patch v2

2007-09-13 Thread Ken';ichi Ohmichi
e to grep for them. So these names should be changed. This discussion is the following: http://www.ussg.iu.edu/hypermail/linux/kernel/0709.1/0415.html Thanks Ken'ichi Ohmichi - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PR

Re: [-mm patch] kernel/kexec.c: make code static

2007-09-12 Thread Ken';ichi Ohmichi
Hi Adrian, Maneesh, Maneesh Soni wrote: > On Mon, Sep 10, 2007 at 02:20:40PM +0200, Adrian Bunk wrote: >> On Mon, Sep 10, 2007 at 11:55:49AM +0900, Ken'ichi Ohmichi wrote: >>> Hi Adrian, >>> >>> >>> 2007/09/09 22:25:16 +0200, Adrian Bunk <[

[PATCH 3/3] [-mm patch] Use the existing ia64_tpa() instead of asm code

2007-09-10 Thread Ken';ichi Ohmichi
[3/3] Use the existing ia64_tpa() instead of asm code. Thanks Ken'ichi Ohmichi --- Signed-off-by: Ken'ichi Ohmichi <[EMAIL PROTECTED]> --- diff -rpuN a/arch/ia64/kernel/machine_kexec.c b/arch/ia64/kernel/machine_kexec.c --- a/arch/ia64/kernel/machine_kexec.c 2007-09-10 23

[PATCH 2/3] [-mm patch] Add nodemask_t's size and NR_FREE_PAGES's value to vmcoreinfo_data

2007-09-10 Thread Ken';ichi Ohmichi
I created the patch to let the kernel output them. makedumpfile site: https://sourceforge.net/projects/makedumpfile/ Thanks Ken'ichi Ohmichi --- Signed-off-by: Ken'ichi Ohmichi <[EMAIL PROTECTED]> --- diff -rpuN a/include/linux/kexec.h b/include/linux/kexec.h --- a/includ

[PATCH 1/3] [-mm patch] Cleanup the coding style according to Andrew's comments

2007-09-10 Thread Ken';ichi Ohmichi
conds() instead of xtime.tv_sec. - Use init_uts_ns.name.release instead of UTS_RELEASE. Thanks Ken'ichi Ohmichi --- Signed-off-by: Ken'ichi Ohmichi <[EMAIL PROTECTED]> Signed-off-by: Andrew Morton <[EMAIL PROTECTED]> --- diff -rpuN a/include/linux/kexec.h b/include/linux/

[PATCH 0/3] [-mm patch] Cleanup add-vmcoreinfo.patch

2007-09-10 Thread Ken';ichi Ohmichi
from the reliability viewpoint. So makedumpfile v1.2.0 came to need these values and I created the patch to let the kernel output them. makedumpfile site: https://sourceforge.net/projects/makedumpfile/ [3/3] Use the existing ia64_tpa() instead of asm code. Thanks Ken'ichi Ohmichi - To

Re: [-mm patch] kernel/kexec.c: make code static

2007-09-09 Thread Ken';ichi Ohmichi
e' undeclared (first use in this function) arch/ia64/kernel/machine_kexec.c:144: error: implicit declaration of function 'CONFIG' arch/ia64/kernel/machine_kexec.c:144: error: 'PGTABLE_3' undeclared (first use in this function) make[1]: *** [arch/ia64/kernel/machine_kexec.

Re: [PATCH 0/3] vmcoreinfo support for dump filtering

2007-09-03 Thread Ken';ichi Ohmichi
Hi, 2007/08/22 21:08:38 +0900, Ken'ichi Ohmichi <[EMAIL PROTECTED]> wrote: > >Hi Andrew, > >This patch set frees the restriction that makedumpfile users should >install a vmlinux file (including the debugging information) into >each system. > >makedumpfile co

Re: [PATCH 0/3] vmcoreinfo support for dump filtering

2007-08-23 Thread Ken';ichi Ohmichi
RELEASE); >> +vmcoreinfo_append_str("PAGESIZE=%d\n", PAGE_SIZE); > >I expect the virtualisation guys would be bothered by an open-coded access >to UTS_RELEASE. I guess it doesn't matter much here, but perhaps it'd be >setting a better example to use init

[PATCH 3/3] [makedumpfile] Extract vmcoreinfo from /proc/vmcore

2007-08-22 Thread Ken';ichi Ohmichi
[3/3] [makedumpfile] Extract vmcoreinfo from /proc/vmcore The patch is for makedumpfile v1.1.6. (https://sourceforge.net/projects/makedumpfile/) makedumpfile command extracts the vmcoreinfo data from /proc/vmcore and uses it for dump filtering. Thanks Ken'ichi Ohmichi --- Signed-o

[PATCH 2/3] [kexec-tools] Pass vmcoreinfo's address and size

2007-08-22 Thread Ken';ichi Ohmichi
ernel through ELF header of /proc/vmcore. When the second kernel is booting, the kernel gets them from the ELF header and creates vmcoreinfo's PT_NOTE segment into /proc/vmcore. Thanks Ken'ichi Ohmichi --- Signed-off-by: Dan Aloni <[EMAIL PROTECTED]> Signed-off-by: Ken'ichi

[PATCH 1/3] [linux] Add vmcoreinfo

2007-08-22 Thread Ken';ichi Ohmichi
[1/3] [linux] Add vmcoreinfo The patch is for linux-2.6.22. The patch adds the vmcoreinfo data. Its address and size are output to /sys/kernel/vmcoreinfo. Thanks Ken'ichi Ohmichi --- Signed-off-by: Dan Aloni <[EMAIL PROTECTED]> Signed-off-by: Ken'ichi Ohmichi <[EMAIL PROTEC

[PATCH 0/3] vmcoreinfo support for dump filtering

2007-08-22 Thread Ken';ichi Ohmichi
lied with [PATCH 1/3]. - Preload the second kernel by the kexec-tools applied with [PATCH 2/3]. - Cause panic and switch to the second kernel. - Get a dumpfile by the makedumpfile applied with [PATCH 3/3]: (Ex.) # makedumpfile -cd31 /proc/vmcore dumpfile Thanks Ken'ichi Ohmichi - To unsubscribe

Re: Determine version of kernel that produced vmcore

2007-07-23 Thread Ken';ichi Ohmichi
Hi Bernhard, 2007/07/19 01:10:50 +0200, Bernhard Walle <[EMAIL PROTECTED]> wrote: >[1] didn't we agree to vmcoreinfo? I agree to vmcoreinfo. I'll rename makedumpfile's config file to "vmcoreinfo". Thanks Ken'ichi Ohmichi - To unsubscribe from this list:

Re: Determine version of kernel that produced vmcore

2007-07-23 Thread Ken';ichi Ohmichi
ly. I'll start making new patches after the release. Thanks Ken'ichi Ohmichi - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/

Re: Determine version of kernel that produced vmcore

2007-07-23 Thread Ken';ichi Ohmichi
not read the info exported from kernel. This way new >features can be made to work on older kernels. That sounds good. Dan Aloni, I'd like to cooperate with you for implementing this feature. If you have some patches other than 2007/07/10 patches, could you send me them ? I will upd

Re: Determine version of kernel that produced vmcore

2007-07-18 Thread Ken';ichi Ohmichi
t dependent on somebody removing above variable tomorrow. >> > >> > Dan, are you planning to put the modified patch for discussions on LKML? >> >> You mean the proposal with the makedumpfile-compatible ELF note? >> Although I like that idea, I think Ken'ichi

Re: Determine version of kernel that produced vmcore

2007-07-13 Thread Ken';ichi Ohmichi
cified, because there is the rule that a mkdfinfo file should be generated on 1st-kernel. Now, I will change this rule for generating a mkdfinfo file on the kernel-building environment. I feel considering 2nd-kernel PAGESIZE as 1st-kernel PAGESIZE is better than considering the PAGESIZE o

Re: Determine version of kernel that produced vmcore

2007-07-11 Thread Ken';ichi Ohmichi
pages - zone.free_area - zone.vm_stat - zone.spanned_pages - free_area.free_list - list_head.next - list_head.prev * The numbers of array - mem_section - pgdat_list - node_data - zone.free_area I'd like to know your motivation for this work. I think you don't want to

Re: Determine version of kernel that produced vmcore

2007-07-09 Thread Ken';ichi Ohmichi
during 1st-kernel running. Even if CONFIGFILE will be updated, makedumpfile can read the CONFIGFILE because makedumpfile should be updated with CONFIGFILE. I'd like to change the name of CONFIGFILE to mkdfinfo. Thanks Ken'ichi Ohmichi - To unsubscribe from this list: send the line