Re: [PATCH 5.2 10/20] media: radio-raremono: change devm_k*alloc to k*alloc

2019-08-05 Thread Luke Nowakowski-Krijger
Hi there, On Fri, Aug 02, 2019 at 03:04:25AM -0700, Joe Perches wrote: > On Fri, 2019-08-02 at 11:40 +0200, Greg Kroah-Hartman wrote: > > From: Luke Nowakowski-Krijger > > > > commit c666355e60ddb4748ead3bdd983e3f7f2224aaf0 upstream. > > > > Change devm_k*allo

[PATCH RESEND] media: hdpvr: Add device num check and handling

2019-07-17 Thread Luke Nowakowski-Krijger
...@syzkaller.appspotmail.com Signed-off-by: Luke Nowakowski-Krijger --- Changes in V1: + add storing of incremented index in dev_num var + add bounds check on dev_num and appropriate error handling - remove attomic_inc_return from inside of hdpvr_register call drivers/media/usb/hdpvr/hdpvr-core.c | 14

[PATCH v2 RESEND] media: dvb_frontend.h: Fix shifting signed 32-bit value problem

2019-07-17 Thread Luke Nowakowski-Krijger
Fix DVBFE_ALGO_RECOVERY and DVBFE_ALGO_SEARCH_ERROR use BIT macro which fixes undefined behavior error by certain compilers. Also changed all other bit shifted definitions to use macro for better readability. Signed-off-by: Luke Nowakowski-Krijger --- Changes in V2: + Added BIT macro to all

Re: [PATCH 5.1 000/138] 5.1.18-stable review

2019-07-13 Thread Luke Nowakowski-Krijger
On Fri, Jul 12, 2019 at 02:17:44PM +0200, Greg Kroah-Hartman wrote: > This is the start of the stable review cycle for the 5.1.18 release. > There are 138 patches in this series, all will be posted as a response > to this one. If anyone has any issues with these being applied, please > let me know

Re: [PATCH 4.19 00/91] 4.19.59-stable review

2019-07-13 Thread Luke Nowakowski-Krijger
On Fri, Jul 12, 2019 at 02:18:03PM +0200, Greg Kroah-Hartman wrote: > This is the start of the stable review cycle for the 4.19.59 release. > There are 91 patches in this series, all will be posted as a response > to this one. If anyone has any issues with these being applied, please > let me know

Re: [PATCH 5.2 00/61] 5.2.1-stable review

2019-07-13 Thread Luke Nowakowski-Krijger
On Fri, Jul 12, 2019 at 02:19:13PM +0200, Greg Kroah-Hartman wrote: > This is the start of the stable review cycle for the 5.2.1 release. > There are 61 patches in this series, all will be posted as a response > to this one. If anyone has any issues with these being applied, please > let me know.

Re: [PATCH 3.16 000/129] 3.16.70-rc1 review

2019-07-08 Thread Luke Nowakowski-Krijger
On Mon, Jul 08, 2019 at 04:29:22PM +0100, Ben Hutchings wrote: > On Mon, 2019-07-08 at 06:05 -0700, Luke Nowakowski-Krijger wrote: > > Hello, > > > > I got 1 error when applying this patch series to the latest linux-3.16.y > > stable branch > > > >

Re: [PATCH 5.1 00/96] 5.1.17-stable review

2019-07-08 Thread Luke Nowakowski-Krijger
On Mon, Jul 08, 2019 at 05:12:32PM +0200, Greg Kroah-Hartman wrote: > This is the start of the stable review cycle for the 5.1.17 release. > There are 96 patches in this series, all will be posted as a response > to this one. If anyone has any issues with these being applied, please > let me know.

Re: [PATCH 4.14 00/56] 4.14.133-stable review

2019-07-08 Thread Luke Nowakowski-Krijger
On Mon, Jul 08, 2019 at 05:12:52PM +0200, Greg Kroah-Hartman wrote: > This is the start of the stable review cycle for the 4.14.133 release. > There are 56 patches in this series, all will be posted as a response > to this one. If anyone has any issues with these being applied, please > let me kno

Re: [PATCH 3.16 000/129] 3.16.70-rc1 review

2019-07-08 Thread Luke Nowakowski-Krijger
Hello, I got 1 error when applying this patch series to the latest linux-3.16.y stable branch fs/fuse/file.c:218:3: error: implicit declaration of function ‘stream_open’ Thanks, - Luke

[PATCH RESEND] media: hdpvr: Add device num check and handling

2019-07-06 Thread Luke Nowakowski-Krijger
...@syzkaller.appspotmail.com Signed-off-by: Luke Nowakowski-Krijger --- Changes in V1: + add storing of incremented index in dev_num var + add bounds check on dev_num and appropriate error handling - remove attomic_inc_return from inside of hdpvr_register call drivers/media/usb/hdpvr/hdpvr-core.c | 14

[PATCH v2] media: dvb_frontend.h: Fix shifting signed 32-bit value problem

2019-07-04 Thread Luke Nowakowski-Krijger
Fix DVBFE_ALGO_RECOVERY and DVBFE_ALGO_SEARCH_ERROR use BIT macro which fixes undefined behavior error by certain compilers. Also changed all other bit shifted definitions to use macro for better readability. Signed-off-by: Luke Nowakowski-Krijger --- Changes in V2: + Added BIT macro to all

[Linux-kernel-mentee, PATCH] media: dvb_frontend.h: Fix shifting signed 32-bit value problem

2019-07-04 Thread Luke Nowakowski-Krijger
Fix DVBFE_ALGO_RECOVERY and DVBFE_ALGO_SEARCH_ERROR to use U cast which fixes undefined behavior error by certain compilers. Signed-off-by: Luke Nowakowski-Krijger --- include/media/dvb_frontend.h | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/include/media

[Linux-kernel-mentees,PATCH] media: hdpvr: Add device num check and handling

2019-07-01 Thread Luke Nowakowski-Krijger
...@syzkaller.appspotmail.com Signed-off-by: Luke Nowakowski-Krijger --- Changes in V1: + add storing of incremented index in dev_num var + add bounds check on dev_num and appropriate error handling - remove attomic_inc_return from inside of hdpvr_register call drivers/media/usb/hdpvr/hdpvr-core.c | 14

[Linux-kernel-mentees] [PATCH v4 RESEND] Media: Radio: Change devm_k*alloc to k*alloc

2019-06-21 Thread Luke Nowakowski-Krijger
-after-free errors. This patch fixes this by manually allocating memory, and freeing it in the v4l2.release callback that gets called when the last radio device exits. Reported-and-tested-by: syzbot+a4387f5b6b799f6be...@syzkaller.appspotmail.com Signed-off-by: Luke Nowakowski-Krijger --- Changes