On Tue, Jan 06, 2015 at 09:42:21AM -0800, Greg Kroah-Hartman wrote:
> On Tue, Jan 06, 2015 at 03:29:56PM +0100, Mariusz Gorski wrote:
> > Add new attribute to simplify reading of current temperature.
> >
> > Signed-off-by: Mariusz Gorski
> > ---
> >
On Tue, Jan 06, 2015 at 04:01:47PM +0100, Richard Weinberger wrote:
> On Tue, Jan 6, 2015 at 3:29 PM, Mariusz Gorski
> wrote:
> > DS18B20 and it's brothers are pretty popular in the RaspberryPi world
> > when it comes to temperature measurement. All tutorials on the Intern
Add new attribute to simplify reading of current temperature.
Signed-off-by: Mariusz Gorski
---
drivers/w1/slaves/w1_therm.c | 32
1 file changed, 32 insertions(+)
diff --git a/drivers/w1/slaves/w1_therm.c b/drivers/w1/slaves/w1_therm.c
index 3bad3d6..65af193
ave's structures (e.g. family_data).
Mariusz Gorski (2):
w1: slaves: w1_therm: Extract read_rom function
w1: slaves: w1_therm: Add temp attribute
drivers/w1/slaves/w1_therm.c | 83 ++--
1 file changed, 65 insertions(+), 18 deletions(-)
--
2.2.1
--
To
Extract read_rom function to make it reusable by other attributes.
Signed-off-by: Mariusz Gorski
---
drivers/w1/slaves/w1_therm.c | 51
1 file changed, 33 insertions(+), 18 deletions(-)
diff --git a/drivers/w1/slaves/w1_therm.c b/drivers/w1/slaves
Hi Supid,
On Sat, Dec 06, 2014 at 03:39:33PM +0530, Sudip Mukherjee wrote:
> On Sat, Dec 06, 2014 at 09:41:08AM +0100, Willy Tarreau wrote:
> > Hi Sudip,
> >
> > [ CCing Mariusz who's currently cleaning up the driver ]
> >
> > On Tue, Dec 02, 2014 at 01:32:14PM +0530, Sudip Mukherjee wrote:
> >
On Sat, Dec 06, 2014 at 01:46:52PM +0530, Sudip Mukherjee wrote:
> On Fri, Dec 05, 2014 at 10:10:43PM +0100, Mariusz Gorski wrote:
> > Get rid of magic numbers in LCD commands and replace them with defined
> > values, so that it's more obvious that the commands are doing.
>
Get rid of magic numbers in LCD commands and replace them with defined
values, so that it's more obvious that the commands are doing.
Signed-off-by: Mariusz Gorski
---
v2: Found and got rid of two more magic number usages
drivers/staging/panel/panel.c
Get rid of magic numbers in LCD commands and replace them with defined
values, so that it's more obvious that the commands are doing.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 83 +--
1 file changed, 57 insertions(+), 26 dele
Remove lcd.left_shift because it is only written to at some places but
never read from.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/staging/panel/panel.c b/drivers/staging/panel/panel.c
index 98325b7..b68a9c3
On Fri, Nov 28, 2014 at 12:32:48PM -0800, Greg Kroah-Hartman wrote:
> On Thu, Nov 27, 2014 at 08:50:55PM +0100, Mariusz Gorski wrote:
> > On Thu, Nov 27, 2014 at 07:57:06AM -0800, Greg Kroah-Hartman wrote:
> > > On Thu, Nov 27, 2014 at 07:24:17AM -0800, Greg Kroah-Hartman wro
Remove useless function and let the kernel call the actual
init function directly.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 7 +--
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/drivers/staging/panel/panel.c b/drivers/staging
Avoid magic number and use a comparison with a defined value instead
that checks whether module param has been set by the user to some
value at loading time.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 86
Make keypad_type and lcd_type module params read-only.
This step also starts making it more clear what is
the precedence of device params coming from different
sources (device profile, runtime module param values etc).
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging
Move more or less all LCD-related state into struct lcd
in order to get better cohesion; use bool instead of int
where it makes sense.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 255 ++
1 file changed, 134
Use a defined value instead of magic number comparison
for checking whether a module param value has been set.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 20 ++--
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a
Start decoupling module params from the actual device state,
both for lcd and keypad, by keeping the params read-only
and moving the device state to related structs.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 35
Rework lcd_init method to make it a little bit more clear about
the precedence of the params, move LCD geometry and pins layout
to the LCD struct and thus make the LCD-related module params
effectively read-only.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel
Set default parport module param value to DEFAULT_PARPORT so that
a if-block can be avoided.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/staging/panel/panel.c b/drivers
to behaviour of
the code itself (at least for now), so all hacky places are kept.
The whole patchset is already:
Acked-by: Willy Tarreau
v2: Don't introduce new macros for param value check
v3: Resend, no other changes
Mariusz Gorski (9):
staging: panel: Set default parport module param
Get rid of magic numbers indicating that the value of a module param
is not set. Use a defined value instead.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 22 --
1 file changed, 12 insertions(+), 10 deletions(-)
diff --git a
On Thu, Nov 27, 2014 at 07:57:06AM -0800, Greg Kroah-Hartman wrote:
> On Thu, Nov 27, 2014 at 07:24:17AM -0800, Greg Kroah-Hartman wrote:
> > On Thu, Nov 27, 2014 at 02:26:59PM +0100, Mariusz Gorski wrote:
> > > On Wed, Nov 26, 2014 at 01:58:01PM -0800, Greg Kroah-Hartman wro
On Wed, Nov 26, 2014 at 01:58:01PM -0800, Greg Kroah-Hartman wrote:
> On Wed, Nov 19, 2014 at 09:38:46PM +0100, Mariusz Gorski wrote:
> > Avoid magic number and use a comparison with a defined value instead
> > that checks whether module param has been set by the user to some
>
Remove useless function and let the kernel call the actual
init function directly.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 7 +--
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/drivers/staging/panel/panel.c b/drivers/staging
Avoid magic number and use a comparison with a defined value instead
that checks whether module param has been set by the user to some
value at loading time.
Signed-off-by: Mariusz Gorski
---
v2: Don't introduce new macros for param value check
drivers/staging/panel/panel.c
Get rid of magic numbers indicating that the value of a module param
is not set. Use a defined value instead.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 22 --
1 file changed, 12 insertions(+), 10 deletions(-)
diff --git a
Rework lcd_init method to make it a little bit more clear about
the precedence of the params, move LCD geometry and pins layout
to the LCD struct and thus make the LCD-related module params
effectively read-only.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 304
Use a defined value instead of magic number comparison
for checking whether a module param value has been set.
Signed-off-by: Mariusz Gorski
---
v2: Don't introduce new macros for param value check
drivers/staging/panel/panel.c | 20 ++--
1 file changed, 10 insertions(+
Make keypad_type and lcd_type module params read-only.
This step also starts making it more clear what is
the precedence of device params coming from different
sources (device profile, runtime module param values etc).
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 71
Move more or less all LCD-related state into struct lcd
in order to get better cohesion; use bool instead of int
where it makes sense.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 255 ++
1 file changed, 134
Start decoupling module params from the actual device state,
both for lcd and keypad, by keeping the params read-only
and moving the device state to related structs.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 35
Set default parport module param value to DEFAULT_PARPORT so that
a if-block can be avoided.
Signed-off-by: Mariusz Gorski
Acked-by: Willy Tarreau
---
drivers/staging/panel/panel.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/staging/panel/panel.c b/drivers
to behaviour of
the code itself (at least for now), so all hacky places are kept.
v2: Don't introduce new macros for param value check
Mariusz Gorski (9):
staging: panel: Set default parport module param value
staging: panel: Call init function directly
staging: panel: Remove magic nu
On Tue, Nov 18, 2014 at 10:25:23PM +0100, Willy Tarreau wrote:
> On Tue, Nov 18, 2014 at 09:56:13PM +0100, Mariusz Gorski wrote:
> > Use a macro instead of magic number comparison for checking
> > whether a module param value has been set.
> >
> > Si
On Tue, Nov 18, 2014 at 10:23:26PM +0100, Willy Tarreau wrote:
> On Tue, Nov 18, 2014 at 09:56:12PM +0100, Mariusz Gorski wrote:
> > Rework lcd_init method to make it a little bit more clear about
> > the precedence of the params, move LCD geometry and pins layout
> > to th
On Tue, Nov 18, 2014 at 10:18:44PM +0100, Willy Tarreau wrote:
> On Tue, Nov 18, 2014 at 09:56:09PM +0100, Mariusz Gorski wrote:
> > Avoid values comparison and use a macro instead that checks
> > whether module param has been set by the user to some value
> > at loading time
On Tue, Nov 18, 2014 at 10:20:34PM +0100, Willy Tarreau wrote:
> On Tue, Nov 18, 2014 at 09:56:11PM +0100, Mariusz Gorski wrote:
> > Make keypad_type and lcd_type module params read-only.
> > This step also starts making it more clear what is
> > the precedence of devi
Remove useless function and let the kernel call the actual
init function directly.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 7 +--
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/drivers/staging/panel/panel.c b/drivers/staging/panel/panel.c
index
Use a macro instead of magic number comparison for checking
whether a module param value has been set.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 21 +++--
1 file changed, 11 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/panel/panel.c b
Avoid values comparison and use a macro instead that checks
whether module param has been set by the user to some value
at loading time.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 88 ++-
1 file changed, 45 insertions(+), 43
Make keypad_type and lcd_type module params read-only.
This step also starts making it more clear what is
the precedence of device params coming from different
sources (device profile, runtime module param values etc).
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 71
Get rid of magic numbers indicating that the value of a module param
is not set. Use a defined value instead.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 22 --
1 file changed, 12 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/panel
to behaviour of
the code itself (at least for now), so all hacky places are kept.
Mariusz Gorski (9):
staging: panel: Set default parport module param value
staging: panel: Call init function directly
staging: panel: Remove magic numbers
staging: panel: Use a macro for checking module
Start decoupling module params from the actual device state,
both for lcd and keypad, by keeping the params read-only
and moving the device state to related structs.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 35 +--
1 file changed, 21
Move more or less all LCD-related state into struct lcd
in order to get better cohesion; use bool instead of int
where it makes sense.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 255 ++
1 file changed, 134 insertions(+), 121
Set default parport module param value to DEFAULT_PARPORT so that
a if-block can be avoided.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/staging/panel/panel.c b/drivers/staging/panel/panel.c
Rework lcd_init method to make it a little bit more clear about
the precedence of the params, move LCD geometry and pins layout
to the LCD struct and thus make the LCD-related module params
effectively read-only.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 304
Change the order of the initial DEFAULT_* defines so that it
matches the Kconfig order.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/panel/panel.c b/drivers/staging/panel/panel.c
index
Change the order of the module parameter declarations
so that it matches the Kconfig order.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 73 ++-
1 file changed, 38 insertions(+), 35 deletions(-)
diff --git a/drivers/staging/panel
Give DEFAULT_KEYPAD and DEFAULT_LCD defines better names,
so that their meaning is emphasized.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/panel/panel.c b/drivers/staging
Change the order of the DEFAULT_* values redefines so that it
matches the Kconfig order.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 26 +-
1 file changed, 13 insertions(+), 13 deletions(-)
diff --git a/drivers/staging/panel/panel.c b/drivers
igger clean-up of current init code.
Mariusz Gorski (4):
staging: panel: Reorder initial DEFAULT_* defines
staging: panel: Reorder DEFAULT_* values redefines
staging: panel: Reorder module parameter declarations
staging: panel: Use better names for two defined values
drivers/staging/
On Wed, Nov 05, 2014 at 01:19:10PM +0300, Dan Carpenter wrote:
> On Tue, Nov 04, 2014 at 10:47:19PM +0100, Mariusz Gorski wrote:
> > Fix the implementation of a single-open policy for both
> > devices (lcd and keypad) by using atomic_t instead of plain ints.
> >
>
> Th
Fix the implementation of a single-open policy for both
devices (lcd and keypad) by using atomic_t instead of plain ints.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 19 ++-
1 file changed, 10 insertions(+), 9 deletions(-)
diff --git a/drivers/staging
Remove Lindent task from TODO file as it's obsolete.
Signed-off-by: Mariusz Gorski
---
v4: Keep checkpatch.pl on the list as there are still some strict issues.
drivers/staging/panel/TODO | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/panel/TODO b/drivers/staging/panel
On Sat, Nov 01, 2014 at 10:29:16AM +0530, Sudip Mukherjee wrote:
> On Fri, Oct 31, 2014 at 11:08:34PM +0100, Konrad Zapalowicz wrote:
> > On 10/31, Mariusz Gorski wrote:
> > > Remove Lindent and checkpatch.pl tasks from TODO file as the first one
> > > is obsolete and th
Remove Lindent and checkpatch.pl tasks from TODO file as the first one
is obsolete and the other one is already done.
Signed-off-by: Mariusz Gorski
---
v3: Fixed commit summary
drivers/staging/panel/TODO | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/panel/TODO b/drivers
Remove Lindent and checkpatch.pl tasks from TODO file as the first one
is obsolete and the other one is already done.
v2: Fixed commit summary
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/TODO | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/panel/TODO b/drivers
Remove Lindent and checkpatch.pl tasks from TODO file as the first one
is obsolete and the other one is already done.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/TODO | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/panel/TODO b/drivers/staging/panel/TODO
index
Fix "warning: missing initializer [-Wmissing-field-initializers]"
by using designated struct initializers.
Signed-off-by: Mariusz Gorski
---
drivers/staging/panel/panel.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/panel/panel.c
net/lnet/module.c:139:1: warning: symbol
'fini_lnet' was not declared. Should it be static?
Signed-off-by: Mariusz Gorski
---
drivers/staging/lustre/lnet/lnet/module.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/lustre/lnet/lnet/module.c
Apply __init marker to module's init function and __exit to module's
exit function as they both have no other usage.
Signed-off-by: Mariusz Gorski
---
drivers/staging/lustre/lnet/lnet/module.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/l
These patches fix some sparse warnings and apply __init and __exit
markers to module's init and exit functions.
v2: Add missing commit sign-offs
Mariusz Gorski (2):
staging: lustre: Reduce function visibility
staging: lustre: Use __init and __exit markers for lifecycle functions
dr
Apply __init marker to module's init function and __exit to module's
exit function as they both have no other usage.
---
drivers/staging/lustre/lnet/lnet/module.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/lustre/lnet/lnet/module.c
b/drivers/staging/lu
This patch fixes the following sparse warnings:
drivers/staging/lustre/lnet/lnet/module.c:47:1: warning: symbol
'lnet_configure' was not declared. Should it be static?
drivers/staging/lustre/lnet/lnet/module.c:67:1: warning: symbol
'lnet_unconfigure' was not declared. Should it be static?
drive
These patches fix some sparse warnings and apply __init and __exit
markers to module's init and exit functions.
Mariusz Gorski (2):
staging: lustre: Reduce function visibility
staging: lustre: Use __init and __exit markers for lifecycle functions
drivers/staging/lustre/lnet/lnet/mod
t;
>> On 10/19/14 02:46, Mariusz Gorski wrote:
>>> Sparse throws the following warning, which I can't really understand:
>>>
>>> $ make drivers/staging/vt6655/ C=2
>>> [...]
>>> CHECK drivers/staging/vt6655/datarate.c
>>> d
Sparse throws the following warning, which I can't really understand:
$ make drivers/staging/vt6655/ C=2
[...]
CHECK drivers/staging/vt6655/datarate.c
drivers/staging/vt6655/datarate.c:302:40: warning: Initializer entry
defined twice
drivers/staging/vt6655/datarate.c:302:46: also defined her
68 matches
Mail list logo