Re: [PATCH v2] staging: wlan-ng: Fixed too long code line warnings.

2016-12-02 Thread Markus Böhme
On 12/02/2016 11:09 AM, Yan Laijun wrote: > Fixed checkpatch warning "line over 80 characters" in > wlan-ng/hfa384x_usb.c file. > > Signed-off-by: Yan Laijun > --- > Changes in v2: > - Remove initialization of usbin on its decarlation. > --- > drivers/staging/wlan-ng/hfa384x_usb.c | 3 ++- > 1

Re: [PATCH v3 net-next 1/2] net: ethernet: slicoss: add slicoss gigabit ethernet driver

2016-11-29 Thread Markus Böhme
On 11/28/2016 09:46 PM, Lino Sanfilippo wrote: > Hi Markus, > > On 27.11.2016 18:59, Markus Böhme wrote: >> Hello Lino, >> >> just some things barely worth mentioning: >> > >> >> I found a bunch of unused #defines in sli

Re: [PATCH v3 net-next 1/2] net: ethernet: slicoss: add slicoss gigabit ethernet driver

2016-11-27 Thread Markus Böhme
Hello Lino, just some things barely worth mentioning: On 11/26/2016 01:20 PM, Lino Sanfilippo wrote: > Add driver for Alacritech gigabit ethernet cards with SLIC (session-layer > interface control) technology. The driver provides basic support without > SLIC for the following devices: > > - Moja

Re: [PATCH v2 2/2] staging: slicoss: remove UPDATE_STATS_GB macro and inline code

2016-11-24 Thread Markus Böhme
On 11/24/2016 08:21 PM, Sergio Paracuellos wrote: > This patch removes UPDATE_STATS_GB macro in slic.h header file > and just inline code. This improve readability. > > Signed-off-by: Sergio Paracuellos > --- > drivers/staging/slicoss/slic.h| 5 > drivers/staging/slicoss/slicoss.c | 52

Re: [PATCH 2/2] staging: slicoss: replace UPDATE_STATS_GB macro into an inline function

2016-11-23 Thread Markus Böhme
On 11/23/2016 08:00 PM, Markus Böhme wrote: > On 11/23/2016 07:10 PM, Sergio Paracuellos wrote: >> This patch replaces UPDATE_STATS_GB macro in slic.h header file >> into an inline function. This provides type safety and readability. >> >> Signed-off-by: Sergio Para

Re: [PATCH 2/2] staging: slicoss: replace UPDATE_STATS_GB macro into an inline function

2016-11-23 Thread Markus Böhme
On 11/23/2016 07:10 PM, Sergio Paracuellos wrote: > This patch replaces UPDATE_STATS_GB macro in slic.h header file > into an inline function. This provides type safety and readability. > > Signed-off-by: Sergio Paracuellos > --- > drivers/staging/slicoss/slic.h| 6 ++--- > drivers/staging/

Re: [PATCH] staging:android:io: Fix multiple styling issues

2016-09-22 Thread Markus Böhme
Hello Yannis! There is a typo in your one-line description/subject ("ion"). On 09/22/2016 07:55 PM, Yannis Damigos wrote: > This patch fixes 1 error, 1 warning and 14 checks found by > checkpatch. Please be more specific in your commit message and mention what exactly you are doing to the code a

Re: drivers: staging: vme: Fixed some code style warnings

2016-09-14 Thread Markus Böhme
w mail, and be sure to mark it as v2. In future mails, please avoid top-posting. It is frowned upon because it makes it unnecessarily hard to follow a discussion. Thanks, Markus > > > Исходное сообщение > От: Markus Böhme > Отправлено: среда, 14 сентября 2016 г.

Re: drivers: staging: vme: Fixed some code style warnings

2016-09-14 Thread Markus Böhme
On 09/13/2016 12:31 AM, Andrew Kanner wrote: > Signed-off-by: Andrew Kanner > --- > drivers/staging/vme/devices/vme_pio2_core.c | 12 ++-- > drivers/staging/vme/devices/vme_user.c | 2 +- > 2 files changed, 7 insertions(+), 7 deletions(-) > (snip) Hello Andrew, please be more spec

Re: [PATCH 33/33] Staging: android: ion: ion.c: Compression of lines for

2016-07-30 Thread Markus Böhme
On 07/30/2016 01:12 PM, Nadim almas wrote: > This patch compresses two lines in to a single line in file rtw_android.c > if immediate return statement is found. It also removes variable > bytes_written as it is no longer needed. This commit message is wrong. Neither are you editing rtw_android.c,

Re: [PATCH 32/32] Staging/octeon-usb/octeon-hcd.c: Compression of lines for immediate return This patch compresses two lines in to a single line in file octeon-hcd.c

2016-07-23 Thread Markus Böhme
Nadim, several points stand out in your patch: On 07/22/2016 12:17 PM, Nadim almas wrote: > if immediate return statement is found. It also removes variable > bytes_written as > it is no longer needed. > > It is done using script Coccinelle. And coccinelle uses following > semantic > patch for t

[PATCH] staging/rdma/hfi1: select CRC32

2016-03-31 Thread Markus Böhme
The function parse_platform_config in firmware.c calls crc32_le. Building without CRC32 selected causes a link error: drivers/built-in.o: In function `parse_platform_config': (.text+0x92ffa): undefined reference to `crc32_le' Signed-off-by: Markus Böhme --- drivers/staging/rdma/hf

Re: [PATCH v2 3/6] Staging: combine: daqboard2000: Simplify a trivial if-return sequence

2015-06-22 Thread Markus Böhme
--- a/drivers/staging/comedi/drivers/daqboard2000.c +++ b/drivers/staging/comedi/drivers/daqboard2000.c @@ -713,12 +713,8 @@ static int daqboard2000_auto_attach(struct comedi_device *dev, return result; s = &dev->subdevices[2]; - result = subdev_8255_init(dev, s, da

Re: [PATCH] Staging: sm750fb: fix checkpatch.pl indentation warnings

2015-06-14 Thread Markus Böhme
This patch fixes indentation issues by replacing spaces by tabs at the start of line Signed-off-by: Niranjan Dighe diff --git a/drivers/staging/sm750fb/ddk750_dvi.c b/drivers/staging/sm750fb/ddk750_dvi.c index b2bf7e6..c73b74a 100644 --- a/drivers/staging/sm750fb/ddk750_dvi.c +++ b/drivers/sta