Thank you Peter for pointing out my miss, I appreciate that sincerely.
> * MSR_CORE_C3_RESIDENCY: CORE C3 Residency Counter
> * perf code: 0x01
> * Available model: NHM,WSM,SNB,IVB,HSW,BDW,SKL,GLM,
> -
> Why don't you add a "sync" helper function in main.c with the timing
> and message that will be called from hibernate.c, user.c and
> suspend.c
> (in the last one conditional on
> !IS_ENABLED(CONFIG_SUSPEND_SKIP_SYNC))?
>
> That would reduce some code duplication nicely.
I uploaded v5 in recipr
Thanks for comments.
> > + if (!IS_ENABLED(CONFIG_SUSPEND_SKIP_SYNC)) {
> > + ktime_t start;
> > + unsigned int elapsed_msecs;
> > +
> > + trace_suspend_resume(TPS("sync_filesystems"), 0, true);
> > + pr_info("Syncing filesystems ... ");
> > + st
>
> I'd rather educate other developers that this may happen. dmesg
> timestamps should already make it easy to see.
>
> And actually... if you do "time sync" in userspace just before
> programing the RTC and suspending, this whole issue should go away.
>
>
I agree w/ you on both comments basic
> The backdrop is some stress test script of suspend/resume, like
> Chrome
> OS, is designed to program an expected RTC wake-alarm then issue
> suspend command, while in rare case (or buggy software), the
> filesystem
> sync could cost longer time in seconds, this consumes the alarm
> budget
> caus
On Tue, 2019-02-05 at 22:23 +0100, Pavel Machek wrote:
> On Sun 2019-02-03 13:20:07, Harry Pan wrote:
> > This patch gives the reader an intuitive metric of the time cost by
> > the kernel issuing a filesystem sync during suspend; although
> > developer
> > can guess by the timestamp of next log or
On Tue, 2019-02-05 at 12:55 +0100, Rafael J. Wysocki wrote:
>
> > + ktime_t start, end, elapsed;
>
> Why do you need three vars here? One should be sufficient.
...
> > + start = ktime_get_boottime();
>
> Why _boottime()?
>
Yes, I agree both comments.
BTW, The initial idea came from proces
On Tue, 2016-09-13 at 15:41 +0200, Thomas Gleixner wrote:
> On Sun, 11 Sep 2016, Harry Pan wrote:
> > This patch also enables multiple quirks.
>
> This patch adds a single quirk for Baytrail.
>
> Please stop sending out patches 5 seconds after a review. Take your time
Definitely I take this seri
My apology that I resent again in order to clean my junk of useless
enum, and ignore ambiguous in-reply-to (2016/9/11/8) due to subject.
new patchset is here:
https://lkml.org/lkml/2016/9/11/11
https://lkml.org/lkml/2016/9/11/12
https://lkml.org/lkml/2016/9/11/10
Thanks,
Harry
Hi Thomas,
Appreciate comments, I understood and learned.
I just uploaded 3 patches integrated yours, yet there was 'git am'
failure thus I did hand work, kindly double check.
Sincerely,
Harry
On Fri, 2016-09-09 at 23:21 +0200, Thomas Gleixner wrote:
> On Fri, 9 Sep 2016, Pan
I refined/uploaded again, kindly advise.
On Fri, 2016-09-09 at 17:11 +0200, Thomas Gleixner wrote:
> On Fri, 9 Sep 2016, Harry Pan wrote:
> > - if (apply_quirk)
> > + if (apply_quirk == RAPL_HSX_QUIRK)
> > rapl_hw_unit[RAPL_IDX_RAM_NRG_STAT] = 16;
> >
> > /*
> > +* Some A
Hi Peter,
Totally agreed and uploaded patchset again.
https://lkml.org/lkml/2016/9/9/467
https://lkml.org/lkml/2016/9/9/468
One more thing, I did not refine rapl_advertise() description.
Advice is welcome.
Sincerely,
Harry
On Fri, 2016-09-09 at 11:29 +0200, Peter Zijlstra wrote:
> On Thu, Sep 08
On Thu, 2016-03-17 at 09:54 +, Mark Brown wrote:
> On Wed, Mar 16, 2016 at 07:17:51PM +0800, Harry Pan wrote:
>
> > Conflicts:
> > sound/soc/soc-dapm.c
>
> Don't include noise like this in upstream submissions.
>
I learned, thanks.
> > + if (!strcmp(cmpnt->name, "snd-soc-dummy"))
> > +
> I'd say as a quick fix for stable check that card is not NULL in
> dapm_widget_show_component(). And as a longterm fix get rid of
> dapm_widget
> file. Nobody should hopefully use it anymore with debugfs being
> available as
> the far better alternative.
>
> - Lars
Well, that was my original ap
14 matches
Mail list logo