Re: [PATCH, new ACPI driver] new sony_acpi driver

2005-02-11 Thread Pekka Enberg
On Fri, 11 Feb 2005 12:36:37 +0100, Stelian Pop <[EMAIL PROTECTED]> wrote: > +static int __init sony_acpi_add(struct acpi_device *device) > +{ > + acpi_status status = AE_OK; > + struct sony_snc *snc = NULL; > + int result; > + > + snc = kmalloc(sizeof(struct sony_snc), GFP_

Re: [PATCH, new ACPI driver] new sony_acpi driver

2005-02-11 Thread Pekka Enberg
On Thu, 10 Feb 2005 17:18:10 +0100, Stelian Pop <[EMAIL PROTECTED]> wrote: > +static int sony_acpi_write_brt(struct file *file, const char __user *buffer, > unsigned long count, void *data) > +{ > + struct sony_snc *snc = (struct sony_snc *) data; The casts for void pointer conversiosn are

Re: [PATCH] relayfs redux, part 4

2005-02-09 Thread Pekka Enberg
On Wed, 9 Feb 2005 20:49:36 -0600, Tom Zanussi <[EMAIL PROTECTED]> wrote: > +static int relayfs_create_entry(const char *name, struct dentry *parent, > + int mode, struct rchan *chan, > + struct dentry **dentry) > +{ > + struct qstr

Re: [PATCH] relayfs redux, part 4

2005-02-09 Thread Pekka Enberg
Hi Tom, On Wed, 9 Feb 2005 20:49:36 -0600, Tom Zanussi <[EMAIL PROTECTED]> wrote: > +static inline struct page **alloc_page_array(int size, int *page_count) > +{ > + int n_pages; > + struct page **page_array; > + > + size = PAGE_ALIGN(size); > + n_pages = size >> PAGE_SHIFT

Re: [PATCH 9/8] lib/sort: turn off self-test

2005-02-09 Thread Pekka Enberg
On Mon, 31 Jan 2005 09:03:44 -0800, Matt Mackall <[EMAIL PROTECTED]> wrote: > It's a nice self-contained unit test. It's here because I ran into a > strange regparm-related bug when developing the code in userspace and > I wanted to be sure that it was easy to diagnose in the field if a > similar b

Re: [PATCH] PPC/PPC64: Introduce CPU_HAS_FEATURE() macro

2005-02-04 Thread Pekka Enberg
On Fri, 2005-02-04 at 11:20 -0600, Olof Johansson wrote: > * cpu-has-feature(cpu-feature-foo) v cpu-has-feature(foo): I picked the > latter for readability. > * Renaming CPU_FTR_ -> CPU_ makes it less obvious that > it's actually a cpu feature it's describing (i.e. CPU_ALTIVEC vs > CPU_FTR_ALTIVEC)

Re: [PATCH] PPC/PPC64: Introduce CPU_HAS_FEATURE() macro

2005-02-04 Thread Pekka Enberg
Hi, On Fri, 4 Feb 2005 01:22:54 -0600, Olof Johansson <[EMAIL PROTECTED]> wrote: > +#define CPU_HAS_FEATURE(x) (cur_cpu_spec->cpu_features & CPU_FTR_##x) > + Please drop the CPU_FTR_##x macro magic as it makes grepping more complicated. If the enum names are too long, just do s/CPU_FTR_/CPU_/

Re: [PATCH 2.6] 4/7 replace uml_strdup by kstrdup

2005-02-01 Thread Pekka Enberg
On Tue, 1 Feb 2005 03:28:31 +, [EMAIL PROTECTED] <[EMAIL PROTECTED]> wrote: > diff -buprN -X dontdiff > vanilla-2.6.11-rc2-bk9/arch/um/os-Linux/drivers/tuntap_user.c > linux-2.6.11-rc2-bk9/arch/um/os-Linux/drivers/tuntap_user.c > --- vanilla-2.6.11-rc2-bk9/arch/um/os-Linux/drivers/tuntap_use

Re: [PATCH 2.6] 1/7 create kstrdup library function

2005-02-01 Thread Pekka Enberg
At some point in time, I wrote: > > kstrdup() is a special-case _memory allocator_ (not so much a string > > operation) so I think it should go into mm/slab.c where we currently > > have kcalloc(). On Tue, 01 Feb 2005 17:00:17 +, Paulo Marques <[EMAIL PROTECTED]> wrote: > I was following Rusty

Re: [PATCH 2.6] 1/7 create kstrdup library function

2005-02-01 Thread Pekka Enberg
Hi, On Tue, 1 Feb 2005 03:28:21 +, [EMAIL PROTECTED] <[EMAIL PROTECTED]> wrote: > > This patch creates the kstrdup library function so that it doesn't have to be > reimplemented (or even EXPORT'ed) by every user that needs it. > > Signed-off-by: Paulo Marques <[EMAIL PROTECTED]> > > diff -

Re: [PATCH] relayfs redux for 2.6.10: lean and mean

2005-01-20 Thread Pekka Enberg
On Thu, 20 Jan 2005 01:23:48 -0500, Karim Yaghmour <[EMAIL PROTECTED]> wrote: > +config RELAYFS_FS > + tristate "Relayfs file system support" > + ---help--- > + Relayfs is a high-speed data relay filesystem designed to provide > + an efficient mechanism for tools and facilities

[PATCH 5/6] cifs: reduce deep nesting

2005-01-15 Thread Pekka Enberg
This patch converts deep if statement nesting to use gotos in few places. Signed-off-by: Pekka Enberg <[EMAIL PROTECTED]> --- cifsfs.c | 51 +++ connect.c | 44 2 files changed, 51 inse

[PATCH 6/6] cifs: convert schedule_timeout to msleep and ssleep

2005-01-15 Thread Pekka Enberg
This patch converts cifs code to use msleep() and ssleep() instead of schedule_timeout(). Signed-off-by: Pekka Enberg <[EMAIL PROTECTED]> --- cifsfs.c |9 - connect.c | 25 + 2 files changed, 13 insertions(+), 21 deletions(-) Index: 2.6/fs/cifs/ci

[PATCH 3/6] cifs: enum conversion

2005-01-15 Thread Pekka Enberg
Convert #defines to proper enums and remove duplicate symbols. Signed-off-by: Pekka Enberg <[EMAIL PROTECTED]> --- asn1.c| 72 +++-- cifspdu.h | 798 -- 2 files changed, 464 insertions(+), 406 deletions(-) Index: 2.6/f

[PATCH 4/6] cifs: remove spurious casts

2005-01-15 Thread Pekka Enberg
Remove spurious void pointer casts. Signed-off-by: Pekka Enberg <[EMAIL PROTECTED]> --- cifsfs.c|9 - dir.c |6 ++ file.c | 32 +--- misc.c | 17 - readdir.c |6 +++--- transport.c |5 ++

[PATCH 2/6] cifs: remove dead code

2005-01-15 Thread Pekka Enberg
This patch removes commented out code. Signed-off-by: Pekka Enberg <[EMAIL PROTECTED]> --- asn1.c| 122 -- cifsencrypt.c |5 -- cifsfs.c | 25 --- cifssmb.c | 48 +- con

[PATCH 1/6] cifs: copy_to_user and copy_from_user fixes

2005-01-15 Thread Pekka Enberg
Check return value for copy_to_user() and copy_from_user(). Signed-off-by: Pekka Enberg <[EMAIL PROTECTED]> --- cifssmb.c | 37 ++--- file.c|6 +- 2 files changed, 27 insertions(+), 16 deletions(-) Index: linux/fs/cifs/cif

<    5   6   7   8   9   10