[PATCH] drivers: spi: convert to devm_ioremap_resource()

2013-05-13 Thread Silviu-Mihai Popescu
coccinelle. Signed-off-by: Silviu-Mihai Popescu --- drivers/spi/spi-bcm2835.c |7 +++ 1 file changed, 3 insertions(+), 4 deletions(-) diff --git a/drivers/spi/spi-bcm2835.c b/drivers/spi/spi-bcm2835.c index 89c0b50..a4185e4 100644 --- a/drivers/spi/spi-bcm2835.c +++ b/drivers/spi/spi-bcm2835.c

[PATCH] drivers: iio: adc: convert to devm_ioremap_resource()

2013-05-11 Thread Silviu-Mihai Popescu
Convert all uses of devm_request_and_ioremap() to the newly introduced devm_ioremap_resource() which provides more consistent error handling. Signed-off-by: Silviu-Mihai Popescu --- drivers/iio/adc/exynos_adc.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a

[PATCH] drivers: ata: rcar: use devm_ioremap_resource()

2013-04-11 Thread Silviu-Mihai Popescu
Convert use of devm_request_and_ioremap() to the newly introduced devm_ioremap_resource() which provides more consistent error handling. This was found with coccinelle. Signed-off-by: Silviu-Mihai Popescu --- drivers/ata/sata_rcar.c |6 +++--- 1 file changed, 3 insertions(+), 3 deletions

[PATCH] drivers: tty: serial: use devm_ioremap_resource()

2013-04-11 Thread Silviu-Mihai Popescu
coccinelle. Signed-off-by: Silviu-Mihai Popescu --- drivers/tty/serial/serial-tegra.c |8 +++- 1 file changed, 3 insertions(+), 5 deletions(-) diff --git a/drivers/tty/serial/serial-tegra.c b/drivers/tty/serial/serial-tegra.c index 372de8a..2080fd7 100644 --- a/drivers/tty/serial/serial

[PATCH] net: ethernet: stmicro: stmmac: use devm_ioremap_resource()

2013-04-11 Thread Silviu-Mihai Popescu
coccinelle. Signed-off-by: Silviu-Mihai Popescu --- .../net/ethernet/stmicro/stmmac/stmmac_platform.c |8 +++- 1 file changed, 3 insertions(+), 5 deletions(-) diff --git a/drivers/net/ethernet/stmicro/stmmac/stmmac_platform.c b/drivers/net/ethernet/stmicro/stmmac/stmmac_platform.c index

[PATCH] drivers: usb: chipidea: convert to devm_ioremap_resource()

2013-04-10 Thread Silviu-Mihai Popescu
Convert use of devm_request_and_ioremap() to the newly introduced devm_ioremap_resource() which provides more consistent error handling. devm_ioremap_resource() provides its own error messages so all explicit error messages can be removed from the failure code paths. Signed-off-by: Silviu-Mihai

[PATCH] drivers: mtd: devices: convert to devm_ioremap_resource()

2013-04-10 Thread Silviu-Mihai Popescu
Convert all uses of devm_request_and_ioremap() to the newly introduced devm_ioremap_resource() which provides more consistent error handling. Signed-off-by: Silviu-Mihai Popescu --- drivers/mtd/devices/elm.c |6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers

[PATCH] drivers: media: platform: convert to devm_ioremap_resource()

2013-04-10 Thread Silviu-Mihai Popescu
Convert all uses of devm_request_and_ioremap() to the newly introduced devm_ioremap_resource() which provides more consistent error handling. Signed-off-by: Silviu-Mihai Popescu --- drivers/media/platform/sh_veu.c |6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a

[PATCH] drivers: cpuidle: kirkwood: fix coccicheck warnings

2013-03-21 Thread Silviu-Mihai Popescu
-Mihai Popescu --- drivers/cpuidle/cpuidle-kirkwood.c |6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/cpuidle/cpuidle-kirkwood.c b/drivers/cpuidle/cpuidle-kirkwood.c index 670aa1e..53aad73 100644 --- a/drivers/cpuidle/cpuidle-kirkwood.c +++ b/drivers/cpuidle

[PATCH] drivers: cpufreq: kirkwood: fix coccicheck warnings

2013-03-21 Thread Silviu-Mihai Popescu
-Mihai Popescu --- drivers/cpufreq/kirkwood-cpufreq.c |8 +++- 1 file changed, 3 insertions(+), 5 deletions(-) diff --git a/drivers/cpufreq/kirkwood-cpufreq.c b/drivers/cpufreq/kirkwood-cpufreq.c index 0e83e3c..6052476 100644 --- a/drivers/cpufreq/kirkwood-cpufreq.c +++ b/drivers/cpufreq

[PATCH v2] drivers: staging: davinci_vpfe: use resource_size()

2013-03-18 Thread Silviu-Mihai Popescu
This uses the resource_size() function instead of explicit computation. Signed-off-by: Silviu-Mihai Popescu --- drivers/staging/media/davinci_vpfe/dm365_ipipe.c |2 +- drivers/staging/media/davinci_vpfe/dm365_isif.c|4 ++-- drivers/staging/media/davinci_vpfe/dm365_resizer.c |2

[PATCH] drivers: power: goldfish: use resource_size()

2013-03-17 Thread Silviu-Mihai Popescu
This uses the resource_size() function instead of explicit computation. Signed-off-by: Silviu-Mihai Popescu --- drivers/power/goldfish_battery.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/power/goldfish_battery.c b/drivers/power/goldfish_battery.c index

[PATCH] drivers: staging: davinci_vpfe: use resource_size()

2013-03-17 Thread Silviu-Mihai Popescu
This uses the resource_size() function instead of explicit computation. Signed-off-by: Silviu-Mihai Popescu --- drivers/staging/media/davinci_vpfe/dm365_ipipe.c |3 ++- drivers/staging/media/davinci_vpfe/dm365_isif.c|6 -- drivers/staging/media/davinci_vpfe/dm365_resizer.c

[PATCH] drivers: net: irda: use resource_size() in au1k_ir.c

2013-03-17 Thread Silviu-Mihai Popescu
This uses the resource_size() function instead of explicit computation. Signed-off-by: Silviu-Mihai Popescu --- drivers/net/irda/au1k_ir.c |5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/drivers/net/irda/au1k_ir.c b/drivers/net/irda/au1k_ir.c index b5151e4..56f1e6d

[PATCH] drivers: ata: use resource_size()

2013-03-16 Thread Silviu-Mihai Popescu
This uses the resource_size() function instead of explicit computation. Signed-off-by: Silviu-Mihai Popescu --- drivers/ata/pata_octeon_cf.c |3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/ata/pata_octeon_cf.c b/drivers/ata/pata_octeon_cf.c index ff2e57f

[PATCH] power: 88pm860x: fix invalid free of devm_* allocated data

2013-03-16 Thread Silviu-Mihai Popescu
The objects allocated by devm_* APIs are managed by devres and are freed when the device is detached. There is no need to use kfree() explicitly. Signed-off-by: Silviu-Mihai Popescu --- drivers/power/88pm860x_charger.c |1 - 1 file changed, 1 deletion(-) diff --git a/drivers/power

[PATCH] imx_drm: ipu_v3: fix invalid free of devm_* allocated data

2013-03-16 Thread Silviu-Mihai Popescu
The objects allocated by devm_* APIs are managed by devres and are freed when the device is detached. There is no need to use kfree() explicitly. Signed-off-by: Silviu-Mihai Popescu --- drivers/staging/imx-drm/ipu-v3/ipu-dp.c |1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging

[PATCH] sound: soc: fix invalid free of devm_ allocated data

2013-03-16 Thread Silviu-Mihai Popescu
The objects allocated by devm_* APIs are managed by devres and are freed when the device is detached. Hence there is no need to use kfree() explicitly. Signed-off-by: Silviu-Mihai Popescu --- sound/soc/soc-core.c |2 -- 1 file changed, 2 deletions(-) diff --git a/sound/soc/soc-core.c b

[PATCH] net: lpc_eth: fix coccicheck warnings

2013-03-12 Thread Silviu-Mihai Popescu
Use resource_size() instead of explicit calculation and change the way debugging for struct resource is done. Signed-off-by: Silviu-Mihai Popescu --- drivers/net/ethernet/nxp/lpc_eth.c |7 ++- 1 file changed, 2 insertions(+), 5 deletions(-) diff --git a/drivers/net/ethernet/nxp

[PATCH] ethernet: nxp: use resource_size()

2013-03-12 Thread Silviu-Mihai Popescu
Use resource_size() instead of explicit calculation. This was found via make coccicheck. Signed-off-by: Silviu-Mihai Popescu --- drivers/net/ethernet/nxp/lpc_eth.c |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/net/ethernet/nxp/lpc_eth.c b/drivers/net

[PATCH] mmc: host: use resource_size()

2013-03-12 Thread Silviu-Mihai Popescu
Use resource_size() instead of explicit calculation. This was found via make coccicheck. Signed-off-by: Silviu-Mihai Popescu --- drivers/mmc/host/android-goldfish.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/mmc/host/android-goldfish.c b/drivers/mmc/host

[PATCH] bluetooth: use PTR_RET instead of IS_ERR + PTR_ERR

2013-03-12 Thread Silviu-Mihai Popescu
This uses PTR_RET instead of IS_ERR and PTR_ERR in order to increase readability. Signed-off-by: Silviu-Mihai Popescu --- net/bluetooth/hci_sysfs.c |5 + 1 file changed, 1 insertion(+), 4 deletions(-) diff --git a/net/bluetooth/hci_sysfs.c b/net/bluetooth/hci_sysfs.c index 23b4e24

[PATCH] bridge: netfilter: use PTR_RET instead of IS_ERR + PTR_ERR

2013-03-12 Thread Silviu-Mihai Popescu
This uses PTR_RET instead of IS_ERR and PTR_ERR in order to increase readability. Signed-off-by: Silviu-Mihai Popescu --- net/bridge/netfilter/ebtable_broute.c |4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/net/bridge/netfilter/ebtable_broute.c b/net/bridge/netfilter

[PATCH] ipv4: netfilter: use PTR_RET instead of IS_ERR + PTR_ERR

2013-03-12 Thread Silviu-Mihai Popescu
This uses PTR_RET instead of IS_ERR and PTR_ERR in order to increase readability. Signed-off-by: Silviu-Mihai Popescu --- net/ipv4/netfilter/arptable_filter.c |4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/net/ipv4/netfilter/arptable_filter.c b/net/ipv4/netfilter

[PATCH v3] pci: convert to devm_ioremap_resource()

2013-03-12 Thread Silviu-Mihai Popescu
Convert all uses of devm_request_and_ioremap() to the newly introduced devm_ioremap_resource() which provides more consistent error handling. Signed-off-by: Silviu-Mihai Popescu --- arch/mips/pci/pci-ar71xx.c |6 +++--- arch/mips/pci/pci-ar724x.c | 18 +- 2 files changed

[PATCH] mach_omap2: use PTR_RET instead of IS_ERR + PTR_ERR

2013-03-12 Thread Silviu-Mihai Popescu
This uses PTR_RET instead of IS_ERR and PTR_ERR in order to increase readability. Signed-off-by: Silviu-Mihai Popescu --- arch/arm/mach-omap2/devices.c |4 ++-- arch/arm/mach-omap2/fb.c |5 + arch/arm/mach-omap2/gpmc.c|2 +- arch/arm/mach-omap2/pmu.c |5 + 4

[PATCH] ethernet: amd: use PTR_RET instead of IS_ERR + PTR_ERR

2013-03-12 Thread Silviu-Mihai Popescu
This uses PTR_RET instead of IS_ERR and PTR_ERR in order to increase readability. Signed-off-by: Silviu-Mihai Popescu --- drivers/net/ethernet/amd/atarilance.c |4 +--- drivers/net/ethernet/amd/mvme147.c|4 +--- drivers/net/ethernet/amd/ni65.c |2 +- drivers/net/ethernet

[PATCH v2] pci: convert to devm_ioremap_resource()

2013-03-12 Thread Silviu-Mihai Popescu
-Mihai Popescu --- arch/mips/pci/pci-ar71xx.c |6 +++--- arch/mips/pci/pci-ar724x.c | 18 +- 2 files changed, 12 insertions(+), 12 deletions(-) diff --git a/arch/mips/pci/pci-ar71xx.c b/arch/mips/pci/pci-ar71xx.c index 412ec02..18517dd 100644 --- a/arch/mips/pci/pci-ar71xx.c

[PATCH] parport: use kmemdup instead of kmalloc + memcpy

2013-03-11 Thread Silviu-Mihai Popescu
This replaces calls to kmalloc followed by memcpy with a single call to kmemdup. This was found via make coccicheck. Signed-off-by: Silviu-Mihai Popescu --- drivers/parport/parport_gsc.c|4 ++-- drivers/parport/parport_sunbpp.c |5 ++--- drivers/parport/procfs.c |6

[PATCH] fs: cifs: use kmemdup instead of kmalloc + memcpy

2013-03-11 Thread Silviu-Mihai Popescu
This replaces calls to kmalloc followed by memcpy with a single call to kmemdup. This was found via make coccicheck. Signed-off-by: Silviu-Mihai Popescu --- fs/cifs/cifs_spnego.c |3 +-- fs/cifs/cifsacl.c |3 +-- fs/cifs/cifssmb.c |3 +-- fs/cifs/sess.c|8

[PATCH] omap: convert to devm_ioremap_resource()

2013-03-11 Thread Silviu-Mihai Popescu
-Mihai Popescu --- sound/soc/omap/omap-dmic.c |9 +++-- sound/soc/omap/omap-mcpdm.c |8 +++- 2 files changed, 6 insertions(+), 11 deletions(-) diff --git a/sound/soc/omap/omap-dmic.c b/sound/soc/omap/omap-dmic.c index 77e9e7e..8ebaf11 100644 --- a/sound/soc/omap/omap-dmic.c +++ b

[PATCH] pci: use newly introduced devm_ioremap_resource()

2013-03-11 Thread Silviu-Mihai Popescu
-Mihai Popescu --- arch/mips/pci/pci-ar71xx.c |6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/arch/mips/pci/pci-ar71xx.c b/arch/mips/pci/pci-ar71xx.c index 412ec02..18517dd 100644 --- a/arch/mips/pci/pci-ar71xx.c +++ b/arch/mips/pci/pci-ar71xx.c @@ -366,9 +366,9

[PATCH v2] kirkwood: fix coccicheck warnings

2013-03-11 Thread Silviu-Mihai Popescu
-Mihai Popescu --- drivers/cpufreq/kirkwood-cpufreq.c |8 +++- drivers/cpuidle/cpuidle-kirkwood.c |6 +++--- 2 files changed, 6 insertions(+), 8 deletions(-) diff --git a/drivers/cpufreq/kirkwood-cpufreq.c b/drivers/cpufreq/kirkwood-cpufreq.c index 0e83e3c..6052476 100644 --- a/drivers

[PATCH] pci: convert to devm_ioremap_resource()

2013-03-11 Thread Silviu-Mihai Popescu
-Mihai Popescu --- arch/mips/pci/pci-ar724x.c | 18 +- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git a/arch/mips/pci/pci-ar724x.c b/arch/mips/pci/pci-ar724x.c index 8a0700d..65ec032 100644 --- a/arch/mips/pci/pci-ar724x.c +++ b/arch/mips/pci/pci-ar724x.c @@ -365,25

[PATCH] soc_camera: convert to devm_ioremap_resource()

2013-03-11 Thread Silviu-Mihai Popescu
-Mihai Popescu --- drivers/media/platform/soc_camera/pxa_camera.c |6 +++--- .../platform/soc_camera/sh_mobile_ceu_camera.c |8 +++- drivers/media/platform/soc_camera/sh_mobile_csi2.c |8 +++- 3 files changed, 9 insertions(+), 13 deletions(-) diff --git a/drivers/media

[PATCH] watchdog: convert to devm_ioremap_resource()

2013-03-11 Thread Silviu-Mihai Popescu
-Mihai Popescu --- drivers/watchdog/ath79_wdt.c |8 +++- drivers/watchdog/davinci_wdt.c |8 +++- drivers/watchdog/s3c2410_wdt.c |9 +++-- 3 files changed, 9 insertions(+), 16 deletions(-) diff --git a/drivers/watchdog/ath79_wdt.c b/drivers/watchdog/ath79_wdt.c index

[PATCH] kirkwood: fix coccicheck warnings

2013-03-11 Thread Silviu-Mihai Popescu
-Mihai Popescu --- drivers/cpufreq/kirkwood-cpufreq.c |8 +++- drivers/cpuidle/cpuidle-kirkwood.c |6 +++--- drivers/thermal/kirkwood_thermal.c |8 +++- 3 files changed, 9 insertions(+), 13 deletions(-) diff --git a/drivers/cpufreq/kirkwood-cpufreq.c b/drivers/cpufreq/kirkwood

[PATCH] matrox: fix coccicheck warning in matroxfb_base.c

2013-03-11 Thread Silviu-Mihai Popescu
This replaces a call to kmalloc() followed by memset() with just one call to kzalloc(). Signed-off-by: Silviu-Mihai Popescu --- drivers/video/matrox/matroxfb_base.c |3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/video/matrox/matroxfb_base.c b/drivers/video

[PATCH] aic7xxx: use kzalloc instead of kmalloc + memset

2013-03-10 Thread Silviu-Mihai Popescu
This replaces a call to kmalloc() followed by memset() with just one call to kzalloc(). This was found using make coccicheck. Signed-off-by: Silviu-Mihai Popescu --- drivers/scsi/aic7xxx/aic7xxx_core.c |9 +++-- 1 file changed, 3 insertions(+), 6 deletions(-) diff --git a/drivers/scsi

[PATCH v2] CAIF: fix indentation for function arguments

2013-03-06 Thread Silviu-Mihai Popescu
This lines up function arguments on second and subsequent lines at the first column after the openning parenthesis of the first line. Signed-off-by: Silviu-Mihai Popescu --- net/caif/caif_dev.c |9 + net/caif/caif_socket.c | 22 +++--- net/caif/caif_usb.c

[PATCH] CAIF: fix indentation for function arguments

2013-03-06 Thread Silviu-Mihai Popescu
This lines up function arguments on second and subsequent lines at the first column after the openning parenthesis of the first line. Signed-off-by: Silviu-Mihai Popescu --- net/caif/caif_dev.c |8 net/caif/caif_socket.c | 22 +++--- net/caif/caif_usb.c

[PATCH v3] CAIF: fix sparse warning for caif_usb

2013-03-03 Thread Silviu-Mihai Popescu
This fixes the following sparse warning: net/caif/caif_usb.c:84:16: warning: symbol 'cfusbl_create' was not declared. Should it be static? Signed-off-by: Silviu-Mihai Popescu --- net/caif/caif_usb.c |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/net/caif/ca

[PATCH v2] CAIF: fix sparse warning for caif_usb

2013-03-03 Thread Silviu-Mihai Popescu
This fixes the following sparse warning: net/caif/caif_usb.c:84:16: warning: symbol 'cfusbl_create' was not declared. Should it be static? Signed-off-by: Silviu-Mihai Popescu --- net/caif/caif_usb.c |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/net/caif/ca

[PATCH] CAIF: fix sparse warning for caif_usb

2013-03-03 Thread Silviu-Mihai Popescu
This fixes the following sparse warning: net/caif/caif_usb.c:84:16: warning: symbol 'cfusbl_create' was not declared. Should it be static? Signed-off-by: Silviu-Mihai Popescu --- net/caif/caif_usb.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/net/caif/caif_u

[PATCH] caif_dev: fix sparse warnings for caif_flow_cb

2013-03-02 Thread Silviu-Mihai Popescu
This fixed the following sparse warning: net/caif/caif_dev.c:121:6: warning: symbol 'caif_flow_cb' was not declared. Should it be static? Signed-off-by: Silviu-Mihai Popescu --- net/caif/caif_dev.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/net/caif/caif_d

[PATCH] sunrpc/auth_gss: fix sparse warnings for gss_mech_switch

2013-02-21 Thread Silviu-Mihai Popescu
27; was not declared. Should it be static? Signed-off-by: Silviu-Mihai Popescu --- net/sunrpc/auth_gss/gss_mech_switch.c |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/net/sunrpc/auth_gss/gss_mech_switch.c b/net/sunrpc/auth_gss/gss_mech_switch.c index b174fcd..f0f4

[PATCH] tcp_output: fix sparse warning for tcp_wfree

2012-08-04 Thread Silviu-Mihai Popescu
Fix sparse warning: * symbol 'tcp_wfree' was not declared. Should it be static? Signed-off-by: Silviu-Mihai Popescu --- net/ipv4/tcp_output.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/net/ipv4/tcp_output.c b/net/ipv4/tcp_output.c index 3f1bcf

[PATCH] mac802154: fix sparse warning for mac802154_slave_get_priv

2012-07-13 Thread Silviu-Mihai Popescu
Make sparse happy by fixing the following error: * symbol 'mac802154_slave_get_priv' was not declared. Should it be static? Signed-off-by: Silviu-Mihai Popescu --- net/mac802154/mib.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/net/mac802154/m