Re: [PATCH 1/2] remoteproc: mediatek: Make sure IPI buffer fits in L2TCM

2024-03-22 Thread Tzung-Bi Shih
ic. > > To fix that, check that the IPI buffer fits, otherwise return a > failure and refuse to boot the relevant SCP core (or the SCP at > all, if this is single core). > > Fixes: 3efa0ea743b7 ("remoteproc/mediatek: read IPI buffer offset from FW") > Signed-off-by: AngeloGioacchino Del Regno > Reviewed-by: Tzung-Bi Shih

Re: [PATCH RESEND v5 8/8] arm64: dts: mt6359: add PMIC MT6359 related nodes

2021-02-01 Thread Tzung-Bi Shih
On Sun, Jan 31, 2021 at 7:06 PM Matthias Brugger wrote: > On 29/01/2021 10:49, Hsin-Hsiung Wang wrote: > > + mt6359codec: mt6359codec { > > + }; > > I understand that the dmic-mode and mic-type-X depends on the actual board on > which it is used. In that case I think we

Re: [PATCH] ASoC: mediatek: add MTK_PMIC_WRAP dependency

2020-12-30 Thread Tzung-Bi Shih
mp;& SND_SOC [=y] && > MTK_PMIC_WRAP [=n] > Selected by [y]: > - SND_SOC_MT8192_MT6359_RT1015_RT5682 [=y] && SOUND [=y] && !UML && SND > [=y] && SND_SOC [=y] && I2C [=y] && SND_SOC_MT8192 [=y] > > Add a dependency to avoid that. > > Signed-off-by: Arnd Bergmann Acked-by: Tzung-Bi Shih

Re: [PATCH] ASoC: cros_ec_codec: fix uninitialized memory read

2020-12-04 Thread Tzung-Bi Shih
On Fri, Dec 4, 2020 at 4:28 PM Arnd Bergmann wrote: > > On Fri, Dec 4, 2020 at 3:56 AM Tzung-Bi Shih wrote: > > > > On Fri, Dec 4, 2020 at 6:55 AM Arnd Bergmann wrote: > > > > In the case in i2s_rx_event(), only the "cmd" member is used. But it &

Re: [PATCH] [v2] ASoC: cros_ec_codec: fix uninitialized memory read

2020-12-04 Thread Tzung-Bi Shih
On Fri, Dec 4, 2020 at 4:36 PM Arnd Bergmann wrote: > diff --git a/sound/soc/codecs/cros_ec_codec.c > b/sound/soc/codecs/cros_ec_codec.c > index 58894bf47514..6ec673573c70 100644 > --- a/sound/soc/codecs/cros_ec_codec.c > +++ b/sound/soc/codecs/cros_ec_codec.c > @@ -348,7 +348,7 @@ static int

Re: [PATCH] ASoC: cros_ec_codec: fix uninitialized memory read

2020-12-03 Thread Tzung-Bi Shih
ror: '*((void *)+4)' may be used > uninitialized in this function [-Werror=maybe-uninitialized] >83 | *((int *)to + 1) = *((int *)from + 1); > > Initialize all the unused fields to zero. > > Fixes: 727f1c71c780 ("ASoC: cros_ec_codec: refactor I2S RX") >

Re: [PATCH v4 2/2] ASoC: qcom: sc7180: Modify machine driver for 2mic

2020-11-02 Thread Tzung-Bi Shih
s") > > Signed-off-by: Ajye Huang LGTM. Reviewed-by: Tzung-Bi Shih

Re: [PATCH v3 2/2] ASoC: qcom: sc7180: Modify machine driver for 2mic

2020-11-02 Thread Tzung-Bi Shih
On Mon, Nov 2, 2020 at 2:24 PM Ajye Huang wrote: > > In addition, having mixer control to switch between DMICs by > using "dmic-gpios" property. > > Refer to this one as an example, > commit b7a742cff3f6 ("ASoC: AMD: Use mixer control to switch between DMICs") > > Signed-off-by: Ajye Huang I am

Re: [PATCH v2 2/2] ASoC: qcom: sc7180: Modify machine driver for 2mic

2020-10-30 Thread Tzung-Bi Shih
On Fri, Oct 30, 2020 at 6:55 PM Ajye Huang wrote: > But dmic_get() will need dmic_switch, should i keep dmic_switch? I see. I overlooked it. You can keep the dmic_switch for this purpose or just call gpiod_get_value_cansleep().

Re: [PATCH v2 2/2] ASoC: qcom: sc7180: Modify machine driver for 2mic

2020-10-30 Thread Tzung-Bi Shih
On Fri, Oct 30, 2020 at 3:57 PM Ajye Huang wrote: > +static struct gpio_desc *dmic_sel; > +static int dmic_switch; If you really need them, you should put them in struct sc7180_snd_data. > +static int dmic_set(struct snd_kcontrol *kcontrol, > + struct snd_ctl_elem_value

Re: [PATCH v11 2/3] ASoC: qcom: dt-bindings: Add sc7180 machine bindings

2020-10-21 Thread Tzung-Bi Shih
Hi, sorry for jumping into your discussion but I am trying to summarize them to make sure we are on the same page. Pardon me to manually copy-and-paste partial sentences to quote. ACK: - Don't expose DAI connections in compatible strings. - Use "model" DT property to make the card more

Re: [PATCH] remoteproc/mediatek: Add support for mt8192 SCP

2020-09-17 Thread Tzung-Bi Shih
emove them because these 2 macros are unused now. With that, Reviewed-by: Tzung-Bi Shih

Re: [PATCH v8 3/3] ASoC: qcom: sc7180: Add machine driver for sound card registration

2020-09-11 Thread Tzung-Bi Shih
On Thu, Sep 10, 2020 at 1:24 PM Cheng-Yi Chiang wrote: > +struct sc7180_snd_data { > + u32 pri_mi2s_clk_count; > + struct snd_soc_jack hs_jack; > + struct device_node *hs_jack_of_node; > + struct snd_soc_jack hdmi_jack; > + struct device_node *hdmi_jack_of_node; >

Re: [PATCH v8 1/3] ASoC: hdmi-codec: Use set_jack ops to set jack

2020-09-11 Thread Tzung-Bi Shih
> .use_pmdown_time= 1, > .endianness = 1, > .non_legacy_dai_naming = 1, > + .set_jack = hdmi_codec_set_jack_detect, "hdmi_codec_set_jack" looks better to me. If you would send a newer version, consider changing the name. With that: Reviewed-by: Tzung-Bi Shih

Re: [PATCH v5 2/2] dt-bindings: mediatek: mt6359: add codec document

2020-09-07 Thread Tzung-Bi Shih
On Thu, Aug 20, 2020 at 3:40 AM Mark Brown wrote: > > On Wed, Aug 19, 2020 at 11:42:27PM +0800, Tzung-Bi Shih wrote: > > > But I found struct mfd_cell also contains member .of_compatible. What > > is the difference if we use compatible string (as is) for this device > &

Re: [PATCH v5 2/2] dt-bindings: mediatek: mt6359: add codec document

2020-08-19 Thread Tzung-Bi Shih
On Wed, Aug 19, 2020 at 6:38 PM Mark Brown wrote: > > On Mon, Aug 17, 2020 at 04:11:03PM +0800, Tzung-Bi Shih wrote: > > I misunderstood. It still needs the compatible string to match the > > corresponding driver. > > No, it doesn't. The MFD should be registering the pla

Re: [PATCH v5 2/2] dt-bindings: mediatek: mt6359: add codec document

2020-08-17 Thread Tzung-Bi Shih
On Mon, Aug 17, 2020 at 3:29 PM Tzung-Bi Shih wrote: > > On Mon, Aug 17, 2020 at 2:08 PM Jiaxin Yu wrote: > > +properties: > > + compatible: > > +const: mediatek,mt6359-sound > > The compatible string has been removed since v3. > > > +required

Re: [PATCH v5 1/2] ASoC: mediatek: mt6359: add codec driver

2020-08-17 Thread Tzung-Bi Shih
On Mon, Aug 17, 2020 at 2:08 PM Jiaxin Yu wrote: > > Add the mt6359 codec driver. > > Signed-off-by: Jiaxin Yu Reviewed-by: Tzung-Bi Shih LGTM, thanks.

Re: [PATCH v5 2/2] dt-bindings: mediatek: mt6359: add codec document

2020-08-17 Thread Tzung-Bi Shih
On Mon, Aug 17, 2020 at 2:08 PM Jiaxin Yu wrote: > +properties: > + compatible: > +const: mediatek,mt6359-sound The compatible string has been removed since v3. > +required: > + - compatible The same here. > +examples: > + - | > +mt6359codec: mt6359codec { > + compatible =

Re: [PATCH v4 1/2] ASoC: mediatek: mt6359: add codec driver

2020-08-16 Thread Tzung-Bi Shih
On Sun, Aug 16, 2020 at 1:20 AM Jiaxin Yu wrote: > > +static int mt6359_platform_driver_probe(struct platform_device *pdev) [snip] > + > + return devm_snd_soc_register_component(>dev, > + _soc_component_driver, > +

Re: [PATCH v3 0/2] Add mediatek codec mt6359 driver

2020-08-14 Thread Tzung-Bi Shih
On Fri, Aug 14, 2020 at 6:47 PM Jiaxin Yu wrote: > Jiaxin Yu (2): > WIP: ASoC: mediatek: mt6359: add codec driver > WIP: dt-bindings: mediatek: mt6359: add codec document Please remove the "WIP: " prefixes and resend again.

Re: [PATCH v2 1/2] ASoC: mediatek: mt6359: add codec driver

2020-08-10 Thread Tzung-Bi Shih
On Mon, Aug 10, 2020 at 11:11 AM Jiaxin Yu wrote: > > Add the mt6359 codec driver. > > Signed-off-by: Jiaxin Yu Reviewed-by: Tzung-Bi Shih This patch also reviewed few rounds on https://crrev.com/c/2299951

Re: [PATCH v3 2/2] ASoC: qcom: sc7180: Add machine driver for sound card registration

2020-07-31 Thread Tzung-Bi Shih
jit Pandey > Signed-off-by: Cheng-Yi Chiang Reviewed-by: Tzung-Bi Shih LGTM.

Re: [PATCH v2 2/2] ASoC: qcom: sc7180: Add machine driver for sound card registration

2020-07-21 Thread Tzung-Bi Shih
On Tue, Jul 21, 2020 at 6:44 PM Cheng-Yi Chiang wrote: > diff --git a/sound/soc/qcom/sc7180.c b/sound/soc/qcom/sc7180.c > new file mode 100644 > index ..3beb2b129d01 > --- /dev/null > +++ b/sound/soc/qcom/sc7180.c > @@ -0,0 +1,380 @@ > +// SPDX-License-Identifier: GPL-2.0-only > +// >

Re: Speaker pops with max98357a on rk3399-gru-kevin since v5.7

2020-07-21 Thread Tzung-Bi Shih
On Tue, Jul 21, 2020 at 6:40 AM Alper Nebi Yasak wrote: > > On 17/07/2020 05:27, Tzung-Bi Shih wrote: > > I am not convinced the pop comes from 128f825aeab7. > > Maybe some pre-existing defect in rk3399_gru_sound got exposed by > 128f825aeab7 or the machine driver needs some

Re: [PATCH] platform_data: cros_ec_commands.h: drop a duplicated word

2020-07-19 Thread Tzung-Bi Shih
On Sun, Jul 19, 2020 at 8:30 AM Randy Dunlap wrote: > > Drop the repeated word "using" in a comment. > > Signed-off-by: Randy Dunlap > Cc: Tzung-Bi Shih > Cc: Mark Brown > --- I guess you didn't include the maintainers: Benson Leung (maintainer:CHROMEOS EC SUB

Re: [PATCH 2/2] ASoC: qcom: sc7180: Add machine driver for sound card registration

2020-07-19 Thread Tzung-Bi Shih
On Fri, Jul 17, 2020 at 8:02 PM Cheng-Yi Chiang wrote: > diff --git a/sound/soc/qcom/sc7180.c b/sound/soc/qcom/sc7180.c > new file mode 100644 > index ..cbe6b487d432 > --- /dev/null > +++ b/sound/soc/qcom/sc7180.c > @@ -0,0 +1,410 @@ > +// SPDX-License-Identifier: GPL-2.0-only > +/* >

Re: Speaker pops with max98357a on rk3399-gru-kevin since v5.7

2020-07-16 Thread Tzung-Bi Shih
On Thu, Jul 16, 2020 at 7:49 PM Alper Nebi Yasak wrote: > I have been getting "pop" sounds from the speaker on my rk3399-gru-kevin > for a while, and bisected it to 128f825aeab7 ("ASoC: max98357a: move > control of SD_MODE to DAPM"), but looks like the pops were somewhat > expected: I am not

Re: [PATCH v2] ASoC: cros_ec_codec: Log results when EC commands fail

2020-07-03 Thread Tzung-Bi Shih
On Fri, Jul 3, 2020 at 3:19 PM Yu-Hsuan Hsu wrote: > Log results of failed EC commands to identify a problem more easily. > > Replace cros_ec_cmd_xfer_status with cros_ec_cmd_xfer because the result > has already been checked in this function. The wrapper is not needed. Alternatively, you can

Re: [PATCH v2 0/2] ASoC: mediatek: mt6358: support DMIC one-wire mode

2020-06-05 Thread Tzung-Bi Shih
on https://crrev.com/c/2230086 > Documentation/devicetree/bindings/sound/mt6358.txt | 6 ++ > sound/soc/codecs/mt6358.c | 23 > +- > 2 files changed, 28 insertions(+), 1 deletion(-) With that: Reviewed-by: Tzung-Bi Shih

Re: [PATCH] ASoC: mediatek: mt6358: support DMIC one-wire mode

2020-05-29 Thread Tzung-Bi Shih
On Fri, May 29, 2020 at 9:05 PM Mark Brown wrote: > > On Fri, May 29, 2020 at 07:22:43PM +0800, Tzung-Bi Shih wrote: > > On Fri, May 29, 2020 at 7:09 PM Mark Brown wrote: > > > > What is DMIC one wire mode? This doesn't sound like something I'd > > > expect to v

Re: [PATCH] ASoC: mediatek: mt6358: support DMIC one-wire mode

2020-05-29 Thread Tzung-Bi Shih
On Fri, May 29, 2020 at 7:09 PM Mark Brown wrote: > > On Fri, May 29, 2020 at 07:04:53PM +0800, Jiaxin Yu wrote: > > Supports DMIC one-wire mode. Adds a mixer control to enable and disable. > > What is DMIC one wire mode? This doesn't sound like something I'd > expect to vary at runtime. It

Re: [V3 PATCH 2/2] ASoC: max98390: Added Amplifier Driver

2020-05-14 Thread Tzung-Bi Shih
On Wed, May 13, 2020 at 3:47 PM Steve Lee wrote: > +++ b/sound/soc/codecs/max98390.c > @@ -0,0 +1,1030 @@ > +// SPDX-License-Identifier: GPL-2.0-or-later > +/* > + * max98390.c -- MAX98390 ALSA Soc Audio driver > + * > + * Copyright (C) 2020 Maxim Integrated Products > + * > + */ My previous

Re: [V3 PATCH 2/2] ASoC: max98390: Added Amplifier Driver

2020-05-13 Thread Tzung-Bi Shih
On Wed, May 13, 2020 at 6:53 PM Mark Brown wrote: > > On Wed, May 13, 2020 at 04:45:23PM +0900, Steve Lee wrote: > > > Changes since V2: > > * Removed warn massage in max98390_dsm_calib_get func > > and add comment. > > The problem isn't the warning, the problem is that you have an

Re: [PATCH 2/2] ASoC: max98390: Added Amplifier Driver

2020-05-11 Thread Tzung-Bi Shih
(The patch passed 2 round review in https://crrev.com/c/2083354) On Sun, May 10, 2020 at 4:23 PM Steve Lee wrote: > +static int max98390_dai_set_fmt(struct snd_soc_dai *codec_dai, unsigned int > fmt) > +{ > + struct snd_soc_component *component = codec_dai->component; > + struct

Re: [PATCH] ASoC: cros_ec_codec: allocate shash_desc dynamically

2020-05-08 Thread Tzung-Bi Shih
On Fri, May 8, 2020 at 5:34 AM Arnd Bergmann wrote: > Fixes: b6bc07d4360d ("ASoC: cros_ec_codec: support WoV") > Signed-off-by: Arnd Bergmann Reviewed-by: Tzung-Bi Shih LGTM. Thanks for the fix.

Re: [PATCH] ASoC: mediatek: Check SND_SOC_CROS_EC_CODEC dependency

2019-10-23 Thread Tzung-Bi Shih
On Wed, Oct 23, 2019 at 4:38 PM maowenan wrote: > I receive below message after I post, do you know why? > ''' > Your mail to 'Alsa-devel' with the subject > > [PATCH] ASoC: mediatek: Check SND_SOC_CROS_EC_CODEC dependency > > Is being held until the list moderator can review it for approval.

Re: [PATCH] ASoC: mediatek: Check SND_SOC_CROS_EC_CODEC dependency

2019-10-23 Thread Tzung-Bi Shih
On Wed, Oct 23, 2019 at 2:31 PM Mao Wenan wrote: > > If SND_SOC_MT8183_MT6358_TS3A227E_MAX98357A=y, > below errors can be seen: > sound/soc/codecs/cros_ec_codec.o: In function `send_ec_host_command': > cros_ec_codec.c:(.text+0x534): undefined reference to > `cros_ec_cmd_xfer_status' >

Re: [PATCH] ASoC: mediatek: Check SND_SOC_CROS_EC_CODEC dependency

2019-10-23 Thread Tzung-Bi Shih
t; > Fixes: 2cc3cd5fdc8b ("ASoC: mediatek: mt8183: support WoV") > Signed-off-by: Mao Wenan Acked-by: Tzung-Bi Shih Thanks for the catching.

Re: [PATCH] firmware: vpd: Add an interface to read VPD value

2019-10-07 Thread Tzung-Bi Shih
On Mon, Oct 7, 2019 at 3:16 PM Cheng-Yi Chiang wrote: > > Add an interface for other driver to query VPD value. > This will be used for ASoC machine driver to query calibration > data stored in VPD for smart amplifier speaker resistor > calibration. > > Signed-off-by: Cheng-Yi Chiang > --- >

Re: [PATCH v4] platform/chrome: cros_ec_trace: update generating script

2019-08-01 Thread Tzung-Bi Shih
On Thu, Aug 1, 2019 at 6:59 PM Enric Balletbo i Serra wrote: > > Hi Tzung-Bi > > On 30/7/19 16:07, Tzung-Bi Shih wrote: > > Hi Enric, > > > > I found it is error-prone to replace the EC_CMDS after updated. > > Perhaps, we should introduce an intermediat

Re: [PATCH v4] platform/chrome: cros_ec_trace: update generating script

2019-07-30 Thread Tzung-Bi Shih
Hi Enric, I found it is error-prone to replace the EC_CMDS after updated. Perhaps, we should introduce an intermediate file "cros_ec_trace.inc". The generating script replaces whole ".inc" file every time and the cros_ec_trace.c includes the "cros_ec_trace.inc". If this proposal makes sense to

[PATCH v4] platform/chrome: cros_ec_trace: update generating script

2019-07-30 Thread Tzung-Bi Shih
The original script generates unneeded ", \" on the last line which results in compile error if one would forget to remove them. Update the script to not generate ", \" on the last line. Also add a define guard for EC_CMDS. Signed-off-by: Tzung-Bi Shih --- Changes from v1

[PATCH v3] platform/chrome: cros_ec_trace: update generating script

2019-07-29 Thread Tzung-Bi Shih
To remove ", \" from the last line. Signed-off-by: Tzung-Bi Shih --- Changes from v1: - simpler awk code Changes from v2: - use c style comments instead of c++ style - use '@' delimiter in sed instead of '/' to avoid unintentional end of comment "*/" drivers/platform/ch

[PATCH v2] platform/chrome: cros_ec_trace: update generating script

2019-07-23 Thread Tzung-Bi Shih
To remove ", \" from the last line. Signed-off-by: Tzung-Bi Shih --- Changes from v1: - simpler awk code drivers/platform/chrome/cros_ec_trace.c | 13 - 1 file changed, 12 insertions(+), 1 deletion(-) diff --git a/drivers/platform/chrome/cros_ec_trace.c b/drivers/platf

[PATCH] platform/chrome: cros_ec_trace: update generating script

2019-07-23 Thread Tzung-Bi Shih
To remove ", \" from the last line. Signed-off-by: Tzung-Bi Shih --- drivers/platform/chrome/cros_ec_trace.c | 18 +- 1 file changed, 17 insertions(+), 1 deletion(-) diff --git a/drivers/platform/chrome/cros_ec_trace.c b/drivers/platform/chrome/cros_ec_tra

Re: [PATCH] ASoC: codecs: ad193x: Use regmap_multi_reg_write() when initializing

2019-07-10 Thread Tzung-Bi Shih
On Wed, Jul 10, 2019 at 6:51 PM Codrin Ciubotariu wrote: > > Using regmap_multi_reg_write() when we set the default values for our > registers makes the code smaller and easier to read. > > Suggested-by: Tzung-Bi Shih > Signed-off-by: Codrin Ciubotariu Reviewed-by: Tzung-Bi Shih LGTM. Thanks.

Re: linux-next: Fixes tag needs some work in the sound-asoc tree

2019-07-10 Thread Tzung-Bi Shih
On Thu, Jul 11, 2019 at 12:13 AM Stephen Rothwell wrote: > In commit > > 6cd249cfad68 ("ASoC: max98357a: use mdelay for sdmode-delay") > > Fixes tag > > Fixes: cec5b01f8f1c ("ASoC: max98357a: avoid speaker pop when playback > > has these problem(s): > > - Subject has leading but no trailing

Re: [PATCH] sound: soc: codecs: mt6358: change return type of mt6358_codec_init_reg

2019-07-09 Thread Tzung-Bi Shih
quot;0" > on line 2289 > > Signed-off-by: Hariprasad Kelam Acked-by: Tzung-Bi Shih Thanks for cleaning this up.

Re: [alsa-devel] [PATCH 1/2] ASoC: codecs: ad193x: Group register initialization at probe

2019-07-03 Thread Tzung-Bi Shih
On Thu, Jun 27, 2019 at 8:05 PM Codrin Ciubotariu wrote: > +struct ad193x_reg_default { > + unsigned int reg; > + unsigned int val; > +}; You probably don't need to define this. There is a struct reg_sequence in regmap.h. > + > +/* codec register values to set after reset */ >

Re: [BISECT] No audio after "ASoC: core: use component driver name as component name"

2019-05-31 Thread Tzung-Bi Shih
On Fri, May 31, 2019 at 5:27 PM Krzysztof Kozlowski wrote: > The problem might be in component name. The driver->name and > fmt_single_name(dev, >id) are: > snd_dmaengine_pcm != 383.i2s > snd_dmaengine_pcm != 383.i2s-sec > samsung-i2s != 383.i2s > > This commit should not go in