Re: [PATCH 1/2] drm/amdgpu/debugfs: fix memory leak when pm_runtime_get_sync failed

2020-06-16 Thread chentao (AS)
Ok, i will modify it in v2 patch. On 2020/6/16 14:50, Christian König wrote: Probably better to remove the duplication of result and r here and then use "goto err".

[PATCH -next] scsi: ufs-mediatek: Make ufs_mtk_fixup_dev_quirks static

2020-05-13 Thread ChenTao
Fix the following warning: drivers/scsi/ufs/ufs-mediatek.c:585:6: warning: symbol 'ufs_mtk_fixup_dev_quirks' was not declared. Should it be static? Reported-by: Hulk Robot Signed-off-by: ChenTao --- drivers/scsi/ufs/ufs-mediatek.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff

[PATCH -next] sfc: Make siena_check_caps static

2020-05-13 Thread ChenTao
Fix the following warning: drivers/net/ethernet/sfc/siena.c:951:14: warning: symbol 'siena_check_caps' was not declared. Should it be static? Reported-by: Hulk Robot Signed-off-by: ChenTao --- drivers/net/ethernet/sfc/siena.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff

[PATCH -next v2] rtl8187: Remove unused variable rtl8225z2_tx_power_ofdm

2020-05-12 Thread ChenTao
Fix the following warning: drivers/net/wireless/realtek/rtl818x/rtl8187/rtl8225.c:609:17: warning: ‘rtl8225z2_tx_power_ofdm’ defined but not used static const u8 rtl8225z2_tx_power_ofdm[] = { Acked-by: Hin-Tak Leung Acked-by: Larry Finger Reported-by: Hulk Robot Signed-off-by: ChenTao

[PATCH -next v2] rtl8187: Remove unused variable rtl8225z2_tx_power_ofdm

2020-05-12 Thread ChenTao
Fix the following warning: drivers/net/wireless/realtek/rtl818x/rtl8187/rtl8225.c:609:17: warning: ‘rtl8225z2_tx_power_ofdm’ defined but not used static const u8 rtl8225z2_tx_power_ofdm[] = { Acked-by: Hin-Tak Leung Acked-by: Larry Finger Reported-by: Hulk Robot Signed-off-by: ChenTao

Re: [PATCH -next] net/wireless/rtl8225: Remove unused variable rtl8225z2_tx_power_ofdm

2020-05-12 Thread chentao (AS)
Thanks, i will change it in v2. On 2020/5/12 23:24, Larry Finger wrote: On 5/12/20 6:14 AM, ChenTao wrote: Fix the following warning: drivers/net/wireless/realtek/rtl818x/rtl8187/rtl8225.c:609:17: warning: ‘rtl8225z2_tx_power_ofdm’ defined but not used   static const u8

[PATCH -next] net/wireless/rtl8225: Remove unused variable rtl8225z2_tx_power_ofdm

2020-05-12 Thread ChenTao
Fix the following warning: drivers/net/wireless/realtek/rtl818x/rtl8187/rtl8225.c:609:17: warning: ‘rtl8225z2_tx_power_ofdm’ defined but not used static const u8 rtl8225z2_tx_power_ofdm[] = { Reported-by: Hulk Robot Signed-off-by: ChenTao --- drivers/net/wireless/realtek/rtl818x/rtl8187

[PATCH -next] drm/amd/dc: Remove a useless comparison

2020-05-07 Thread ChenTao
u/drm/amd/amdgpu/../display/dc/gpio/hw_generic.c:109:10: warning: comparison of unsigned expression < 0 is always false [-Wtype-limits] if ((en < GPIO_DDC_LINE_MIN) || (en > GPIO_DDC_LINE_MAX)) { Reported-by: Hulk Robot Signed-off-by: ChenTao --- drivers/gpu/drm/amd/display/dc/gpi

[PATCH] input/misc/drv260x: Remove a useless comparison

2020-05-06 Thread ChenTao
ics->mode < DRV260X_LRA_MODE || drivers/input/misc/drv260x.c:490:23: warning: comparison of unsigned expression < 0 is always false [-Wtype-limits] if (haptics->library < DRV260X_LIB_EMPTY || Reported-by: Hulk Robot Signed-off-by: ChenTao --- drivers/input/misc/drv260x.c | 6 ++--

[PATCH -next] soc: fsl_asrc: Make some functions static

2020-05-06 Thread ChenTao
Fix the following warning: sound/soc/fsl/fsl_asrc.c:157:5: warning: symbol 'fsl_asrc_request_pair' was not declared. Should it be static? sound/soc/fsl/fsl_asrc.c:200:6: warning: symbol 'fsl_asrc_release_pair' was not declared. Should it be static? Reported-by: Hulk Robot Signed-off-by: ChenTao

[PATCH -next] power/supply/cw2015: Make some symbols static

2020-05-06 Thread ChenTao
Fix the following warning: drivers/power/supply/cw2015_battery.c:96:5: warning: 'cw_update_profile' was not declared. Should it be static? drivers/power/supply/cw2015_battery.c:712:1: warning: 'cw_bat_pm_ops' was not declared. Should it be static? Reported-by: Hulk Robot Signed-off-by: ChenTao

[PATCH -next] net: enetc: Make some symbols static

2020-05-06 Thread ChenTao
? Reported-by: Hulk Robot Signed-off-by: ChenTao --- drivers/net/ethernet/freescale/enetc/enetc_qos.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/drivers/net/ethernet/freescale/enetc/enetc_qos.c b/drivers/net/ethernet/freescale/enetc/enetc_qos.c index 48e589e9d0f7

[PATCH -next] input/keyboard/qt1050: fix unsigned comparison with 0

2020-05-06 Thread ChenTao
Fixes warning because num is u32 and can never be negtative drivers/input/keyboard/qt1050.c:371:18: warning: comparison of unsigned expression < 0 is always false [-Wtype-limits] if (button.num < 0 || button.num > QT1050_MAX_KEYS - 1) Reported-by: Hulk Robot Signed-off-by

[PATCH -next] drm/amdgpu/navi10: fix unsigned comparison with 0

2020-05-05 Thread ChenTao
Fixes warning because size is uint32_t and can never be negtative drivers/gpu/drm/amd/amdgpu/../powerplay/navi10_ppt.c:1296:12: warning: comparison of unsigned expression < 0 is always false [-Wtype-limits] if (size < 0) Reported-by: Hulk Robot Signed-off-by: ChenTao --- drivers/g

[PATCH -next] drm/radeon: fix unsigned comparison with 0

2020-05-04 Thread ChenTao
:11: warning: comparison of unsigned expression < 0 is always false [-Wtype-limits] if (pipe < 0 || pipe >= rdev->num_crtc) { Reported-by: Hulk Robot Signed-off-by: ChenTao --- drivers/gpu/drm/radeon/radeon_kms.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

Re: [PATCH 1/1] interconnect: qcom: Move the static keyword to the front of declaration

2020-04-29 Thread chentao (AS)
Thank you for your review and modification! On 2020/4/29 18:19, Georgi Djakov wrote: From: ChenTao Fix the following warning: Move the static keyword to the front of declaration of sdm845_icc_osm_l3 sdm845_aggre1_noc sc7180_icc_osm_l3 sdm845_aggre2_noc sdm845_config_noc sdm845_dc_noc

[PATCH v2] soc: imx8m: Make imx8m_dsp_ops static

2020-04-28 Thread ChenTao
Fix the following warning: sound/soc/sof/imx/imx8m.c:95:20: warning: symbol 'imx8m_dsp_ops' was not declared. Should it be static? Reported-by: Hulk Robot Signed-off-by: ChenTao Acked-by: Kai Vehmanen Reviewed-by: Daniel Baluta --- v1->v2: - add recipient broo...@kernel.org alsa-de...@a

Re: [PATCH] soc: imx8m: Make imx8m_dsp_ops static

2020-04-28 Thread chentao (AS)
Thanks a lot, i will resend v2 and add  Mark Brown broo...@kernel.org  alsa-de...@alsa-project.org On 2020/4/29 0:42, Daniel Baluta wrote: On Sat, Apr 25, 2020 at 11:03 AM ChenTao wrote: Fix the following warning: sound/soc/sof/imx/imx8m.c:95:20: warning: symbol 'imx8m_dsp_ops

Re: [PATCH v2] xen-blkback: define pr_fmt macro to avoid the duplication of DRV_PFX

2015-04-01 Thread Chentao (Boby)
On 2015/4/1 23:04, Tao Chen wrote: Define pr_fmt macro with {xen-blkback: } prefix, then remove all use of DRV_PFX in the pr sentences. Replace all DPRINTK with pr sentences, and get rid of DPRINTK macro. It will simplify the code. And if the pr sentences miss a \n, add it in the end. If the

Re: [PATCH] xen-blkback: define pr_fmt macro to avoid the duplication of DRV_PFX

2015-04-01 Thread Chentao (Boby)
Thanks roger and joe. I will adopt your suggestions in my v2 patch. On 2015/3/31 22:57, Roger Pau Monné wrote: El 31/03/15 a les 23.14, Tao Chen ha escrit: Define pr_fmt macro with {xen-blkback: } prefix, then remove all use of DRV_PFX in the pr and DPRINTK sentences. It will simplify the

Re: [PATCH] xen-blkback: define pr_fmt macro to avoid the duplication of DRV_PFX

2015-04-01 Thread Chentao (Boby)
Thanks roger and joe. I will adopt your suggestions in my v2 patch. On 2015/3/31 22:57, Roger Pau Monné wrote: El 31/03/15 a les 23.14, Tao Chen ha escrit: Define pr_fmt macro with {xen-blkback: } prefix, then remove all use of DRV_PFX in the pr and DPRINTK sentences. It will simplify the

Re: [PATCH v2] xen-blkback: define pr_fmt macro to avoid the duplication of DRV_PFX

2015-04-01 Thread Chentao (Boby)
On 2015/4/1 23:04, Tao Chen wrote: Define pr_fmt macro with {xen-blkback: } prefix, then remove all use of DRV_PFX in the pr sentences. Replace all DPRINTK with pr sentences, and get rid of DPRINTK macro. It will simplify the code. And if the pr sentences miss a \n, add it in the end. If the

Re: [PATCH] xen-blkback: enlarge the array size of blkback name

2015-03-26 Thread Chentao (Boby)
You are right, roger. Thanks. domid is a u16, it will occupy 5 characters at most. So the biggest length of blkback name is 8+5+5=18. At this situation, define BLKBACK_NAME_LEN macro to be 20 is safe. On 2015/3/26 19:23, Roger Pau Monné wrote: El 13/03/15 a les 16.52, Tao Chen ha escrit:

Re: [PATCH] xen-blkback: enlarge the array size of blkback name

2015-03-26 Thread Chentao (Boby)
You are right, roger. Thanks. domid is a u16, it will occupy 5 characters at most. So the biggest length of blkback name is 8+5+5=18. At this situation, define BLKBACK_NAME_LEN macro to be 20 is safe. On 2015/3/26 19:23, Roger Pau Monné wrote: El 13/03/15 a les 16.52, Tao Chen ha escrit:

Re: [PATCH v2] xen-scsiback: use DRV_PFX in the pr macros and DPRINTK

2015-03-09 Thread Chentao (Boby)
On 2015/3/6 20:50, Joe Perches wrote: On Fri, 2015-03-06 at 17:33 +0800, Chentao (Boby) wrote: #ifdef pr_fmt #undef pr_fmt #endif #define pr_fmt(fmt) "xen-pvscsi: " fmt No, just use add #define pr_fmt(fmt) "xen-pvscsi: " fmt before the first #include. The #ifdef

Re: [PATCH v3] xen-scsiback: define a pr_fmt macro with xen-pvscsi

2015-03-09 Thread Chentao (Boby)
On 2015/3/6 20:53, Juergen Gross wrote: On 03/06/2015 09:34 PM, Tao Chen wrote: Add the {xen-pvscsi: } prefix in pr_fmt and remove DPRINTK, then replace all DPRINTK with pr_debug. Also fixed up some comments just as eliminate redundant whitespace and format the code. These will make the

Re: [PATCH v3] xen-scsiback: define a pr_fmt macro with xen-pvscsi

2015-03-09 Thread Chentao (Boby)
On 2015/3/6 20:53, Juergen Gross wrote: On 03/06/2015 09:34 PM, Tao Chen wrote: Add the {xen-pvscsi: } prefix in pr_fmt and remove DPRINTK, then replace all DPRINTK with pr_debug. Also fixed up some comments just as eliminate redundant whitespace and format the code. These will make the

Re: [PATCH v2] xen-scsiback: use DRV_PFX in the pr macros and DPRINTK

2015-03-09 Thread Chentao (Boby)
On 2015/3/6 20:50, Joe Perches wrote: On Fri, 2015-03-06 at 17:33 +0800, Chentao (Boby) wrote: #ifdef pr_fmt #undef pr_fmt #endif #define pr_fmt(fmt) xen-pvscsi: fmt No, just use add #define pr_fmt(fmt) xen-pvscsi: fmt before the first #include. The #ifdef/#undef/#endif isn't necessary

Re: [PATCH v2] xen-scsiback: use DRV_PFX in the pr macros and DPRINTK

2015-03-06 Thread Chentao (Boby)
On 2015/3/4 18:34, David Vrabel wrote: On 04/03/15 18:32, Tao Chen wrote: Defined the string of {xen-pvscsi: } as DRV_PFX, then use it in the pr sentences and DPRINTK. Also fixed up some comments just as eliminate redundant white spaces and format the code. These will make the code easier to

Re: [PATCH v2] xen-scsiback: use DRV_PFX in the pr macros and DPRINTK

2015-03-06 Thread Chentao (Boby)
On 2015/3/5 0:32, Joe Perches wrote: On Wed, 2015-03-04 at 18:32 +, Tao Chen wrote: Defined the string of {xen-pvscsi: } as DRV_PFX, then use it in the pr sentences and DPRINTK. Also fixed up some comments just as eliminate redundant white spaces and format the code. These will make the

Re: [PATCH v2] xen-scsiback: use DRV_PFX in the pr macros and DPRINTK

2015-03-06 Thread Chentao (Boby)
On 2015/3/5 0:32, Joe Perches wrote: On Wed, 2015-03-04 at 18:32 +, Tao Chen wrote: Defined the string of {xen-pvscsi: } as DRV_PFX, then use it in the pr sentences and DPRINTK. Also fixed up some comments just as eliminate redundant white spaces and format the code. These will make the

Re: [PATCH v2] xen-scsiback: use DRV_PFX in the pr macros and DPRINTK

2015-03-06 Thread Chentao (Boby)
On 2015/3/4 18:34, David Vrabel wrote: On 04/03/15 18:32, Tao Chen wrote: Defined the string of {xen-pvscsi: } as DRV_PFX, then use it in the pr sentences and DPRINTK. Also fixed up some comments just as eliminate redundant white spaces and format the code. These will make the code easier to

Re: [PATCH] xen-scsiback: use DRV_PFX in the pr macros

2015-03-04 Thread Chentao (Boby)
Hi, Juergen. Thanks for your advice. I will send a v2 patch based on your suggested modifications. On 2015/3/3 17:52, Juergen Gross wrote: On 03/03/2015 09:37 AM, Tao Chen wrote: Replace the string of {xen-pvscsi:} in the pr sentences with DRV_PFX, it makes the code easier to read. I'm

Re: [PATCH] xen-scsiback: use DRV_PFX in the pr macros

2015-03-04 Thread Chentao (Boby)
Hi, Juergen. Thanks for your advice. I will send a v2 patch based on your suggested modifications. On 2015/3/3 17:52, Juergen Gross wrote: On 03/03/2015 09:37 AM, Tao Chen wrote: Replace the string of {xen-pvscsi:} in the pr sentences with DRV_PFX, it makes the code easier to read. I'm