Re: [PATCH] ALSA: riptide: Use DIV_ROUND_UP

2016-06-29 Thread Takashi Iwai
On Wed, 29 Jun 2016 16:56:28 +0200, Amitoj Kaur Chawla wrote: > > The kernel.h macro DIV_ROUND_UP performs the computation > (((n) + (d) - 1) /(d)) but is perhaps more readable. > > The Coccinelle script used to make this change is as follows: > @haskernel@ > @@ > > #include > > @depends on ha

Re: [PATCH] ALSA: riptide: Use DIV_ROUND_UP

2016-06-29 Thread Takashi Sakamoto
On Jun 29 2016 23:56, Amitoj Kaur Chawla wrote: The kernel.h macro DIV_ROUND_UP performs the computation (((n) + (d) - 1) /(d)) but is perhaps more readable. The Coccinelle script used to make this change is as follows: @haskernel@ @@ #include @depends on haskernel@ expression n,d; @@ ( - (n

[PATCH] ALSA: riptide: Use DIV_ROUND_UP

2016-06-29 Thread Amitoj Kaur Chawla
The kernel.h macro DIV_ROUND_UP performs the computation (((n) + (d) - 1) /(d)) but is perhaps more readable. The Coccinelle script used to make this change is as follows: @haskernel@ @@ #include @depends on haskernel@ expression n,d; @@ ( - (n + d - 1) / d + DIV_ROUND_UP(n,d) | - (n + (d - 1)