Re: [PATCH] do_fork(): Rename 'stack_size' argument to reflect actual use

2015-03-05 Thread Alex Dowad
On 05/03/15 22:29, David Rientjes wrote: On Thu, 5 Mar 2015, Alex Dowad wrote: diff --git a/kernel/fork.c b/kernel/fork.c index cf65139..b38a2ae 100644 --- a/kernel/fork.c +++ b/kernel/fork.c @@ -1186,10 +1186,12 @@ init_task_pid(struct task_struct *task, enum pid_type type, struct pid *pid)

Re: [PATCH] do_fork(): Rename 'stack_size' argument to reflect actual use

2015-03-05 Thread David Rientjes
On Thu, 5 Mar 2015, Alex Dowad wrote: > > > diff --git a/kernel/fork.c b/kernel/fork.c > > > index cf65139..b38a2ae 100644 > > > --- a/kernel/fork.c > > > +++ b/kernel/fork.c > > > @@ -1186,10 +1186,12 @@ init_task_pid(struct task_struct *task, enum > > > pid_type type, struct pid *pid) > > >*

Re: [PATCH] do_fork(): Rename 'stack_size' argument to reflect actual use

2015-03-05 Thread Alex Dowad
On 05/03/15 01:07, David Rientjes wrote: On Wed, 4 Mar 2015, Alex Dowad wrote: The 'stack_size' argument is never used to pass a stack size. It's only used when forking a kernel thread, in which case it is an argument which should be passed to the 'main' function which the kernel thread execu

Re: [PATCH] do_fork(): Rename 'stack_size' argument to reflect actual use

2015-03-04 Thread David Rientjes
On Wed, 4 Mar 2015, Alex Dowad wrote: > The 'stack_size' argument is never used to pass a stack size. It's only used > when > forking a kernel thread, in which case it is an argument which should be > passed > to the 'main' function which the kernel thread executes. Hence, rename it to > 'kthrea

Re: [PATCH] do_fork(): Rename 'stack_size' argument to reflect actual use

2015-03-04 Thread Kees Cook
On Wed, Mar 4, 2015 at 4:40 AM, Alex Dowad wrote: > The 'stack_size' argument is never used to pass a stack size. It's only used > when > forking a kernel thread, in which case it is an argument which should be > passed > to the 'main' function which the kernel thread executes. Hence, rename it

[PATCH] do_fork(): Rename 'stack_size' argument to reflect actual use

2015-03-04 Thread Alex Dowad
The 'stack_size' argument is never used to pass a stack size. It's only used when forking a kernel thread, in which case it is an argument which should be passed to the 'main' function which the kernel thread executes. Hence, rename it to 'kthread_arg'. Signed-off-by: Alex Dowad --- Hi, Please