Re: [PATCH] kernfs: move the last knowledge of sysfs out from kernfs

2014-04-26 Thread Jianyu Zhan
Hi, Greg, >This doesn't apply to my tree, can you please redo it against >the driver-core-next branch and resend? I've reworked it on top of driver-core-next. Thanks! --<8-- There is still one residue of sysfs remaining: the sb_magic SYSFS_MAGIC. However this should be kernfs user spec

Re: [PATCH] kernfs: move the last knowledge of sysfs out from kernfs

2014-04-25 Thread Greg KH
On Thu, Apr 17, 2014 at 01:24:18AM +0800, Jianyu Zhan wrote: > There is still one residue of sysfs remaining: the sb_magic > SYSFS_MAGIC. However this should be kernfs user specific, > so this patch moves it out. Kerrnfs user should specify their > magic number while mouting. > > Signed-off-by: Ji

Re: [PATCH] kernfs: move the last knowledge of sysfs out from kernfs

2014-04-16 Thread Tejun Heo
On Thu, Apr 17, 2014 at 01:24:18AM +0800, Jianyu Zhan wrote: > On Thu, Apr 17, 2014 at 12:46 AM, Tejun Heo wrote: > > Please put it before @new_sb_created. > > Ok. > > > Also, why isn't it unsigned long magic? > > I just thought there may be more private data in the future, so I made > it a voi

Re: [PATCH] kernfs: move the last knowledge of sysfs out from kernfs

2014-04-16 Thread Jianyu Zhan
On Thu, Apr 17, 2014 at 12:46 AM, Tejun Heo wrote: > Please put it before @new_sb_created. Ok. > Also, why isn't it unsigned long magic? I just thought there may be more private data in the future, so I made it a void pointer. But now I think this is overskill and meaningless. Renewed patch he

Re: [PATCH] kernfs: move the last knowledge of sysfs out from kernfs

2014-04-16 Thread Tejun Heo
Hello, On Thu, Apr 17, 2014 at 12:40:01AM +0800, Jianyu Zhan wrote: > @@ -132,6 +132,7 @@ const void *kernfs_super_ns(struct super_block *sb) > * @flags: mount flags specified for the mount > * @root: kernfs_root of the hierarchy being mounted > * @new_sb_created: tell the caller if we alloc

[PATCH] kernfs: move the last knowledge of sysfs out from kernfs

2014-04-16 Thread Jianyu Zhan
There is still one residue of sysfs remaining: the sb_magic SYSFS_MAGIC. However this should be kernfs user specific, so this patch moves it out. Kerrnfs user should specify their magic number while mouting. Signed-off-by: Jianyu Zhan --- fs/kernfs/mount.c | 9 + fs/sysfs/mount.c