Re: [PATCH] mach_omap2: use PTR_RET instead of IS_ERR + PTR_ERR

2013-03-22 Thread Jon Hunter
On 03/22/2013 11:36 AM, Russell King - ARM Linux wrote: > On Wed, Mar 20, 2013 at 01:28:47PM -0500, Jon Hunter wrote: >> Sorry I am now not sure I follow you here. Someone just pointed out to >> me that PTR_RET() is defined as ... >> >> static inline int __must_check PTR_RET(const void *ptr) >> {

Re: [PATCH] mach_omap2: use PTR_RET instead of IS_ERR + PTR_ERR

2013-03-22 Thread Russell King - ARM Linux
On Wed, Mar 20, 2013 at 01:28:47PM -0500, Jon Hunter wrote: > Sorry I am now not sure I follow you here. Someone just pointed out to > me that PTR_RET() is defined as ... > > static inline int __must_check PTR_RET(const void *ptr) > { > if (IS_ERR(ptr)) > return PTR_ERR(ptr); >

Re: [PATCH] mach_omap2: use PTR_RET instead of IS_ERR + PTR_ERR

2013-03-21 Thread Silviu Popescu
On Wed, Mar 20, 2013 at 8:28 PM, Jon Hunter wrote: > > On 03/12/2013 06:05 AM, Russell King - ARM Linux wrote: >> On Tue, Mar 12, 2013 at 09:58:29AM +0200, Silviu-Mihai Popescu wrote: >>> This uses PTR_RET instead of IS_ERR and PTR_ERR in order to increase >>> readability. >>> >>> Signed-off-by: S

Re: [PATCH] mach_omap2: use PTR_RET instead of IS_ERR + PTR_ERR

2013-03-20 Thread Jon Hunter
On 03/12/2013 06:05 AM, Russell King - ARM Linux wrote: > On Tue, Mar 12, 2013 at 09:58:29AM +0200, Silviu-Mihai Popescu wrote: >> This uses PTR_RET instead of IS_ERR and PTR_ERR in order to increase >> readability. >> >> Signed-off-by: Silviu-Mihai Popescu >> --- >> arch/arm/mach-omap2/devices.

Re: [PATCH] mach_omap2: use PTR_RET instead of IS_ERR + PTR_ERR

2013-03-12 Thread Russell King - ARM Linux
On Tue, Mar 12, 2013 at 09:58:29AM +0200, Silviu-Mihai Popescu wrote: > This uses PTR_RET instead of IS_ERR and PTR_ERR in order to increase > readability. > > Signed-off-by: Silviu-Mihai Popescu > --- > arch/arm/mach-omap2/devices.c |4 ++-- > arch/arm/mach-omap2/fb.c |5 + > a

[PATCH] mach_omap2: use PTR_RET instead of IS_ERR + PTR_ERR

2013-03-12 Thread Silviu-Mihai Popescu
This uses PTR_RET instead of IS_ERR and PTR_ERR in order to increase readability. Signed-off-by: Silviu-Mihai Popescu --- arch/arm/mach-omap2/devices.c |4 ++-- arch/arm/mach-omap2/fb.c |5 + arch/arm/mach-omap2/gpmc.c|2 +- arch/arm/mach-omap2/pmu.c |5 + 4