[PATCH] perf/x86/uncore: Remove unnecessary assignment to "box" in uncore_pci_remove(...)

2014-05-29 Thread Giedrius Rekasius
Local variable "box" gets assigned correct value when it is initialized. There is no need to assign the same value again. Variable declarations were reshuffled for better readability. Signed-off-by: Giedrius Rekasius --- Original patch was amended for better readability based on feedback from Wal

Re: [PATCH] perf/x86/uncore: Remove unnecessary assignment to "box" in uncore_pci_remove(...)

2014-05-28 Thread Thomas Gleixner
On Wed, 28 May 2014, walter harms wrote: > Am 28.05.2014 11:11, schrieb Giedrius Rekasius: > > Local variable "box" gets assigned correct value when it is initialized. > > There is no need to assign the same value again. > > > > Signed-off-by: Giedrius Rekasius > > --- > > arch/x86/kernel/cpu/pe

Re: [PATCH] perf/x86/uncore: Remove unnecessary assignment to "box" in uncore_pci_remove(...)

2014-05-28 Thread Giedrius Rekasius
On Wed, May 28, 2014 at 12:16:04PM +0200, walter harms wrote: > > > Am 28.05.2014 11:11, schrieb Giedrius Rekasius: > > Local variable "box" gets assigned correct value when it is initialized. > > There is no need to assign the same value again. > > > > Signed-off-by: Giedrius Rekasius > > ---

Re: [PATCH] perf/x86/uncore: Remove unnecessary assignment to "box" in uncore_pci_remove(...)

2014-05-28 Thread walter harms
Am 28.05.2014 11:11, schrieb Giedrius Rekasius: > Local variable "box" gets assigned correct value when it is initialized. > There is no need to assign the same value again. > > Signed-off-by: Giedrius Rekasius > --- > arch/x86/kernel/cpu/perf_event_intel_uncore.c | 1 - > 1 file changed, 1 de

[PATCH] perf/x86/uncore: Remove unnecessary assignment to "box" in uncore_pci_remove(...)

2014-05-28 Thread Giedrius Rekasius
Local variable "box" gets assigned correct value when it is initialized. There is no need to assign the same value again. Signed-off-by: Giedrius Rekasius --- arch/x86/kernel/cpu/perf_event_intel_uncore.c | 1 - 1 file changed, 1 deletion(-) diff --git a/arch/x86/kernel/cpu/perf_event_intel_unc