Re: [PATCH] sched: Enhance readability of iterating wake_list

2017-02-10 Thread Byungchul Park
On Fri, Feb 10, 2017 at 08:55:23AM +0100, Peter Zijlstra wrote: > On Fri, Feb 10, 2017 at 01:09:31PM +0900, Byungchul Park wrote: > > +#define for_each_wake_list(task, node) \ > > + for ((task) = llist_entry((node), struct task_struct, wake_entry); \ > > +node; (node) = llist_next(node),

Re: [PATCH] sched: Enhance readability of iterating wake_list

2017-02-10 Thread Byungchul Park
On Fri, Feb 10, 2017 at 08:55:23AM +0100, Peter Zijlstra wrote: > On Fri, Feb 10, 2017 at 01:09:31PM +0900, Byungchul Park wrote: > > +#define for_each_wake_list(task, node) \ > > + for ((task) = llist_entry((node), struct task_struct, wake_entry); \ > > +node; (node) = llist_next(node),

Re: [PATCH] sched: Enhance readability of iterating wake_list

2017-02-10 Thread Byungchul Park
On Fri, Feb 10, 2017 at 08:55:23AM +0100, Peter Zijlstra wrote: > On Fri, Feb 10, 2017 at 01:09:31PM +0900, Byungchul Park wrote: > > +#define for_each_wake_list(task, node) \ > > + for ((task) = llist_entry((node), struct task_struct, wake_entry); \ > > +node; (node) = llist_next(node),

Re: [PATCH] sched: Enhance readability of iterating wake_list

2017-02-10 Thread Byungchul Park
On Fri, Feb 10, 2017 at 08:55:23AM +0100, Peter Zijlstra wrote: > On Fri, Feb 10, 2017 at 01:09:31PM +0900, Byungchul Park wrote: > > +#define for_each_wake_list(task, node) \ > > + for ((task) = llist_entry((node), struct task_struct, wake_entry); \ > > +node; (node) = llist_next(node),

Re: [PATCH] sched: Enhance readability of iterating wake_list

2017-02-09 Thread Peter Zijlstra
On Fri, Feb 10, 2017 at 01:09:31PM +0900, Byungchul Park wrote: > +#define for_each_wake_list(task, node) \ > + for ((task) = llist_entry((node), struct task_struct, wake_entry); \ > + node; (node) = llist_next(node), \ > + (task) = llist_entry((node), struct task_struct,

Re: [PATCH] sched: Enhance readability of iterating wake_list

2017-02-09 Thread Peter Zijlstra
On Fri, Feb 10, 2017 at 01:09:31PM +0900, Byungchul Park wrote: > +#define for_each_wake_list(task, node) \ > + for ((task) = llist_entry((node), struct task_struct, wake_entry); \ > + node; (node) = llist_next(node), \ > + (task) = llist_entry((node), struct task_struct,

[PATCH] sched: Enhance readability of iterating wake_list

2017-02-09 Thread Byungchul Park
This is just for enhancing readability and a trivial one. Please take this only if you agree. -8<- >From bb8cfcaa21ce157fb890a3e878fed2f2b7dadf81 Mon Sep 17 00:00:00 2001 From: Byungchul Park <byungchul.p...@lge.com> Date: Fri, 10 Feb 2017 12:53:14 +0900 Subject: [PATCH] sc

[PATCH] sched: Enhance readability of iterating wake_list

2017-02-09 Thread Byungchul Park
This is just for enhancing readability and a trivial one. Please take this only if you agree. -8<- >From bb8cfcaa21ce157fb890a3e878fed2f2b7dadf81 Mon Sep 17 00:00:00 2001 From: Byungchul Park Date: Fri, 10 Feb 2017 12:53:14 +0900 Subject: [PATCH] sched: Enhance readability of ite