Re: [PATCH 07/14] powercap/intel_rapl: Simplify rapl_find_package()

2019-03-26 Thread Len Brown
On Tue, Feb 26, 2019 at 2:07 PM Peter Zijlstra wrote: > > On Tue, Feb 26, 2019 at 01:20:05AM -0500, Len Brown wrote: > > -static struct rapl_package *find_package_by_id(int id) > > +static struct rapl_package *rapl_find_package(int cpu) > > { > > + int id = topology_physical_package_id(cpu);

Re: [PATCH 07/14] powercap/intel_rapl: Simplify rapl_find_package()

2019-02-26 Thread Peter Zijlstra
On Tue, Feb 26, 2019 at 01:20:05AM -0500, Len Brown wrote: > -static struct rapl_package *find_package_by_id(int id) > +static struct rapl_package *rapl_find_package(int cpu) > { > + int id = topology_physical_package_id(cpu); > struct rapl_package *rp; Which you'll change to topology_p

[PATCH 07/14] powercap/intel_rapl: Simplify rapl_find_package()

2019-02-25 Thread Len Brown
From: Zhang Rui Syntax only, no functional or semantic change. Simplify how the code to discover a package is called. Rename find_package_by_id() to rapl_find_package() Signed-off-by: Zhang Rui Signed-off-by: Len Brown Acked-by: Rafael J. Wysocki Cc: linux...@vger.kernel.org --- drivers/pow