Re: [PATCH 1/2] mm,swap: extract swap single page readahead into its own function

2020-09-23 Thread Christoph Hellwig
On Mon, Sep 21, 2020 at 10:01:47PM -0400, Rik van Riel wrote: > +static struct page *swap_cluster_read_one(swp_entry_t entry, > + unsigned long offset, gfp_t gfp_mask, > + struct vm_area_struct *vma, unsigned long addr, bool readahead) > +{ > + bool page_allocated; > +

[PATCH 1/2] mm,swap: extract swap single page readahead into its own function

2020-09-21 Thread Rik van Riel
Split swap single page readahead into its own function, to make the next patch easier to read. No functional changes. Signed-off-by: Rik van Riel --- mm/swap_state.c | 40 +--- 1 file changed, 25 insertions(+), 15 deletions(-) diff --git a/mm/swap_state.c