Re: [PATCH 1/2] x86: reimplement ___preempt_schedule*() using THUNK helpers

2014-09-04 Thread Andy Lutomirski
On Thu, Sep 4, 2014 at 6:42 AM, Oleg Nesterov wrote: > > ___preempt_schedule() does SAVE_ALL/RESTORE_ALL but this is suboptimal, > we do not need to save/restore the callee-saved register. And we already > have arch/x86/lib/thunk_*.S which implements the similar asm wrappers, > so it makes sense t

Re: [PATCH 1/2] x86: reimplement ___preempt_schedule*() using THUNK helpers

2014-09-04 Thread Oleg Nesterov
On 09/04, Denys Vlasenko wrote: > > or thunk_ra should be renamed to THUNK (like it is in thunk_64.S) Of course! Thanks a lot Denys. Oleg. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http

Re: [PATCH 1/2] x86: reimplement ___preempt_schedule*() using THUNK helpers

2014-09-04 Thread Denys Vlasenko
On Thu, Sep 4, 2014 at 3:42 PM, Oleg Nesterov wrote: > -#ifdef CONFIG_TRACE_IRQFLAGS > /* put return address in eax (arg1) */ > - .macro thunk_ra name,func > + .macro thunk_ra name, func, put_ret_addr_in_eax=0 > .globl \name > \name: > pushl %eax > push

[PATCH 1/2] x86: reimplement ___preempt_schedule*() using THUNK helpers

2014-09-04 Thread Oleg Nesterov
___preempt_schedule() does SAVE_ALL/RESTORE_ALL but this is suboptimal, we do not need to save/restore the callee-saved register. And we already have arch/x86/lib/thunk_*.S which implements the similar asm wrappers, so it makes sense to redefine ___preempt_schedule() as "THUNK ..." and remove preem