Re: [PATCH 1/3] seq_file: Introduce DEFINE_SEQ_ATTRIBUTE() helper macro

2020-05-09 Thread Markus Elfring
… > +++ b/include/linux/seq_file.h > @@ -145,6 +145,25 @@ void *__seq_open_private(struct file *, const struct > seq_operations *, int); > int seq_open_private(struct file *, const struct seq_operations *, int); > int seq_release_private(struct inode *, struct file *); > > +#define

[PATCH 1/3] seq_file: Introduce DEFINE_SEQ_ATTRIBUTE() helper macro

2020-05-09 Thread Kefeng Wang
Introduce DEFINE_SEQ_ATTRIBUTE() helper macro to decrease code duplication. Signed-off-by: Kefeng Wang --- include/linux/seq_file.h | 19 +++ 1 file changed, 19 insertions(+) diff --git a/include/linux/seq_file.h b/include/linux/seq_file.h index 1672cf6f7614..c77869cf7d10