Re: [PATCH 10/21] cpuidle: reduce code duplication inside cpuidle_idle_call()

2013-09-25 Thread Daniel Lezcano
On 09/22/2013 03:21 AM, Viresh Kumar wrote: > We are doing this twice in cpuidle_idle_call() routine: > drv->states[next_state].flags & CPUIDLE_FLAG_TIMER_STOP > > Would be better if we actually store this in a local variable and use that. > That > would remove code duplication as well as m

[PATCH 10/21] cpuidle: reduce code duplication inside cpuidle_idle_call()

2013-09-21 Thread Viresh Kumar
We are doing this twice in cpuidle_idle_call() routine: drv->states[next_state].flags & CPUIDLE_FLAG_TIMER_STOP Would be better if we actually store this in a local variable and use that. That would remove code duplication as well as make this piece of code run fast (in case compiler wasn'