Re: [PATCH 20/33] ipv4: add ip_sock_set_recverr

2020-05-20 Thread Christoph Hellwig
On Thu, May 14, 2020 at 04:51:26AM -0700, Joe Perches wrote: > > Mostly to keep it symmetric with the sockopt. I could probably remove > > a few arguments in the series if we want to be strict. > > My preference would use strict and add > arguments only when necessary. In a few cases that would

Re: [PATCH 20/33] ipv4: add ip_sock_set_recverr

2020-05-14 Thread Joe Perches
On Thu, 2020-05-14 at 12:30 +0200, Christoph Hellwig wrote: > On Wed, May 13, 2020 at 02:00:43PM -0700, Joe Perches wrote: > > On Wed, 2020-05-13 at 08:26 +0200, Christoph Hellwig wrote: > > > Add a helper to directly set the IP_RECVERR sockopt from kernel space > > > without going through a fake

Re: [PATCH 20/33] ipv4: add ip_sock_set_recverr

2020-05-14 Thread Christoph Hellwig
On Wed, May 13, 2020 at 02:00:43PM -0700, Joe Perches wrote: > On Wed, 2020-05-13 at 08:26 +0200, Christoph Hellwig wrote: > > Add a helper to directly set the IP_RECVERR sockopt from kernel space > > without going through a fake uaccess. > > This seems used only with true as the second arg. > Is

Re: [PATCH 20/33] ipv4: add ip_sock_set_recverr

2020-05-13 Thread Joe Perches
On Wed, 2020-05-13 at 08:26 +0200, Christoph Hellwig wrote: > Add a helper to directly set the IP_RECVERR sockopt from kernel space > without going through a fake uaccess. This seems used only with true as the second arg. Is there reason to have that argument at all? > diff --git

Re: [PATCH 20/33] ipv4: add ip_sock_set_recverr

2020-05-13 Thread David Howells
Christoph Hellwig wrote: > Add a helper to directly set the IP_RECVERR sockopt from kernel space > without going through a fake uaccess. It looks like if this is an AF_INET6 socket, it will just pass the message straight through to AF_INET4, so: Reviewed-by: David Howells

[PATCH 20/33] ipv4: add ip_sock_set_recverr

2020-05-13 Thread Christoph Hellwig
Add a helper to directly set the IP_RECVERR sockopt from kernel space without going through a fake uaccess. Signed-off-by: Christoph Hellwig --- include/net/ip.h | 1 + net/ipv4/ip_sockglue.c | 10 ++ net/rxrpc/local_object.c | 8 +--- 3 files changed, 12 insertions(+),