Re: [PATCH 3/3] Consolidate send_sigqueue and send_group_sigqueue

2008-02-22 Thread Oleg Nesterov
On 02/22, Pavel Emelyanov wrote: > > --- a/kernel/signal.c > +++ b/kernel/signal.c > @@ -1291,10 +1291,33 @@ void sigqueue_free(struct sigqueue *q) > __sigqueue_free(q); > } > > +static int do_send_sigqueue(int sig, struct sigqueue *q, struct task_struct > *t, > + struct sigpe

[PATCH 3/3] Consolidate send_sigqueue and send_group_sigqueue

2008-02-22 Thread Pavel Emelyanov
Both function do the same thing after proper locking, but with different sigpening structs, so move the common code into a helper. After this we have 4 places that look very similar: send_sigqueue: calls do_send_sigqueue and signal_wakeup send_group_sigqueue: calls do_send_sigqueue and __group_com