Re: [PATCH 3/5] timer: Change idle/iowait accounting semantics

2013-11-04 Thread Frederic Weisbecker
On Sun, Oct 20, 2013 at 09:34:56AM +0200, Andreas Mohr wrote: > Hi, > > just wanted to report that this capricious open-coded (ok, lone-coded :) > converter: > > +static inline ktime_t us_to_ktime(u64 us) > +{ > + static const ktime_t ktime_zero = { .tv64 = 0 }; > + > + return

Re: [PATCH 3/5] timer: Change idle/iowait accounting semantics

2013-11-04 Thread Frederic Weisbecker
On Sun, Oct 20, 2013 at 09:34:56AM +0200, Andreas Mohr wrote: Hi, just wanted to report that this capricious open-coded (ok, lone-coded :) converter: +static inline ktime_t us_to_ktime(u64 us) +{ + static const ktime_t ktime_zero = { .tv64 = 0 }; + + return

Re: [PATCH 3/5] timer: Change idle/iowait accounting semantics

2013-10-20 Thread Andreas Mohr
Hi, just wanted to report that this capricious open-coded (ok, lone-coded :) converter: +static inline ktime_t us_to_ktime(u64 us) +{ + static const ktime_t ktime_zero = { .tv64 = 0 }; + + return ktime_add_us(ktime_zero, us); +} triggered a virtual red flag in my processing. We

Re: [PATCH 3/5] timer: Change idle/iowait accounting semantics

2013-10-20 Thread Andreas Mohr
Hi, just wanted to report that this capricious open-coded (ok, lone-coded :) converter: +static inline ktime_t us_to_ktime(u64 us) +{ + static const ktime_t ktime_zero = { .tv64 = 0 }; + + return ktime_add_us(ktime_zero, us); +} triggered a virtual red flag in my processing. We

[PATCH 3/5] timer: Change idle/iowait accounting semantics

2013-10-19 Thread Frederic Weisbecker
To prepare for fixing a race between iowait and idle time stats, this patch changes the following semantics: * iowait time is going to be accounted from the scheduler rather than the dynticks idle code, lets remove it from the /proc/timer_list dump. * idle sleeptime now also includes the iowait

[PATCH 3/5] timer: Change idle/iowait accounting semantics

2013-10-19 Thread Frederic Weisbecker
To prepare for fixing a race between iowait and idle time stats, this patch changes the following semantics: * iowait time is going to be accounted from the scheduler rather than the dynticks idle code, lets remove it from the /proc/timer_list dump. * idle sleeptime now also includes the iowait