Re: [PATCH 4/7] sched: Add sched_load_rq tracepoint

2019-05-10 Thread Qais Yousef
On 05/10/19 10:51, Dietmar Eggemann wrote: > Hi Qais, > > On 5/5/19 1:57 PM, Qais Yousef wrote: > > [...] > > > diff --git a/kernel/sched/sched_tracepoints.h > > b/kernel/sched/sched_tracepoints.h > > new file mode 100644 > > index ..f4ded705118e > > --- /dev/null > > +++

Re: [PATCH 4/7] sched: Add sched_load_rq tracepoint

2019-05-10 Thread Dietmar Eggemann
Hi Qais, On 5/5/19 1:57 PM, Qais Yousef wrote: [...] diff --git a/kernel/sched/sched_tracepoints.h b/kernel/sched/sched_tracepoints.h new file mode 100644 index ..f4ded705118e --- /dev/null +++ b/kernel/sched/sched_tracepoints.h @@ -0,0 +1,39 @@ +/* SPDX-License-Identifier:

Re: [PATCH 4/7] sched: Add sched_load_rq tracepoint

2019-05-08 Thread Qais Yousef
On 05/06/19 11:18, Peter Zijlstra wrote: > On Mon, May 06, 2019 at 11:08:59AM +0200, Peter Zijlstra wrote: > > Also; I _really_ hate how fat they are. Why can't we do simple straight > > forward things like: > > > > trace_pelt_cfq(cfq); > > trace_pelt_rq(rq); > > trace_pelt_se(se); >

Re: [PATCH 4/7] sched: Add sched_load_rq tracepoint

2019-05-06 Thread Qais Yousef
On 05/06/19 12:01, Steven Rostedt wrote: > On Mon, 6 May 2019 16:33:17 +0100 > Qais Yousef wrote: > > > On 05/06/19 10:46, Steven Rostedt wrote: > > > On Mon, 6 May 2019 15:42:00 +0100 > > > Qais Yousef wrote: > > > > > > > I can control that for the wrappers I'm introducing. But the actual

Re: [PATCH 4/7] sched: Add sched_load_rq tracepoint

2019-05-06 Thread Steven Rostedt
On Mon, 6 May 2019 16:33:17 +0100 Qais Yousef wrote: > On 05/06/19 10:46, Steven Rostedt wrote: > > On Mon, 6 May 2019 15:42:00 +0100 > > Qais Yousef wrote: > > > > > I can control that for the wrappers I'm introducing. But the actual > > > tracepoint > > > get the 'trace_' part prepended

Re: [PATCH 4/7] sched: Add sched_load_rq tracepoint

2019-05-06 Thread Qais Yousef
On 05/06/19 10:46, Steven Rostedt wrote: > On Mon, 6 May 2019 15:42:00 +0100 > Qais Yousef wrote: > > > I can control that for the wrappers I'm introducing. But the actual > > tracepoint > > get the 'trace_' part prepended automatically by the macros. > > > > ie DECLARE_TRACE(pelt_rq, ...)

Re: [PATCH 4/7] sched: Add sched_load_rq tracepoint

2019-05-06 Thread Qais Yousef
On 05/06/19 11:08, Peter Zijlstra wrote: > On Sun, May 05, 2019 at 12:57:29PM +0100, Qais Yousef wrote: > > > +/* > > + * Following tracepoints are not exported in tracefs and provide hooking > > + * mechanisms only for testing and debugging purposes. > > + */ > > +DECLARE_TRACE(sched_load_rq, >

Re: [PATCH 4/7] sched: Add sched_load_rq tracepoint

2019-05-06 Thread Qais Yousef
On 05/06/19 09:52, Steven Rostedt wrote: > On Mon, 6 May 2019 11:08:59 +0200 > Peter Zijlstra wrote: > > > These functions really should be called trace_*() > > > > Also; I _really_ hate how fat they are. Why can't we do simple straight > > forward things like: > > > > trace_pelt_cfq(cfq);

Re: [PATCH 4/7] sched: Add sched_load_rq tracepoint

2019-05-06 Thread Steven Rostedt
On Mon, 6 May 2019 15:42:00 +0100 Qais Yousef wrote: > I can control that for the wrappers I'm introducing. But the actual tracepoint > get the 'trace_' part prepended automatically by the macros. > > ie DECLARE_TRACE(pelt_rq, ...) will automatically generate a function called >

Re: [PATCH 4/7] sched: Add sched_load_rq tracepoint

2019-05-06 Thread Steven Rostedt
On Mon, 6 May 2019 11:08:59 +0200 Peter Zijlstra wrote: > These functions really should be called trace_*() > > Also; I _really_ hate how fat they are. Why can't we do simple straight > forward things like: > > trace_pelt_cfq(cfq); > trace_pelt_rq(rq); > trace_pelt_se(se); >

Re: [PATCH 4/7] sched: Add sched_load_rq tracepoint

2019-05-06 Thread Peter Zijlstra
On Mon, May 06, 2019 at 11:08:59AM +0200, Peter Zijlstra wrote: > Also; I _really_ hate how fat they are. Why can't we do simple straight > forward things like: > > trace_pelt_cfq(cfq); > trace_pelt_rq(rq); > trace_pelt_se(se); > > And then have the thing attached to the event

Re: [PATCH 4/7] sched: Add sched_load_rq tracepoint

2019-05-06 Thread Peter Zijlstra
On Sun, May 05, 2019 at 12:57:29PM +0100, Qais Yousef wrote: > +/* > + * Following tracepoints are not exported in tracefs and provide hooking > + * mechanisms only for testing and debugging purposes. > + */ > +DECLARE_TRACE(sched_load_rq, > + TP_PROTO(int cpu, const char *path, struct

[PATCH 4/7] sched: Add sched_load_rq tracepoint

2019-05-05 Thread Qais Yousef
The new tracepoint allows tracking PELT signals at rq level for all scheduling classes. Signed-off-by: Qais Yousef --- include/trace/events/sched.h | 9 kernel/sched/fair.c | 9 ++-- kernel/sched/pelt.c | 4 kernel/sched/sched_tracepoints.h |