Re: [PATCH 5/7] lib: rework bitmap_parse()

2019-09-09 Thread Andy Shevchenko
On Sun, Sep 08, 2019 at 08:30:19PM -0700, Yury Norov wrote: > bitmap_parse() is ineffective and full of opaque variables and opencoded > parts. It leads to hard understanding and usage of it. This rework > includes: > - remove bitmap_shift_left() call from the cycle. Now it makes the >

[PATCH 5/7] lib: rework bitmap_parse()

2019-09-08 Thread Yury Norov
bitmap_parse() is ineffective and full of opaque variables and opencoded parts. It leads to hard understanding and usage of it. This rework includes: - remove bitmap_shift_left() call from the cycle. Now it makes the complexity of the algorithm as O(nbits^2). In the suggested approach the

Re: [PATCH 5/7] lib: rework bitmap_parse()

2019-07-22 Thread Andy Shevchenko
On Sun, Jul 21, 2019 at 02:27:51PM -0700, Yury Norov wrote: > From Yury Norov > > bitmap_parse() is ineffective and full of opaque variables and opencoded > parts. It leads to hard understanding and usage of it. This rework > includes: > - remove bitmap_shift_left() call from the cycle. Now it

[PATCH 5/7] lib: rework bitmap_parse()

2019-07-21 Thread Yury Norov
>From Yury Norov bitmap_parse() is ineffective and full of opaque variables and opencoded parts. It leads to hard understanding and usage of it. This rework includes: - remove bitmap_shift_left() call from the cycle. Now it makes the complexity of the algorithm as O(nbits^2). In the

Re: [PATCH 5/7] lib: rework bitmap_parse()

2019-05-23 Thread Andrew Morton
On Thu, 9 May 2019 19:26:33 -0700 Yury Norov wrote: > Hi Andy, > > Thanks for thorough review. > > On Wed, May 08, 2019 at 11:46:32AM +0300, Andy Shevchenko wrote: > > On Tue, Apr 30, 2019 at 06:06:34PM -0700, Yury Norov wrote: > > > bitmap_parse() is ineffective and full of opaque variables

Re: [PATCH 5/7] lib: rework bitmap_parse()

2019-05-09 Thread Yury Norov
Hi Andy, Thanks for thorough review. On Wed, May 08, 2019 at 11:46:32AM +0300, Andy Shevchenko wrote: > On Tue, Apr 30, 2019 at 06:06:34PM -0700, Yury Norov wrote: > > bitmap_parse() is ineffective and full of opaque variables and opencoded > > parts. It leads to hard understanding and usage of

Re: [PATCH 5/7] lib: rework bitmap_parse()

2019-05-08 Thread Andy Shevchenko
On Tue, Apr 30, 2019 at 06:06:34PM -0700, Yury Norov wrote: > bitmap_parse() is ineffective and full of opaque variables and opencoded > parts. It leads to hard understanding and usage of it. This rework > includes: > - remove bitmap_shift_left() call from the cycle. Now it makes the >

[PATCH 5/7] lib: rework bitmap_parse()

2019-04-30 Thread Yury Norov
bitmap_parse() is ineffective and full of opaque variables and opencoded parts. It leads to hard understanding and usage of it. This rework includes: - remove bitmap_shift_left() call from the cycle. Now it makes the complexity of the algorithm as O(nbits^2). In the suggested approach the