devm_fwnode_get_index_gpiod_from_child() is going away as the name is
too unwieldy, let's switch to using the new devm_fwnode_gpiod_get().

Note that we no longer need to check for NULL as devm_fwnode_gpiod_get()
will return -ENOENT if GPIO is missing.

Signed-off-by: Dmitry Torokhov <dmitry.torok...@gmail.com>
---

 drivers/regulator/tps65132-regulator.c | 17 ++++++++++-------
 1 file changed, 10 insertions(+), 7 deletions(-)

diff --git a/drivers/regulator/tps65132-regulator.c 
b/drivers/regulator/tps65132-regulator.c
index e302bd01a084..7b0e38f8d627 100644
--- a/drivers/regulator/tps65132-regulator.c
+++ b/drivers/regulator/tps65132-regulator.c
@@ -136,9 +136,10 @@ static int tps65132_of_parse_cb(struct device_node *np,
        struct tps65132_reg_pdata *rpdata = &tps->reg_pdata[desc->id];
        int ret;
 
-       rpdata->en_gpiod = devm_fwnode_get_index_gpiod_from_child(tps->dev,
-                                       "enable", 0, &np->fwnode, 0, "enable");
-       if (IS_ERR_OR_NULL(rpdata->en_gpiod)) {
+       rpdata->en_gpiod = devm_fwnode_gpiod_get(tps->dev, of_fwnode_handle(np),
+                                                "enable", GPIOD_ASIS,
+                                                "enable");
+       if (IS_ERR(rpdata->en_gpiod)) {
                ret = PTR_ERR(rpdata->en_gpiod);
 
                /* Ignore the error other than probe defer */
@@ -147,10 +148,12 @@ static int tps65132_of_parse_cb(struct device_node *np,
                return 0;
        }
 
-       rpdata->act_dis_gpiod = devm_fwnode_get_index_gpiod_from_child(
-                                       tps->dev, "active-discharge", 0,
-                                       &np->fwnode, 0, "active-discharge");
-       if (IS_ERR_OR_NULL(rpdata->act_dis_gpiod)) {
+       rpdata->act_dis_gpiod = devm_fwnode_gpiod_get(tps->dev,
+                                                     of_fwnode_handle(np),
+                                                     "active-discharge",
+                                                     GPIOD_ASIS,
+                                                     "active-discharge");
+       if (IS_ERR(rpdata->act_dis_gpiod)) {
                ret = PTR_ERR(rpdata->act_dis_gpiod);
 
                /* Ignore the error other than probe defer */
-- 
2.23.0.581.g78d2f28ef7-goog

Reply via email to