Re: [PATCH v1 RFC 6/7] Add MIB counter reading support

2017-10-14 Thread Andrew Lunn
> +static void ksz9477_phy_setup(struct ksz_device *dev, int port, > + struct phy_device *phy) > +{ > + if (port < dev->phy_port_cnt) { > + /* SUPPORTED_Asym_Pause and SUPPORTED_Pause can be removed to > + * disable flow control when rate

Re: [PATCH v1 RFC 6/7] Add MIB counter reading support

2017-10-14 Thread Andrew Lunn
> +static void ksz9477_phy_setup(struct ksz_device *dev, int port, > + struct phy_device *phy) > +{ > + if (port < dev->phy_port_cnt) { > + /* SUPPORTED_Asym_Pause and SUPPORTED_Pause can be removed to > + * disable flow control when rate

Re: [PATCH v1 RFC 6/7] Add MIB counter reading support

2017-10-09 Thread Florian Fainelli
On 10/06/2017 01:33 PM, tristram...@microchip.com wrote: > From: Tristram Ha > > Add MIB counter reading support. > Rename ksz_9477_reg.h to ksz9477_reg.h for consistency as the product > name is always KSZ. > Header file ksz_priv.h no longer contains any chip

Re: [PATCH v1 RFC 6/7] Add MIB counter reading support

2017-10-09 Thread Florian Fainelli
On 10/06/2017 01:33 PM, tristram...@microchip.com wrote: > From: Tristram Ha > > Add MIB counter reading support. > Rename ksz_9477_reg.h to ksz9477_reg.h for consistency as the product > name is always KSZ. > Header file ksz_priv.h no longer contains any chip specific data. You should

Re: [PATCH v1 RFC 6/7] Add MIB counter reading support

2017-10-09 Thread Pavel Machek
Hi! > From: Tristram Ha > > Add MIB counter reading support. > Rename ksz_9477_reg.h to ksz9477_reg.h for consistency as the product > name is always KSZ. > Header file ksz_priv.h no longer contains any chip specific data. Nothing obviously wrong here, but if you

Re: [PATCH v1 RFC 6/7] Add MIB counter reading support

2017-10-09 Thread Pavel Machek
Hi! > From: Tristram Ha > > Add MIB counter reading support. > Rename ksz_9477_reg.h to ksz9477_reg.h for consistency as the product > name is always KSZ. > Header file ksz_priv.h no longer contains any chip specific data. Nothing obviously wrong here, but if you are doing another

[PATCH v1 RFC 6/7] Add MIB counter reading support

2017-10-06 Thread Tristram.Ha
From: Tristram Ha Add MIB counter reading support. Rename ksz_9477_reg.h to ksz9477_reg.h for consistency as the product name is always KSZ. Header file ksz_priv.h no longer contains any chip specific data. Signed-off-by: Tristram Ha

[PATCH v1 RFC 6/7] Add MIB counter reading support

2017-10-06 Thread Tristram.Ha
From: Tristram Ha Add MIB counter reading support. Rename ksz_9477_reg.h to ksz9477_reg.h for consistency as the product name is always KSZ. Header file ksz_priv.h no longer contains any chip specific data. Signed-off-by: Tristram Ha --- drivers/net/dsa/microchip/ksz9477.c