Re: [PATCH v2 0/6] x86: Rewrite switch_to()

2016-06-19 Thread Brian Gerst
On Sat, Jun 18, 2016 at 4:56 PM, Brian Gerst wrote: > This patch set simplifies the switch_to() code, by moving the stack switch > code out of line into an asm stub before calling __switch_to(). This ends > up being more readable, and using the C calling convention instead of > clobbering all reg

[PATCH v2 0/6] x86: Rewrite switch_to()

2016-06-18 Thread Brian Gerst
This patch set simplifies the switch_to() code, by moving the stack switch code out of line into an asm stub before calling __switch_to(). This ends up being more readable, and using the C calling convention instead of clobbering all registers improves code generation. It also allows newly forked