This patch series is part of [1] patch series. Because those patches are code cleanup or simplification. I gather those patches into a separate series to make it easier to review.
[1] https://lore.kernel.org/linux-mm/20210409122959.82264-1-songmuc...@bytedance.com/ Changlogs in v2: 1. Collect Acked-by and Review-by tags. 2. Add a new patch to rename lruvec_holds_page_lru_lock to page_matches_lruvec. 3. Add a comment to patch 2. Thanks to Roman, Johannes, Shakeel and Michal's review. Muchun Song (8): mm: memcontrol: fix page charging in page replacement mm: memcontrol: bail out early when !mm in get_mem_cgroup_from_mm mm: memcontrol: remove the pgdata parameter of mem_cgroup_page_lruvec mm: memcontrol: simplify lruvec_holds_page_lru_lock mm: memcontrol: rename lruvec_holds_page_lru_lock to page_matches_lruvec mm: memcontrol: simplify the logic of objcg pinning memcg mm: memcontrol: move obj_cgroup_uncharge_pages() out of css_set_lock mm: vmscan: remove noinline_for_stack include/linux/memcontrol.h | 42 +++++++++--------------------- mm/compaction.c | 2 +- mm/memcontrol.c | 65 +++++++++++++++++++++------------------------- mm/swap.c | 2 +- mm/vmscan.c | 8 +++--- mm/workingset.c | 2 +- 6 files changed, 49 insertions(+), 72 deletions(-) -- 2.11.0