Re: [PATCH v2 3/3] sched: clean-up struct sd_lb_stat

2013-08-06 Thread Preeti U Murthy
Hi Joonsoo, On 08/05/2013 01:02 PM, Joonsoo Kim wrote: >>> + if (busiest->group_imb) { >>> + busiest->sum_weighted_load = >>> + min(busiest->sum_weighted_load, sds->sd_avg_load); >> >> Right here we get confused as to why the total load is being compared >> against

Re: [PATCH v2 3/3] sched: clean-up struct sd_lb_stat

2013-08-06 Thread Preeti U Murthy
Hi Joonsoo, On 08/05/2013 01:02 PM, Joonsoo Kim wrote: + if (busiest-group_imb) { + busiest-sum_weighted_load = + min(busiest-sum_weighted_load, sds-sd_avg_load); Right here we get confused as to why the total load is being compared against load per task

Re: [PATCH v2 3/3] sched: clean-up struct sd_lb_stat

2013-08-05 Thread Joonsoo Kim
> > + if (busiest->group_imb) { > > + busiest->sum_weighted_load = > > + min(busiest->sum_weighted_load, sds->sd_avg_load); > > Right here we get confused as to why the total load is being compared > against load per task (although you are changing it to load per

Re: [PATCH v2 3/3] sched: clean-up struct sd_lb_stat

2013-08-05 Thread Joonsoo Kim
+ if (busiest-group_imb) { + busiest-sum_weighted_load = + min(busiest-sum_weighted_load, sds-sd_avg_load); Right here we get confused as to why the total load is being compared against load per task (although you are changing it to load per task above).

Re: [PATCH v2 3/3] sched: clean-up struct sd_lb_stat

2013-08-01 Thread Preeti U Murthy
Hi Joonsoo, On 08/02/2013 07:20 AM, Joonsoo Kim wrote: > There is no reason to maintain separate variables for this_group > and busiest_group in sd_lb_stat, except saving some space. > But this structure is always allocated in stack, so this saving > isn't really benificial. > > This patch unify

[PATCH v2 3/3] sched: clean-up struct sd_lb_stat

2013-08-01 Thread Joonsoo Kim
There is no reason to maintain separate variables for this_group and busiest_group in sd_lb_stat, except saving some space. But this structure is always allocated in stack, so this saving isn't really benificial. This patch unify these variables, so IMO, readability may be improved.

[PATCH v2 3/3] sched: clean-up struct sd_lb_stat

2013-08-01 Thread Joonsoo Kim
There is no reason to maintain separate variables for this_group and busiest_group in sd_lb_stat, except saving some space. But this structure is always allocated in stack, so this saving isn't really benificial. This patch unify these variables, so IMO, readability may be improved.

Re: [PATCH v2 3/3] sched: clean-up struct sd_lb_stat

2013-08-01 Thread Preeti U Murthy
Hi Joonsoo, On 08/02/2013 07:20 AM, Joonsoo Kim wrote: There is no reason to maintain separate variables for this_group and busiest_group in sd_lb_stat, except saving some space. But this structure is always allocated in stack, so this saving isn't really benificial. This patch unify these