[PATCH v4 1/3] mfd: intel_soc_pmic: Core driver

2014-05-29 Thread Zhu, Lejun
This patch provides the common I2C driver code for Intel SoC PMICs. Signed-off-by: Yang, Bin Signed-off-by: Zhu, Lejun --- v2: - Use regmap instead of creating our own I2C read/write callbacks. - Add one missing EXPORT_SYMBOL. - Remove duplicate code and put them into pmic_regmap_load_from_hw. v

Re: [PATCH v4 1/3] mfd: intel_soc_pmic: Core driver

2014-05-29 Thread Lee Jones
> This patch provides the common I2C driver code for Intel SoC PMICs. > > Signed-off-by: Yang, Bin > Signed-off-by: Zhu, Lejun > --- > v2: > - Use regmap instead of creating our own I2C read/write callbacks. > - Add one missing EXPORT_SYMBOL. > - Remove duplicate code and put them into pmic_regm

Re: [PATCH v4 1/3] mfd: intel_soc_pmic: Core driver

2014-05-29 Thread Zhu, Lejun
On 5/29/2014 7:40 PM, Lee Jones wrote: > [...] > >> +static int intel_soc_pmic_find_gpio_irq(struct device *dev) >> +{ >> +struct gpio_desc *desc; >> +int irq; >> + >> +desc = devm_gpiod_get_index(dev, KBUILD_MODNAME, 0); > > What does "KBUILD_MODNAME" translate to? It translates i

Re: [PATCH v4 1/3] mfd: intel_soc_pmic: Core driver

2014-05-30 Thread Lee Jones
> >> +static int intel_soc_pmic_find_gpio_irq(struct device *dev) > >> +{ > >> + struct gpio_desc *desc; > >> + int irq; > >> + > >> + desc = devm_gpiod_get_index(dev, KBUILD_MODNAME, 0); > > > > What does "KBUILD_MODNAME" translate to? > > It translates into "intel_soc_pmic". Can you just pu

Re: [PATCH v4 1/3] mfd: intel_soc_pmic: Core driver

2014-05-30 Thread Zhu, Lejun
On 2014/5/30 16:08, Lee Jones wrote: +static int intel_soc_pmic_find_gpio_irq(struct device *dev) +{ + struct gpio_desc *desc; + int irq; + + desc = devm_gpiod_get_index(dev, KBUILD_MODNAME, 0); >>> >>> What does "KBUILD_MODNAME" translate to? >> >> It translates

Re: [PATCH v4 1/3] mfd: intel_soc_pmic: Core driver

2014-05-30 Thread Lee Jones
> +static const struct i2c_device_id intel_soc_pmic_i2c_id[] = { > +{"INT33FD:00", (kernel_ulong_t)&intel_soc_pmic_config_crc}, > +{ } > +}; > +MODULE_DEVICE_TABLE(i2c, intel_soc_pmic_i2c_id); > + > +static struct acpi_device_id intel_soc_pmic_acpi

Re: [PATCH v4 1/3] mfd: intel_soc_pmic: Core driver

2014-05-30 Thread Zhu, Lejun
On 2014/5/30 17:28, Lee Jones wrote: >> +static const struct i2c_device_id intel_soc_pmic_i2c_id[] = { >> +{"INT33FD:00", (kernel_ulong_t)&intel_soc_pmic_config_crc}, >> +{ } >> +}; >> +MODULE_DEVICE_TABLE(i2c, intel_soc_pmic_i2c_id); >> + >> +static st