Re: [PATCH v5 1/2] sched/rt: Clean up usage of rt_task()

2024-06-10 Thread Qais Yousef
On 06/05/24 16:07, Daniel Bristot de Oliveira wrote: > On 6/5/24 15:24, Qais Yousef wrote: > >>> But rt is a shortened version of realtime, and so it is making *it less* > >>> clear that we also have DL here. > >> Can SCHED_DL be considered a real-time scheduling class as in opposite > >> to SCHED_

Re: [PATCH v5 1/2] sched/rt: Clean up usage of rt_task()

2024-06-05 Thread Daniel Bristot de Oliveira
On 6/5/24 15:24, Qais Yousef wrote: >>> But rt is a shortened version of realtime, and so it is making *it less* >>> clear that we also have DL here. >> Can SCHED_DL be considered a real-time scheduling class as in opposite >> to SCHED_BATCH for instance? Due to its requirements it fits for a real

Re: [PATCH v5 1/2] sched/rt: Clean up usage of rt_task()

2024-06-05 Thread Qais Yousef
On 06/05/24 11:32, Sebastian Andrzej Siewior wrote: > On 2024-06-04 17:57:46 [+0200], Daniel Bristot de Oliveira wrote: > > On 6/4/24 16:42, Qais Yousef wrote: > > > - (wakeup_rt && !dl_task(p) && !rt_task(p)) || > > > + (wakeup_rt && !realtime_task(p)) || > > > > I do not like bikesheddin

Re: [PATCH v5 1/2] sched/rt: Clean up usage of rt_task()

2024-06-05 Thread Daniel Bristot de Oliveira
On 6/5/24 11:32, Sebastian Andrzej Siewior wrote: > On 2024-06-04 17:57:46 [+0200], Daniel Bristot de Oliveira wrote: >> On 6/4/24 16:42, Qais Yousef wrote: >>> - (wakeup_rt && !dl_task(p) && !rt_task(p)) || >>> + (wakeup_rt && !realtime_task(p)) || >> >> I do not like bikeshedding, and

Re: [PATCH v5 1/2] sched/rt: Clean up usage of rt_task()

2024-06-05 Thread Sebastian Andrzej Siewior
On 2024-06-04 17:57:46 [+0200], Daniel Bristot de Oliveira wrote: > On 6/4/24 16:42, Qais Yousef wrote: > > - (wakeup_rt && !dl_task(p) && !rt_task(p)) || > > + (wakeup_rt && !realtime_task(p)) || > > I do not like bikeshedding, and no hard feelings... > > But rt is a shortened versio

Re: [PATCH v5 1/2] sched/rt: Clean up usage of rt_task()

2024-06-04 Thread Daniel Bristot de Oliveira
On 6/4/24 18:37, Steven Rostedt wrote: > On Tue, 4 Jun 2024 17:57:46 +0200 > Daniel Bristot de Oliveira wrote: > >> On 6/4/24 16:42, Qais Yousef wrote: >>> - (wakeup_rt && !dl_task(p) && !rt_task(p)) || >>> + (wakeup_rt && !realtime_task(p)) || >> >> I do not like bikeshedding, and

Re: [PATCH v5 1/2] sched/rt: Clean up usage of rt_task()

2024-06-04 Thread Steven Rostedt
On Tue, 4 Jun 2024 17:57:46 +0200 Daniel Bristot de Oliveira wrote: > On 6/4/24 16:42, Qais Yousef wrote: > > - (wakeup_rt && !dl_task(p) && !rt_task(p)) || > > + (wakeup_rt && !realtime_task(p)) || > > I do not like bikeshedding, and no hard feelings... > > But rt is a shortened

Re: [PATCH v5 1/2] sched/rt: Clean up usage of rt_task()

2024-06-04 Thread Daniel Bristot de Oliveira
On 6/4/24 16:42, Qais Yousef wrote: > - (wakeup_rt && !dl_task(p) && !rt_task(p)) || > + (wakeup_rt && !realtime_task(p)) || I do not like bikeshedding, and no hard feelings... But rt is a shortened version of realtime, and so it is making *it less* clear that we also have DL here

[PATCH v5 1/2] sched/rt: Clean up usage of rt_task()

2024-06-04 Thread Qais Yousef
rt_task() checks if a task has RT priority. But depends on your dictionary, this could mean it belongs to RT class, or is a 'realtime' task, which includes RT and DL classes. Since this has caused some confusion already on discussion [1], it seemed a clean up is due. I define the usage of rt_task