Re: [RFC PATCH] x86: Use ACCESS_ONCE() for atomic_read()

2014-09-23 Thread Peter Zijlstra
On Tue, Sep 23, 2014 at 09:32:05AM -0400, Pranith Kumar wrote: > On Mon, Sep 22, 2014 at 4:07 PM, Peter Zijlstra wrote: > > On Mon, Sep 22, 2014 at 03:53:09PM -0400, Pranith Kumar wrote: > >> Use the much easier to read ACCESS_ONCE() which is basically the same > >> thing as > >> the cast to vola

Re: [RFC PATCH] x86: Use ACCESS_ONCE() for atomic_read()

2014-09-23 Thread Pranith Kumar
On Mon, Sep 22, 2014 at 4:07 PM, Peter Zijlstra wrote: > On Mon, Sep 22, 2014 at 03:53:09PM -0400, Pranith Kumar wrote: >> Use the much easier to read ACCESS_ONCE() which is basically the same thing >> as >> the cast to volatile. >> >> Please note the change in volatile cast: ACCESS_ONCE(v)->coun

Re: [RFC PATCH] x86: Use ACCESS_ONCE() for atomic_read()

2014-09-22 Thread Pranith Kumar
On Mon, Sep 22, 2014 at 4:07 PM, Peter Zijlstra wrote: > On Mon, Sep 22, 2014 at 03:53:09PM -0400, Pranith Kumar wrote: >> Use the much easier to read ACCESS_ONCE() which is basically the same thing >> as >> the cast to volatile. >> >> Please note the change in volatile cast: ACCESS_ONCE(v)->coun

Re: [RFC PATCH] x86: Use ACCESS_ONCE() for atomic_read()

2014-09-22 Thread Peter Zijlstra
On Mon, Sep 22, 2014 at 03:53:09PM -0400, Pranith Kumar wrote: > Use the much easier to read ACCESS_ONCE() which is basically the same thing as > the cast to volatile. > > Please note the change in volatile cast: ACCESS_ONCE(v)->counter to > ACCESS_ONCE(v->counter). > > Signed-off-by: Pranith Kum

[RFC PATCH] x86: Use ACCESS_ONCE() for atomic_read()

2014-09-22 Thread Pranith Kumar
Use the much easier to read ACCESS_ONCE() which is basically the same thing as the cast to volatile. Please note the change in volatile cast: ACCESS_ONCE(v)->counter to ACCESS_ONCE(v->counter). Signed-off-by: Pranith Kumar --- arch/x86/include/asm/atomic.h | 2 +- 1 file changed, 1 insertion(+)