Re: [SOUND] hda_intel: build fix

2007-03-13 Thread Ralf Baechle
> Ah, that's a nasty part of C const. It should be like > const struct snd_ice1712_card_info *c; > but for pointer-of-pointer, something like > struct snd_ice1712_card_info * const *tbl; Well, that works. Andrew, I'm going to post an updated patch in separate email. Ralf - To

Re: [SOUND] hda_intel: build fix

2007-03-13 Thread Ralf Baechle
Ah, that's a nasty part of C const. It should be like const struct snd_ice1712_card_info *c; but for pointer-of-pointer, something like struct snd_ice1712_card_info * const *tbl; Well, that works. Andrew, I'm going to post an updated patch in separate email. Ralf - To

Re: [SOUND] hda_intel: build fix

2007-03-12 Thread Takashi Iwai
At Mon, 12 Mar 2007 15:46:47 +, Ralf Baechle wrote: > > On Mon, Mar 12, 2007 at 03:43:10PM +0100, Takashi Iwai wrote: > > > Fair enough. I agree that removing const is the only reasonable fix > > right now. But from semantics, const is a good thing, and people may > > try to add it again

Re: [SOUND] hda_intel: build fix

2007-03-12 Thread Ralf Baechle
On Mon, Mar 12, 2007 at 03:43:10PM +0100, Takashi Iwai wrote: > Fair enough. I agree that removing const is the only reasonable fix > right now. But from semantics, const is a good thing, and people may > try to add it again later if we get rid of them now. So, how about to > comment out such

Re: [SOUND] hda_intel: build fix

2007-03-12 Thread Takashi Iwai
At Mon, 12 Mar 2007 13:53:51 +, Ralf Baechle wrote: > > On Mon, Mar 12, 2007 at 12:04:30PM +0100, Takashi Iwai wrote: > > > It's no big problem to remove const in these cases, but allowing const > > with __devinitdata seems the right fix to me... > > Gccs derives the readability of a

Re: [SOUND] hda_intel: build fix

2007-03-12 Thread Ralf Baechle
On Mon, Mar 12, 2007 at 12:04:30PM +0100, Takashi Iwai wrote: > It's no big problem to remove const in these cases, but allowing const > with __devinitdata seems the right fix to me... Gccs derives the readability of a section used with __attribute(section()) from the first use, which in case of

Re: [SOUND] hda_intel: build fix

2007-03-12 Thread Takashi Iwai
At Sat, 10 Mar 2007 19:05:13 +, Ralf Baechle wrote: > > CC [M] sound/pci/hda/hda_intel.o > sound/pci/hda/hda_intel.c:1508: error: position_fix_list causes a section > type conflict > > Gcc like its __devinitdata readable not const, it seems. An alternative > fix would be to remove the

Re: [SOUND] hda_intel: build fix

2007-03-12 Thread Takashi Iwai
At Sat, 10 Mar 2007 19:05:13 +, Ralf Baechle wrote: CC [M] sound/pci/hda/hda_intel.o sound/pci/hda/hda_intel.c:1508: error: position_fix_list causes a section type conflict Gcc like its __devinitdata readable not const, it seems. An alternative fix would be to remove the

Re: [SOUND] hda_intel: build fix

2007-03-12 Thread Ralf Baechle
On Mon, Mar 12, 2007 at 12:04:30PM +0100, Takashi Iwai wrote: It's no big problem to remove const in these cases, but allowing const with __devinitdata seems the right fix to me... Gccs derives the readability of a section used with __attribute(section()) from the first use, which in case of

Re: [SOUND] hda_intel: build fix

2007-03-12 Thread Takashi Iwai
At Mon, 12 Mar 2007 13:53:51 +, Ralf Baechle wrote: On Mon, Mar 12, 2007 at 12:04:30PM +0100, Takashi Iwai wrote: It's no big problem to remove const in these cases, but allowing const with __devinitdata seems the right fix to me... Gccs derives the readability of a section used

Re: [SOUND] hda_intel: build fix

2007-03-12 Thread Ralf Baechle
On Mon, Mar 12, 2007 at 03:43:10PM +0100, Takashi Iwai wrote: Fair enough. I agree that removing const is the only reasonable fix right now. But from semantics, const is a good thing, and people may try to add it again later if we get rid of them now. So, how about to comment out such as

Re: [SOUND] hda_intel: build fix

2007-03-12 Thread Takashi Iwai
At Mon, 12 Mar 2007 15:46:47 +, Ralf Baechle wrote: On Mon, Mar 12, 2007 at 03:43:10PM +0100, Takashi Iwai wrote: Fair enough. I agree that removing const is the only reasonable fix right now. But from semantics, const is a good thing, and people may try to add it again later if

[SOUND] hda_intel: build fix

2007-03-10 Thread Ralf Baechle
CC [M] sound/pci/hda/hda_intel.o sound/pci/hda/hda_intel.c:1508: error: position_fix_list causes a section type conflict Gcc like its __devinitdata readable not const, it seems. An alternative fix would be to remove the __devinitdata attribute but that would result in slight runtime bloat.

[SOUND] hda_intel: build fix

2007-03-10 Thread Ralf Baechle
CC [M] sound/pci/hda/hda_intel.o sound/pci/hda/hda_intel.c:1508: error: position_fix_list causes a section type conflict Gcc like its __devinitdata readable not const, it seems. An alternative fix would be to remove the __devinitdata attribute but that would result in slight runtime bloat.