Re: [patch 1/2] hugetlb: add resv argument to hugetlb_file_setup

2007-03-26 Thread Adam Litke
On Fri, 2007-03-23 at 15:42 -0700, Ken Chen wrote: > rename hugetlb_zero_setup() to hugetlb_file_setup() to better match > function name convention like shmem implementation. Also add an > argument to the function to indicate whether file setup should reserve > hugetlb page upfront or not. > >

Re: [patch 1/2] hugetlb: add resv argument to hugetlb_file_setup

2007-03-26 Thread Adam Litke
On Fri, 2007-03-23 at 15:42 -0700, Ken Chen wrote: rename hugetlb_zero_setup() to hugetlb_file_setup() to better match function name convention like shmem implementation. Also add an argument to the function to indicate whether file setup should reserve hugetlb page upfront or not.

Re: [patch 1/2] hugetlb: add resv argument to hugetlb_file_setup

2007-03-24 Thread Christoph Hellwig
On Fri, Mar 23, 2007 at 03:42:13PM -0700, Ken Chen wrote: > rename hugetlb_zero_setup() to hugetlb_file_setup() to better match > function name convention like shmem implementation. Also add an > argument to the function to indicate whether file setup should reserve > hugetlb page upfront or not.

Re: [patch 1/2] hugetlb: add resv argument to hugetlb_file_setup

2007-03-24 Thread Christoph Hellwig
On Fri, Mar 23, 2007 at 03:42:13PM -0700, Ken Chen wrote: rename hugetlb_zero_setup() to hugetlb_file_setup() to better match function name convention like shmem implementation. Also add an argument to the function to indicate whether file setup should reserve hugetlb page upfront or not. I

Re: [patch 1/2] hugetlb: add resv argument to hugetlb_file_setup

2007-03-23 Thread Jan Engelhardt
On Mar 23 2007 15:53, Ken Chen wrote: > > diff --git a/fs/hugetlbfs/inode.c b/fs/hugetlbfs/inode.c > index 8c718a3..981886f 100644 > --- a/fs/hugetlbfs/inode.c > +++ b/fs/hugetlbfs/inode.c > @@ -734,7 +734,7 @@ static int can_do_hugetlb_shm(void) > can_do_mlock()); > } > >

Re: [patch 1/2] hugetlb: add resv argument to hugetlb_file_setup

2007-03-23 Thread Ken Chen
On 3/23/07, Nish Aravamudan <[EMAIL PROTECTED]> wrote: Comment needs updating too. Thanks. How could I miss that :-( updated patch: diff --git a/fs/hugetlbfs/inode.c b/fs/hugetlbfs/inode.c index 8c718a3..981886f 100644 --- a/fs/hugetlbfs/inode.c +++ b/fs/hugetlbfs/inode.c @@ -734,7 +734,7

Re: [patch 1/2] hugetlb: add resv argument to hugetlb_file_setup

2007-03-23 Thread Nish Aravamudan
On 3/23/07, Ken Chen <[EMAIL PROTECTED]> wrote: rename hugetlb_zero_setup() to hugetlb_file_setup() to better match function name convention like shmem implementation. Also add an argument to the function to indicate whether file setup should reserve hugetlb page upfront or not. Signed-off-by:

[patch 1/2] hugetlb: add resv argument to hugetlb_file_setup

2007-03-23 Thread Ken Chen
rename hugetlb_zero_setup() to hugetlb_file_setup() to better match function name convention like shmem implementation. Also add an argument to the function to indicate whether file setup should reserve hugetlb page upfront or not. Signed-off-by: Ken Chen <[EMAIL PROTECTED]> diff --git

[patch 1/2] hugetlb: add resv argument to hugetlb_file_setup

2007-03-23 Thread Ken Chen
rename hugetlb_zero_setup() to hugetlb_file_setup() to better match function name convention like shmem implementation. Also add an argument to the function to indicate whether file setup should reserve hugetlb page upfront or not. Signed-off-by: Ken Chen [EMAIL PROTECTED] diff --git

Re: [patch 1/2] hugetlb: add resv argument to hugetlb_file_setup

2007-03-23 Thread Nish Aravamudan
On 3/23/07, Ken Chen [EMAIL PROTECTED] wrote: rename hugetlb_zero_setup() to hugetlb_file_setup() to better match function name convention like shmem implementation. Also add an argument to the function to indicate whether file setup should reserve hugetlb page upfront or not. Signed-off-by:

Re: [patch 1/2] hugetlb: add resv argument to hugetlb_file_setup

2007-03-23 Thread Ken Chen
On 3/23/07, Nish Aravamudan [EMAIL PROTECTED] wrote: Comment needs updating too. Thanks. How could I miss that :-( updated patch: diff --git a/fs/hugetlbfs/inode.c b/fs/hugetlbfs/inode.c index 8c718a3..981886f 100644 --- a/fs/hugetlbfs/inode.c +++ b/fs/hugetlbfs/inode.c @@ -734,7 +734,7 @@

Re: [patch 1/2] hugetlb: add resv argument to hugetlb_file_setup

2007-03-23 Thread Jan Engelhardt
On Mar 23 2007 15:53, Ken Chen wrote: diff --git a/fs/hugetlbfs/inode.c b/fs/hugetlbfs/inode.c index 8c718a3..981886f 100644 --- a/fs/hugetlbfs/inode.c +++ b/fs/hugetlbfs/inode.c @@ -734,7 +734,7 @@ static int can_do_hugetlb_shm(void) can_do_mlock()); } -struct