Re: [PATCH v4 1/2] arm: introduce psci_smp_ops

2013-04-02 Thread Stefano Stabellini
On Tue, 2 Apr 2013, Will Deacon wrote: > > diff --git a/arch/arm/include/asm/psci.h b/arch/arm/include/asm/psci.h > > index ce0dbe7..4134dda 100644 > > --- a/arch/arm/include/asm/psci.h > > +++ b/arch/arm/include/asm/psci.h > > @@ -32,5 +32,14 @@ struct psci_operations { > > }; > > > > extern

Re: [PATCH v4 1/2] arm: introduce psci_smp_ops

2013-04-02 Thread Will Deacon
Hi Stefano, On Fri, Mar 29, 2013 at 04:42:49PM +, Stefano Stabellini wrote: > Rename virt_smp_ops to psci_smp_ops and move them to > arch/arm/kernel/psci_smp.c. > Remove mach-virt/platsmp.c, now unused. > Compile psci_smp if CONFIG_ARM_PSCI and CONFIG_SMP. > > Add a cpu_die smp_op based on

Re: [PATCH v4 1/2] arm: introduce psci_smp_ops

2013-04-02 Thread Will Deacon
Hi Stefano, On Fri, Mar 29, 2013 at 04:42:49PM +, Stefano Stabellini wrote: Rename virt_smp_ops to psci_smp_ops and move them to arch/arm/kernel/psci_smp.c. Remove mach-virt/platsmp.c, now unused. Compile psci_smp if CONFIG_ARM_PSCI and CONFIG_SMP. Add a cpu_die smp_op based on

Re: [PATCH v4 1/2] arm: introduce psci_smp_ops

2013-04-02 Thread Stefano Stabellini
On Tue, 2 Apr 2013, Will Deacon wrote: diff --git a/arch/arm/include/asm/psci.h b/arch/arm/include/asm/psci.h index ce0dbe7..4134dda 100644 --- a/arch/arm/include/asm/psci.h +++ b/arch/arm/include/asm/psci.h @@ -32,5 +32,14 @@ struct psci_operations { }; extern struct

Re: [PATCH v4 1/2] arm: introduce psci_smp_ops

2013-03-29 Thread Rob Herring
On 03/29/2013 11:42 AM, Stefano Stabellini wrote: > Rename virt_smp_ops to psci_smp_ops and move them to > arch/arm/kernel/psci_smp.c. > Remove mach-virt/platsmp.c, now unused. > Compile psci_smp if CONFIG_ARM_PSCI and CONFIG_SMP. > > Add a cpu_die smp_op based on psci_ops.cpu_off. > >

Re: [PATCH v4 1/2] arm: introduce psci_smp_ops

2013-03-29 Thread Nicolas Pitre
On Fri, 29 Mar 2013, Stefano Stabellini wrote: > Rename virt_smp_ops to psci_smp_ops and move them to > arch/arm/kernel/psci_smp.c. > Remove mach-virt/platsmp.c, now unused. > Compile psci_smp if CONFIG_ARM_PSCI and CONFIG_SMP. > > Add a cpu_die smp_op based on psci_ops.cpu_off. > > Initialize

Re: [PATCH v4 1/2] arm: introduce psci_smp_ops

2013-03-29 Thread Nicolas Pitre
On Fri, 29 Mar 2013, Stefano Stabellini wrote: Rename virt_smp_ops to psci_smp_ops and move them to arch/arm/kernel/psci_smp.c. Remove mach-virt/platsmp.c, now unused. Compile psci_smp if CONFIG_ARM_PSCI and CONFIG_SMP. Add a cpu_die smp_op based on psci_ops.cpu_off. Initialize PSCI

Re: [PATCH v4 1/2] arm: introduce psci_smp_ops

2013-03-29 Thread Rob Herring
On 03/29/2013 11:42 AM, Stefano Stabellini wrote: Rename virt_smp_ops to psci_smp_ops and move them to arch/arm/kernel/psci_smp.c. Remove mach-virt/platsmp.c, now unused. Compile psci_smp if CONFIG_ARM_PSCI and CONFIG_SMP. Add a cpu_die smp_op based on psci_ops.cpu_off. Initialize PSCI